Announcement

Collapse
No announcement yet.

HS4 "compatible" Insteon Thermostat plug-in is available for beta test!

Collapse
This topic is closed.
X
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 "compatible" Insteon Thermostat plug-in is available for beta test!

    The update to the Insteon Thermostat to work under HS4 and with the MNS Insteon plug-in is now available for beta testing. It is available under Plug-ins -> Add in the HS4 plug-ins list.

    Important:
    1) There are NO feature changes;
    2) Requires Homeseer v4
    3) Requires MNS Insteon plugin version 4.0.3.3 or above
    4) This version IS NOT backwards compatible with the Insteon plug-in v3xxx; DO NOT replace your version 3.0.7.1 version if it is working for you


    Please post here with issues/comments. NOTE: the MNS Insteon plug-in must be functioning for the Insteon Thermostat to work -- if you run into issues, check the log and resolve issues with it before trying the thermostat.

    thanks for feedback -- john

    #2
    Thanks for taking this on John!
    Installed your 3.0.8.0 beta, running Mark's 4.0.3.3 MNS Insteon plugin, using HS4 4.2.12.0 on a HomeTroller Plus.

    Added two Insteon Thermostats 2441TH. Insteon IDs were easily found and units easily added to the plugin, then they showed up as devices in HS4.

    Couple of quick observations based on fairly limited playing around with the settings tonight - the physical thermostats and their corresponding entries in HS4 seem to be controlling each other reasonably well, but not 100% reflecting all changes every time. And room temps and humidity showing on the thermostat did not always show corresponding equal values in HS4. Tried various combinations of polling, disabling then renabling the plugin, closing and restarting HS4 on the HomeTroller Plus, and restarting the Plus Hub a couple of times. Some of those resets/restarts did seem to help. Haven't yet checked the logs, that'll come in the future when I have more time.

    I know this is still a very early beta release so there will be far more refining ahead, but without a doubt you're off to a fantastic start! Those of us (and I'm getting the feeling that's going to be a large number) with Insteon thermostats are very grateful for your efforts 😃.

    Comment


      #3
      Can you please clarify where I can find this,

      Thanks,

      George

      Comment


        #4
        HI George -- in HS4 click Plugins, then Add. On the plug-in list page, turn on "Show Beta Plugins". Insteon Thermostat is in the HS4 list of plug-ins (type "thermo" to search). Thx for testing it! John

        Comment


          #5
          msachs9393,
          Thx for testing. Please send logs when you can -- both Insteon Thermostat and MNS Insteon -- Mark and I will look at them. I'm testing against a wired thermo with humidity sensor (but no external sensor), and a wireless thermostat. But are working perfectly for me; please send any further info on duplicating your issues.

          best -- john

          Comment


            #6
            I have a Hometroller Plus with the HS4 insteon plug in installed and working. I uninstalled the old failed HS3 insteon thermostat plugin and attempted to install the new HS4 insteon thermostat plugin and got this message:

            "WARNING: Failed getting InterfaceStatus from Insteon Thermostat - the interface was not found in the list of active interfaces, the list may need to be refreshed."

            So thinking maybe that I needed to install the thermostat in the main insteon plugin I tried a manual device install and got:

            "The Insteon device at 39.3C.3D did not respond. Please check to make sure the address is correct and that the device is powered-up. The device was not registered."

            and from the log:

            "
            Error while connecting to Insteon plugin. It is running? Will try again in 10 seconds..."

            The thermostat is running as normal from the keypad and used to be controllable when the Insteon servers were still up.

            BTW, after the uninstall of the old HS3 tstat PI I still have " Insteon Thermostat Master Program" in my devices if that matters.

            What am I doing wrong? Thanks,

            George

            Comment


              #7
              Hi George,
              You need to register the thermostat in the Insteon Thermostat plugin (Config page, "Thermostats" tab) -- please remove all traces of any previous installation -- in the HS4 Devices page and anywhere else -- and send the log if it doesn't work. What *should* happen is the thermostat should show up in the HS4 Devices page. You should have a "Polling" button that sends messages to the MNS Insteon PI to get the mode, humidity (if equipped), temp, and set point for the current mode. You can also turn on Developer Mode in HS4 settings which will display the console pages of the two plug-ins -- you'll see the messages going between them.

              Hope this helps -- john

              Comment


                #8
                Uninstalled and reinstalled the tstat PI multiple times, tried to clean out all traces of the prior HS3 and HS4 tstat PI installs, same result as before. Uninstalled the MSN Insteon plugin and deleted all devices to completely start over and i could not get the HS4 MSN Insteon plugin to install. Upgraded the HT Pro software revision to 4.2.12.0. Now the MSN Insteon PI will download but it will not enable, the radio button will not move. Now my system has no insteon control. Latest log attached.

                George
                Attached Files

                Comment


                  #9
                  Suggest getting the MNS Insteon plugin and a few (non thermostat) devices working first -- then install the Insteon Thermostat plugin. Sorry this is so complex! The heart of the insteon support is the MNS Insteon plugin -- it supports pretty much all Insteon devices except the thermostats (recall that Insteon discontinued sales of the thermostat several years ago). Once you get basic Insteon functions working reliably, then add the Insteon Thermostat plugin and register your thermostat in it.

                  The Insteon Thermostat plugin relies on the MNS Insteon plugin to communicate with the Insteon hardware; MNS Insteon should be installed and enabled before enabling the Insteon Thermostat plugin. Unfortunately, thermostat support requires the beta versions of both plugins (4.0.3.3 or higher for MNS Insteon and 3.0.8.0 for Insteon Thermostat).

                  Hope that helps -- john.

                  Comment


                    #10
                    Had MSN Insteon 4.0.3.0 PI installed, all lighting devices registered, mobile MYHS & dashboard programed, all good

                    Added Insteon Thern for HS3, no dice, deleted it

                    Added HS4 Insteon thermostat PI beta 3.0.8.0, could not get the thermostat reporting or control to work

                    Deleted everything, both plug ins, all devices, recycled hub, purchased MSN Insteon PI, started over, reprogrammed everything, no joy

                    Saw comment that I needed the newer beta version of the MSN Insteon PI to work with the new Insteon thern PI, tried to update, no dice

                    Deleted both plugins, all devices, dashboard, recycled hub

                    Added newest 4.0.3.4 bets MSN Insteon PI, reprogrammed all devices, and dashboard, all working as before

                    Added Insteon therm PI beta 3.0.8.0, added therm in therm PI, shows up in HT Plus devices, not in MSN Insteon PI devices, still no control, and improper reporting

                    Therm status in therm PI states "Error rendering thermostat ..." same as all the way back to the beginning.

                    Log attached.

                    Any help is appreciated.

                    George
                    Attached Files

                    Comment


                      #11
                      George, do you have a wired thermostat as well as the wireless thermostat?

                      Comment


                        #12
                        The thermostat that I am trying to control here is an Inst wired therm running my HVAC system. I do also happen to have an Inst wireless therm that is not linked to the wired one (I dont think) and seperately controls some Insteon outletlincs for space heaters.

                        George

                        Comment


                          #13
                          OK -- from the logs I see Insteon ID 39.3C.3D is device "RF Thermostat" (which I presume is a wireless one). If possible, can you remove the wireless one and add the wired and let's see how that works (pls send log)? thx -- john

                          Comment


                            #14
                            The Insteon Therm I have been trying to add is 39.3C.3D and that is the wired one. I have never tried to involve the wireless one, which is 20.4B.5B.


                            George

                            Comment


                              #15
                              OK; got confused by the "RF" in the name -- no problem. What is the model number of the wired thermostat? For some reason, it is not being recognized by the IT plugin...

                              Comment

                              Working...
                              X