No announcement yet.

Can't get the T-Stat Plugin to recognize my Insteon Hub

  • Filter
  • Time
  • Show
Clear All
new posts

    Can't get the T-Stat Plugin to recognize my Insteon Hub

    I'm recently converting over from HA and when I installed the Insteon Plug-in it works fine but when I tried to install the Plugin for the Insteon Thermostats the Plug-in keeps saying "Initializing" so after I waited for over 30 mins I went ahead and went to "More" and "Config" and I see that its not finding my PLM/Hub Address. It does say the Plug-in is "registered"

    I have already deleted the plug-in and closed the program then reinstalled, but I still have the same issue.

    Is there a cashe that I need to delete after I delete the plug in and reinstall or is there a way to type in my Hub Address?

    I'm using an Inteon Hub...and a Home Troller Pro.

    Thanks for any help that anyone can provide.


    Hey Rick,
    Check to ensure you are using the MNS Insteon plugin latest beta and the Insteon Thermostat beta (in HS4 Plugin -> Add page, be sure to click to Show Betas). Go to the tstat plugin Config page, Thermostats tab, and enter your thermostat information and click Save. Then click "Update Links" to the right of your thermostat.

    If you're still having trouble after this, go back to the Config page and on the General tab, click all the "Log...." checkboxes and Save, then go to the Thermostat tab and click Update Links again -- finally, export the log to a file (HS4->Tools->Log) and upload it here. Note: be sure to turn off the "Log..." checkboxes once everything is resolved; you don't want to flood the Log file for no reason... john


      Evening Thanks John,

      As you know I installed my new HS4 thru a Home Troller pro. Put on my first plug-in (Insteon) and was up and running then the second Plug-in (Thermostat Insteon) but it would not recognize my Insteon Hub. So I tried uninstalling and reinstalling to no avail.

      So I scouted around in settings and next to the Main System it said "REGISTER"
      I thought that was complete but went through it again anyway due to the baner saying it Must Be Completed.

      Well after that now I'm a "Guest" and can't access any settings. No matter what I try to do it continues to log me on as a guest.

      I even deleted the account on the Cell phone app but after I re-registered...Yep I'm still only a guest. Any ideas?

      Maybe tell me how to start completely over again.

      I saw somewhere if I delete a config file that might restart from scratch? If that's true, the problem is I'm on a MAC and don't know how to access the files that would be on the HT Pro.

      Hope you can help.




        Don't start over -- I've hit that "Guest" problem also:
        1) in the browser, the URL should be something like http://[your IP address]:[your port]/default.html
        2) change the URL, replacing 'default.html' with 'register.html' -- this should bring up the HS4 registration page where you can enter your license key, etc.