Announcement

Collapse
No announcement yet.

Cannot add new thermostat

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot add new thermostat

    Hi,
    Thanks for creating this plugin for HS3. It was the very last thing I needed to be completely off of HS2.

    I installed the plugin, and I am stuck at the very first hurdle. Adding a new thermostat. No matter what I put in the field, I am presented with this error.

    [???,FFFFFFFF,-1]

  • #2
    This is definitely where documentation will come in handy.

    When you first install, go to PLUG-INS->Insteon Thermostat->Insteon Thermostat Config. Then select the Thermostats tab. I believe that's where you are.

    Initially there are no Thermostats. In the ADD box, type a new name and when you submit, a row is added to the table. You will see your thermostat name and below it will be what you are describing as an error message. That bracketed box is where the devcat (device category), firmware and protocol number are reported after communication is established.

    Enter the address for the insteon thermostat, for example: 1D.6E.22 This should be on a sticker on your thermostat, possibly inside or even on the back I've heard. Note that these are added one part at a time. There are three small text boxes so you'd enter 1D, next you'd enter 6E and finally you'd enter 22.

    Next you want to click Read Links. The act of clicking Read Links will cause your new thermostat's name and insteon address to registered with Mark's plugin and then communication can begin. A timer will kick off silently in the background and in 10 seconds, will attempt to refresh the thermostats tab. Assuming communication was established, that bracketed box will change to something like [050B,D,2]

    If it doesn't seem to be working, go to the General tab and check the Log Debug. Then back to the Thermostats tab and click Read Links again.

    Also, be sure to use the save button occasionally so you don't lose your config changes.

    Once the Read Links has worked, you'll be able to use the Write Links option. This will establish the necessary reporting links in the thermostat so it can report changes made to it locally (button presses etc.)
    HS 3.0.0.435 (PRO)
    Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
    Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
    Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
    http://www.kazteel.com/

    Comment


    • #3
      Thanks for the clarification. I finally did stumble across a way to get the thermostats installed. After I added them, and saved, I rebooted homeseer.

      I will go back and try the read links buttons again. I already have a bunch of new devices in homeseer for the thermostat, and the HVAC unit. As a quick test this morning, I was able to click ON for the fan, on both HVAC units. After hearing them come on, I clicked back to AUTO, and they both went back off.

      That proved it was communicating. However, I didn't prove the thermostats would transmit button press's and send that back to homeseer yet.

      I will get back to it later tonight, I ran into some other unrelated issues I needed to solve first.

      Comment

      Working...
      X