Announcement

Collapse
No announcement yet.

Change to Celsius

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • IanIreland
    replied
    Thank you

    Leave a comment:


  • nfrobertson
    replied
    The bounds and values used within the plugin for temp settings are just numbers. It's true that out of the box, the bounds values are quite large so more in line with F than C. You can update the bounds values on the Config page to C compliant values. Be sure to click the SAVE button when done.

    Temp 4 40
    Heat SP 4 40
    Cool SP 4 40
    Humidity 0 100 (well, 90 according to the doc)

    The 2441th specs are in the manual about page 22
    http://cache-m2.smarthome.com/manuals/2732-x32.pdf


    If you continue to run into issues please let me know and post the full debug log which you can find under HS3\Logs\InsteonThermostatDebug.log

    Nathan

    Leave a comment:


  • IanIreland
    replied
    Hi,

    I'm having issues with F/C.
    I use Celcius as I'm in the UK.
    The thermostat is set to Celcius. It is model 2732-432. and hard wired to a power supply. Plugin version 3.0.4.2
    If I poll the device the log shows the device, devcat = 0511, and has values in C, Temp = 18
    If I try to set the bounds or a program the values are in F and it won't accept values in C. "Trying to set heat below low bounds"

    How can I get everything to be C?

    Leave a comment:


  • nfrobertson
    replied
    I assume you are still using batteries for the thermostat? You are going to have to overcome its natural tendency to "go to sleep". I highly recommend you get a 5V external power supply, at least for this initial setup and testing. I use the apple 5v iphone square wall plug and a USB cable stripped at one end for this. Works great.

    Leave a comment:


  • ez1976
    replied
    after stopping and starting the plugin we are back to the plugin not recognize the thermostat

    Leave a comment:


  • ez1976
    replied
    yes of course
    let me run a clean debug log for you and send it your way

    Leave a comment:


  • nfrobertson
    replied
    Well the good news is we now know the thermostat is talking to the plugin.

    Can you provide the detailed debug log from C:\Program Files (x86)\HomeSeer HS3\Logs\InsteonThermostatDebug.log

    Did you let it run for a while (minutes/hour) so natural temp updates come in?

    Leave a comment:


  • ez1976
    replied
    Hi
    well i deleted the thermostat and re-registered it.
    this time it came up like this
    Childrens Thermostat
    [050A,D,2]


    but still everything is in Fahrenheit

    Leave a comment:


  • nfrobertson
    replied
    Good deal. I would suggest first you go into the web config page thermostats tab, then press the time/sensor on the 2441ZTH and then press the update links button on the config page. Every few seconds press that time/sensor to keep the 2441ZTH awake.

    I highly recommend the external power source option, at least for initial setup, but for long term use also.

    For longer term use on batteries, you will be able to get values from the thermostat as it detects changes in temp/humidity and any manual setpoint changes but you won't have the ability to send setpoint changes or any other commands to it due to this sleep mode. I wish there was a way to turn it off but there isn't. Using the external power option is the only way to make this thermostat fully functional.

    Leave a comment:


  • ez1976
    replied
    that is correct on the battery issue.
    i will later tonight push the button all the time and see if it can recognize it.

    if it changes to Celsius we are good to go.


    i will update later
    thanks

    Leave a comment:


  • nfrobertson
    replied
    The fan mode on the thermostat is either Auto or On. In auto mode the HVAC hardware (not virtual in plug-in) turns on the fan when call for cool/heat is made but the Fan mode in the plug-in remains showing as Auto. Unfortunately I'm guessing this doesn't give you the control you'd want to turn a ceiling fan on/off along with the thermostat.

    A better option is probably to track the device value of the HVAC Mode in the plug-in. When the thermostat calls for either cool or heat, the HVAC Mode device will change state to that value. You could setup a HomeSeer event based on the HVAC mode value change and use that to control a FanLinc like you suggest.

    Back to your wireless 2441ZTH. Are you using this on batteries? Assuming so, there is a known behavior with this specific thermostat that it "goes to sleep" and will not accept commands from external sources. It does this to conserve battery power. There's a thread under the Sage plugin for HS2 where both Tom and I have posted. If possible, using an external power source is the best option, especially during initial setup. What I have found to be the best is one of the small Apple 5V wall transformer plugs for an iPhone (genuine Apple, not sure about knock offs) and a USB cable. Cut the opposite end off the USB cable and you have the +/- connections to use for your 5V external power source for the thermostat. The 2441ZTH seems very picky about the input voltage, too high or low and you can get a very jumpy (rapid changing) humidity reading or if using the external sensor, bad readings from it.

    As a work around if you are using batteries, Tom would push the time/sensor button every few seconds to keep the 2441ZTH awake. This is critically important during the initial link setup where the plugin has to link the PLM and the 2441ZTH together for status reporting.

    I'm guessing you are using this on batteries and that likely explains why in the log we see the send Insteon commands but no reply and the config page shows [???,FFFFFFFF,] instead of valid values.

    Leave a comment:


  • ez1976
    replied
    Thanks
    i re-register the device and let see if it will register it.


    say, can i link the fan mode to a fanlinc? that way i can play around with the ceiling fan?

    Leave a comment:


  • nfrobertson
    replied
    The help documentation for this plug-in has been on my TODO list for a while now. I've pulled together a first rough draft that you can access online HERE

    http://www.kazteel.com/HomeSeer3/Ins...stat_help.html

    If you would rather pull this help down to your system and read it then you can pull down the zip file with it online HERE

    http://www.kazteel.com/HomeSeer3/Ins...THERMOSTAT.zip

    Please review the config section. Make sure you did not register the thermostat inside Mark's Insteon plugin. If you did you will need to delete it from his plugin.

    Leave a comment:


  • ez1976
    replied
    OK
    so how can i make him find out what device is the thermostat?
    it did recognize it when i binded it to the homeseer.
    and it does display the temperature so it is talking to it.

    Leave a comment:


  • nfrobertson
    replied
    The config page info tells me that it hasn't figured out what device category and firmware your thermostat is yet. Without that it can't tell what type of thermostat it's talking to.

    [???,FFFFFFFF,2]

    The snip of your log below shows the commands to determine devcat and firmware were sent out (the 2 transmit commands) but I don't see their reply. Is this as far as the plugin got? Did you leave it running for a while?
    14/06/2014 12:35:57 ~ Insteon Thermostat ~ INFO ~ Insteon PLM address = 1E.CB.3E
    14/06/2014 12:36:03 ~ Insteon Thermostat ~ INFO ~ Registered Insteon Thermostat Children's Large Room with address: 20.4B.B0
    14/06/2014 12:36:03 ~ Insteon Thermostat ~ TEST ~ Request protocol and devcat for Children's Large Room
    14/06/2014 12:36:03 ~ Insteon Thermostat ~ DEBUG ~ TransmitInsteon: [Children's Large Room] [0F] [0D] [00]
    14/06/2014 12:36:03 ~ Insteon Thermostat ~ DEBUG ~ TransmitInsteon: [Children's Large Room] [0F] [10] [00]
    14/06/2014 12:36:35 ~ Insteon Thermostat ~ INFO ~ Children's Large Room protocol = 2
    Here's an example from my dev system where I've started up the v3.0.0.9 plugin talking to one wireless 2441ZTH. You can see once the response from the first two commands comes back that it then polls for additional information and that's where the Celsius bug came up. I still have this 2441ZTH in Celsius mode

    6/14/2014 1:01:24 PM ~ Insteon Thermostat ~ INFO ~ Insteon PLM address = 23.9A.FC
    6/14/2014 1:01:26 PM ~ Insteon Thermostat ~ DEBUG ~ Initializing...
    6/14/2014 1:01:26 PM ~ Insteon Thermostat ~ INFO ~ Registered Insteon Thermostat Wireless with address: 22.0E.C9
    6/14/2014 1:01:26 PM ~ Insteon Thermostat ~ TEST ~ Request protocol and devcat for Wireless
    6/14/2014 1:01:26 PM ~ Insteon Thermostat ~ DEBUG ~ TransmitInsteon: [Wireless] [0F] [0D] [00]
    6/14/2014 1:01:26 PM ~ Insteon Thermostat ~ DEBUG ~ TransmitInsteon: [Wireless] [0F] [10] [00]
    6/14/2014 1:01:26 PM ~ Insteon Thermostat ~ INFO ~ Wireless protocol = 2
    6/14/2014 1:01:27 PM ~ Insteon Thermostat ~ INFO ~ Wireless devcat = 050A
    6/14/2014 1:01:27 PM ~ Insteon Thermostat ~ INFO ~ Wireless version = D
    6/14/2014 1:01:27 PM ~ Insteon Thermostat ~ DEBUG ~ TransmitInsteon: [Wireless] [1F] [2E] [00] ((([00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00])))
    6/14/2014 1:01:30 PM ~ Insteon Thermostat ~ DEBUG ~ TransmitInsteon: [Wireless] [1F] [2E] [00] ((([00] [00] [09] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00])))
    6/14/2014 1:01:33 PM ~ Insteon Thermostat ~ DEBUG ~ Thermostat reports: Button Beep DISABLED
    6/14/2014 1:01:33 PM ~ Insteon Thermostat ~ DEBUG ~ Thermostat reports: Temp Format = Celsius
    6/14/2014 1:01:33 PM ~ Insteon Thermostat ~ DEBUG ~ Using Temp Format = Celsius
    6/14/2014 1:01:33 PM ~ Insteon Thermostat ~ INFO ~ Wireless Temp = 26
    6/14/2014 1:01:33 PM ~ Insteon Thermostat ~ INFO ~ Wireless Ext.Temp = 22
    6/14/2014 1:01:33 PM ~ Insteon Thermostat ~ INFO ~ Wireless Humidity = 19
    6/14/2014 1:01:33 PM ~ Insteon Thermostat ~ INFO ~ Wireless Battery level = 4

    Leave a comment:

Working...
X