Announcement

Collapse
No announcement yet.

Questions about plugin handling of various modes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Questions about plugin handling of various modes


  • #2
    Any 2441TH fans out there with answers?

    Comment


    • #3
      The 2441TH supports the following modes: Off, Heat, Cool, Auto, Program. I believe the 'time of day' you refer to is the Program mode.

      The Program-Heat and Program-Cool are modes only supported by the Venstar thermostats. They are not applicable to the 2441TH.

      Please don't confuse the 2441TH thermostat hardware Program (time of day) mode with the "Programs" and "Hold/Run" inside the plugin. They are separate concepts.

      The plugin can send a message to the 2441TH to switch to it's hardware Program (time of day) mode but has no other ability to interact with settings of that mode on the thermostat. Any programming for that mode has to be done on the thermostat itself and the plugin has no knowledge of it. The insteon protocol between the plugin and thermostat doesn't provide for this information.

      You are correct on the energy/leaf button. There isn't anything in the protocol I'm aware of to engage that mode. It appears to be hardware side only.

      Hopefully this helps

      Nathan
      HS 3.0.0.435 (PRO)
      Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
      Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
      Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
      http://www.kazteel.com/

      Comment


      • #4
        Nathan,

        Thanks for clarifying.

        What is the effect in the plugin of setting Program to 'None'? What actions does it take?

        Comment


        • #5
          At my physical 2441TH, the mode is normally set to Program (time of day) and the fan is set to 'Always'.

          In the plugin, I have an event where I set Program to 'Prog-1', then set to 'Hold'.

          Here's what I notice at the physical 2441TH:
          1- Unexpectedly, the fan turns off; normal?
          2- The mode still shows 'Auto', but the current program icon (sleep, wake, leave, return) on the right side of the display disappears, which makes me think it's no more in Program mode (time of day programming), but rather simple 'Auto'; correct assessment? This would suggest that sending a 'Hold' from the plugin simply switches the 2441TH from Program (time of day) to Auto
          3- The display has changed the high/low set points to 'Prog-1'; good
          4- 'Hold' does not appear on the display as it does when I manually press the 'Hold' button; normal?

          I then have another event where I set to 'Run', then set mode to 'Program'

          Here's what I notice at the physical 2441TH:
          1- The fan remains off
          2- The current program icon (sleep, wake, leave, return) on the right side of the display reappears, so the 2441TH is back in Program (time of day) mode; good
          3- The display still shows the high/low set points of 'Prog-1'; I guess the next change of program (sleep, wake, leave, return) will override those setpoints; right?

          Comment


          • #6
            Nathan,

            Why is it that even though I specifically set the fan to On, it seems the plugin overrides that with 'Auto' ?


            Nov-04 18:22:35 Event Event Trigger "[NOT USED] CVtests CVtest Tstat - All away: set Alarm & Tstat hold on Sleep"
            Nov-04 18:22:35 Device Control Device: Thermostats Insteon 2441TH Program to Eco mode (1)
            Nov-04 18:22:35 Device Control Device: Thermostats Insteon 2441TH Hold/run to Hold (1)
            Nov-04 18:22:35 Device Control Device: Thermostats Insteon 2441TH Fan to On (1)
            Nov-04 18:22:35 Insteon Thermostat SetProgram: [2441TH] [Eco mode]
            Nov-04 18:22:35 Insteon Thermostat SetMode: 2441TH Mode = Auto
            Nov-04 18:22:48 Insteon Thermostat 2441TH [03] Mode=Auto Fan=Auto

            Comment


            • #7
              The program and run/hold features in the plugin are virtual plugin features and do not correspond to the thermostat hardware program mode (of 2441TH) or the program, program-heat, program-cool (of venstar). These are completely separate concepts and you don't want to intermix the two.

              The program and run/hold in the plugin are virtual plugin only operations. They allow you to define virtual programs in the plugin that will set the mode/fan/heat/cool etc. of your thermostat without having to program the thermostat hardware "program" modes locally on each thermostat. You then use HS3 events to turn on/off your virtual plugin programs and possible use the run/hold as a bypass mechanism (i.e Hold current settings and disregard any virtual program changes requested)

              You are, of course, free to use the thermostat hardware program mode. The plugin can send a Mode command to set the 2441th to "Mode=Program" and you will get the stay/leave etc. (i.e. the hardware program mode) turned on.

              This HS3 plugin was modeled after the HS2 plugin and this is how that one worked. It tries to provide a virtual program, run/hold, handling purely within the plugin, not relying on specific hardware features. I'm sorry if this seems confusing and I do understand how it can be.

              Nathan
              HS 3.0.0.435 (PRO)
              Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
              Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
              Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
              http://www.kazteel.com/

              Comment


              • #8
                Nathan,

                Thanks for the explanations. That with some testing gives me a clear picture to what I need to do now.

                I do run the hardware programs on the 2441TH. What I wanted to do is this: when all conditions are right and nobody home, have the plugin override the 2441TH with a (virtual) program with relaxed set points. And when at least one person is back home, have the plugin put the 2441TH back on its hardware programs.

                Just to complete my 'training', could you answer these last questions:
                1- What is the effect in the plugin of setting Program to 'None'? What actions does it take (cmds sent to the 2441TH)? When would this be useful?
                2- Can you make sense of this previous post of mine?

                Comment


                • #9
                  Originally posted by claude View Post
                  Nathan,
                  Just to complete my 'training', could you answer these last questions:
                  1- What is the effect in the plugin of setting Program to 'None'? What actions does it take (cmds sent to the 2441TH)? When would this be useful?
                  The Program=None in the plugin means no virtual programs are in use. It sends no commands to the thermostat. If you had a virtual program set and then set Program=None it will basically leave the thermostat as-is.

                  To achieve what I think you are wanting to do:

                  Switch to thermostat hardware Program:
                  • Set Program=None (turn off virtual program in plugin)
                  • Set Mode=Program (sends command to thermostat to set to hardware program mode)

                  Switch to plugin virtual Program:
                  • Set Program=YourProgramName

                  In the definition of your virtual Program in the plugin, make sure you have selected a valid Mode (Off/Auto/Heat/Cool) and other settings for Fan and/or Heat an/or Cool. You are now using a virtual Program in the plugin and the thermostat is switched to a Mode that is something other than the hardware Program Mode.


                  Be careful of the use of Run/Hold in the plugin. That applies only to the virtual programs in the plugin and if you set to Hold will basically prevent the program settings from taking effect.


                  Originally posted by claude View Post
                  2- Can you make sense of this previous post of mine?
                  In your other post example, you had set the thermostat to Mode=Program (the thermostat hardware program mode) and Fan=On but then turned around and enabled a virtual plugin Program which switched the Mode=Auto and it's unclear if that caused a change to the Fan setting but may have. The last log line is a status message from the thermostat coming back to the plugin.

                  The easiest fix here is to make sure in your virtual plugin Program named "Eco mode" that you select the Fan setting as On (instead of Auto or Don't Set)


                  Hope this helps.


                  Nathan
                  HS 3.0.0.435 (PRO)
                  Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
                  Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
                  Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
                  http://www.kazteel.com/

                  Comment


                  • #10
                    I've got pretty well everything under control, except the fan.

                    Nov-05 16:01:30 Event Event [NOT USED] CVtests CVtest Tstat - All away: set Tstat on Eco triggered by the event page 'Run' button.
                    Nov-05 16:01:30 Event Event Trigger "[NOT USED] CVtests CVtest Tstat - All away: set Tstat on Eco"
                    Nov-05 16:01:30 Device Control Device: Thermostats Insteon 2441TH Program to Eco mode (1)
                    Nov-05 16:01:30 Insteon Thermostat SetProgram: [2441TH] [Eco mode]
                    Nov-05 16:01:30 Insteon Thermostat SetMode: 2441TH Mode = Auto
                    Nov-05 16:01:30 Insteon Thermostat TransmitInsteon: [2441TH] [1F] [6B] [06] ((([00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [8F])))
                    Nov-05 16:01:33 Insteon Thermostat SetFanOn: 2441TH Fan = On no change so skipping device update
                    Nov-05 16:01:36 Insteon Thermostat SetHeatSetpoint: 2441TH set heat setpoint to 18 Current heat setpoint = 16 Current cool setpoint = 23
                    Nov-05 16:01:36 Insteon Thermostat SetHeatSetpoint: 2441TH Heat SetPoint = 18
                    Nov-05 16:01:36 Insteon Thermostat TransmitInsteon: [2441TH] [1F] [6D] [24] ((([00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [6F])))
                    Nov-05 16:01:39 Insteon Thermostat SetCoolSetpoint: 2441TH set cool setpoint to 25 Current cool setpoint = 23 Current heat setpoint = 18
                    Nov-05 16:01:39 Insteon Thermostat SetCoolSetpoint: 2441TH Cool SetPoint = 25
                    Nov-05 16:01:39 Insteon Thermostat TransmitInsteon: [2441TH] [1F] [6C] [32] ((([00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [00] [62])))
                    Nov-05 16:01:42 Insteon Thermostat 2441TH [03] Mode=Auto Fan=Auto


                    As soon as I manually initiated event "All away: set Tstat on Eco", the fan actually stops. The debug logs eventually confirms that.

                    Any thoughts?
                    Attached Files

                    Comment


                    • #11
                      Follow up on previous post

                      Hi Nathan,

                      I'm using a combination of 2441TH hardware programs and a Plugin virtual program.

                      I defined within the plugin a program, 'Eco', with these characteristics:
                      Mode = auto
                      Fan = On

                      After more testing, here's what I have found.

                      Case 1
                      Previous 2441TH hardware state: mode = auto, fan = On
                      Action: within the plugin, set program to 'Eco'
                      2441TH hardware resulting state: mode = auto, fan = On

                      Case 2
                      Previous 2441TH hardware state: mode = program, fan = On
                      Action: within the plugin, set program to 'Eco'
                      2441TH hardware resulting state: mode = auto, fan = Off

                      It seems that when the plugin changes the mode of the 2441TH, a side effect is that the fan is reset to Auto even though the plugin program is set to Fan = On. No such issue if the 2441TH is already in Mode = auto.

                      I tried compensating for this behavior by adding to the event a 'set fan ON', even with a delay of 10 seconds, but the log shows that the plugin ignores that command because it thinks the fan is still On.

                      I also realize that the plugin breaks down the event command into individual 2441TH commands sent to the 2441TH at 3 seconds intervals. It appears that only after all those 'sub-commands' are sent does the plugin receive, or is made aware of, the actual 2441TH state.

                      Nov-07 14:53:21 Insteon Thermostat SetFanOn: 2441TH Fan = On no change so skipping device update
                      Nov-07 14:53:21 Insteon Thermostat 2441TH [03] Mode=Auto Fan=Auto


                      So, two anomalies from my perspective:
                      1- Changing the 2441TH mode (program to auto) should not affect the fan's mode
                      2- Knowing the actual state of the 2441TH only after processing all 'sub-commands'

                      What do you think?

                      Comment


                      • #12
                        Excellent testing Claude. I also tested with my 2441th and found that indeed if the thermostat is in Program Mode with FanOn and the Mode is changed by the plugin, then the fan is defaulting back to Auto. I compared this to using the 2441th manually and Program/FanOn switching the mode does not turn the fan off.

                        I have posted plugin 3.0.3.7 but it's not in the regular updater stream yet. You can install to your HS3 directory an updater_override.txt which you can get at the link below. This will allow you to use the Manage page to download 3.0.3.7. Be sure to remove or rename the updater_override.txt afterwards so it doesn't block other updates for you.

                        http://www.kazteel.com/HomeSeer3/dev...r_override.txt

                        This 3.0.3.7 version overrides the normal skipping logic and forces the commands to be sent so if you switch to your Eco program and that includes a Fan On setting, then it will send the Fan On after the Mode command. Let's see if this helps with what you are trying to do

                        Nathan
                        HS 3.0.0.435 (PRO)
                        Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
                        Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
                        Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
                        http://www.kazteel.com/

                        Comment


                        • #13
                          Hi Nathan,

                          Can't get to http://www.kazteel.com/HomeSeer3/dev...r_override.txt

                          EDIT As I found in another thread, it should be http://www.kazteel.com/HomeSeer3/dev/updater_override.txt
                          Last edited by claude; November 8th, 2015, 03:40 PM.

                          Comment


                          • #14
                            Sorry Claude. Copy/paste issue. Glad you found the correct link.

                            http://www.kazteel.com/HomeSeer3/dev...r_override.txt
                            HS 3.0.0.435 (PRO)
                            Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
                            Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
                            Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
                            http://www.kazteel.com/

                            Comment


                            • #15
                              Originally posted by nfrobertson View Post
                              ... This 3.0.3.7 version overrides the normal skipping logic and forces the commands to be sent so if you switch to your Eco program and that includes a Fan On setting, then it will send the Fan On after the Mode command ...
                              Activating a virtual program defined with Mode = Auto and Fan = On while the 2441TH mode is on Program still turns off the fan (briefly), but the next sub-command of the virtual program to turn on the fan effectively works. The net result is what I expected. Thanks.

                              Strange though that a controller sending a sub-command to switch the 2441TH from Program to Auto would trigger the 2441TH to turn off the fan... firmware glitch?

                              Comment

                              Working...
                              X