Announcement

Collapse
No announcement yet.

Rebuild Homeseer devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • thetaz01
    replied
    Originally posted by nfrobertson View Post
    You have done the correct steps. Delete the old thermostat name from the Config page and Save. Then go to the Home (devices) list in HS3 and if any HS3 devices exist for the old Thermostat name, delete those. Finally, add the new thermostat name which will cause the plugin to create new HS3 devices. Be sure to save after you add the new thermostat.

    Under PLUG-INS->Manage you may wish to check the Developer Mode and then stop and start the plugin again. This will launch a DOS window with only the plugin log messages. That can be useful when you're trying to troubleshoot a startup or device issue. You should see it read the INI file and look for the existing devices. Be sure to turn Developer Mode back off so next time you start HS3 you don't get a bunch of command prompts from all your plugins.

    Nathan

    Thanks for your help..
    Was able fully remove and re-add once more, and it worked that time, maybe I forgot to click save, Which is very possible.. LOL
    thanks so much
    Fred

    Leave a comment:


  • nfrobertson
    replied
    You have done the correct steps. Delete the old thermostat name from the Config page and Save. Then go to the Home (devices) list in HS3 and if any HS3 devices exist for the old Thermostat name, delete those. Finally, add the new thermostat name which will cause the plugin to create new HS3 devices. Be sure to save after you add the new thermostat.

    Under PLUG-INS->Manage you may wish to check the Developer Mode and then stop and start the plugin again. This will launch a DOS window with only the plugin log messages. That can be useful when you're trying to troubleshoot a startup or device issue. You should see it read the INI file and look for the existing devices. Be sure to turn Developer Mode back off so next time you start HS3 you don't get a bunch of command prompts from all your plugins.

    Nathan

    Leave a comment:


  • thetaz01
    replied
    I turned on debug logging and got this piece of info..
    Seems somehow the insteon plug in thinks the devices exist..
    however I do not see them,..
    and I did get an error as well..

    This Thermostat used to be different I deleted it and re-added it with a new name

    Oct-21 5:58:53 PM Insteon Thermostat Found existing TSTAT HUMIDITY device for: Game Room
    Oct-21 5:58:52 PM Error Posting back to plugin web page Insteon_Thermostat_Config: Object reference not set to an instance of an object.-> at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.PostBackProc(String page, String data, String user, Int32 userRights) at Scheduler.proxyPage.postBackProc(StateObject& state, String Data)
    Oct-21 5:58:52 PM Insteon Thermostat Found existing TSTAT TEMP device for: Game Room
    Oct-21 5:58:51 PM Insteon Thermostat Found existing TSTAT COOL device for: Game Room
    Oct-21 5:58:50 PM Insteon Thermostat Found existing TSTAT HEAT device for: Game Room
    Oct-21 5:58:49 PM Insteon Thermostat Found existing TSTAT HOLD device for: Game Room
    Oct-21 5:58:48 PM Insteon Thermostat Found existing TSTAT FAN device for: Game Room
    Oct-21 5:58:47 PM Insteon Thermostat Found existing TSTAT MODE device for: Game Room
    Oct-21 5:58:46 PM Insteon Thermostat Found existing TSTAT PROGRAM device for: Game Room

    Leave a comment:


  • thetaz01
    replied
    Originally posted by nfrobertson View Post
    Every time the plugin starts up it will check for HS3 devices that match those Thermostats that are defined and if it doesn't find a device it will be created.

    Nathan
    Nathan,
    so I posted this in a different topic but this might be better since its RIGHT on topic..

    I never heard back from you regarding renaming a thermostat to change the location in the name.. (i.e. Fred Jrs Bedroom to Store Room)
    I decided to just delete that thermostat in the plug in, and re-add it..
    it worked fine, however I cant get the damn devices to re-create as homeseer devices..
    I have tried reading links, restarting the plugin, and restarting the entire homeseer application...
    I still cant get the homeseer devices to re-add..
    So with that.. I ask two questions ...actually three...
    1) What is the official PROPER process to add/readd a thermostat...
    2) how do I fix this current one?
    3) IS THERE in fact a way to rename a thermostat without deleting and re-adding

    Thanks so much
    Fred

    Leave a comment:


  • jpape
    replied
    Thanks Nathan.


    Sent from my iPad using Tapatalk

    Leave a comment:


  • nfrobertson
    replied
    Every time the plugin starts up it will check for HS3 devices that match those Thermostats that are defined and if it doesn't find a device it will be created.

    Nathan

    Leave a comment:


  • jpape
    started a topic Rebuild Homeseer devices

    Rebuild Homeseer devices

    Is there a way to have the plugin rebuild the Homeseer devices or is it as simple as deleting and re-adding a thermostat?
Working...
X