Announcement

Collapse
No announcement yet.

Can't add thermostats

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jon102034050
    replied
    Originally posted by nfrobertson View Post
    Changes in mode or set points are sent as they happen. Changes in temp or humidity have a threshold like the 2 degrees for temp before they are sent. You should be able to create events based on status changes yes. You will need to observe your particular thermostat to see how it behaves.

    Nathan


    Sent from my iPhone using Tapatalk
    Thank you very much Nathan, I appreciate the support. I'm going to add a few of my other thermostats the new few days and see how they do.

    Leave a comment:


  • nfrobertson
    replied
    Changes in mode or set points are sent as they happen. Changes in temp or humidity have a threshold like the 2 degrees for temp before they are sent. You should be able to create events based on status changes yes. You will need to observe your particular thermostat to see how it behaves.

    Nathan


    Sent from my iPhone using Tapatalk

    Leave a comment:


  • jon102034050
    replied
    Originally posted by nfrobertson View Post
    The thermostat has to send an update to the plugin. It does that usually when there's a 2 degree change. That can make it seem to change slowly.

    Nathan


    Sent from my iPhone using Tapatalk
    Good to know. Does the thermostat push things real time (other than temperature)? I'd like to know if I can reliably create events based off of the changes on the device statuses.

    Thanks

    Leave a comment:


  • nfrobertson
    replied
    The thermostat has to send an update to the plugin. It does that usually when there's a 2 degree change. That can make it seem to change slowly.

    Nathan


    Sent from my iPhone using Tapatalk

    Leave a comment:


  • jon102034050
    replied
    Great, thanks! Any thoughts on why my thermostat isn't updating the temperature? It updates things like mode, fan, and heat set point when I manually change them, but temp doesn't seem too be updating.

    Sent from my SM-G930V using Tapatalk

    Leave a comment:


  • nfrobertson
    replied
    Yes. You can rename the devices. Internally the plugin will still think of them as fan or mode etc but you can give them different names if you want.

    It sounds like you figured out that you add the thermostat via this plugin and not directly with Marks plugin.

    Nathan


    Sent from my iPhone using Tapatalk

    Leave a comment:


  • jon102034050
    replied
    Originally posted by jon102034050 View Post
    Alright, I'm back to this plugin again. I really did like my Insteon thermostats better than my zwave ones, so here I am... I've been able to successfully add a thermostat to the plugin, but it doesn't appear to create a HomeSeer device. Also, I don't see the Thermostat is my "Manage Devices" from Mark's Insteon plugin configuration page.

    Any thoughts? Nothing that I can see looks too concerning in the logs
    Nevermind, I did find the devices that this plugin created, I just assumed they would be named the same as the device that I added from within the plugin. This was obviously incorrect as it appeared to name them like this: "Insteon Thermostats Heating" and "Insteon Thermostats Fan". Is it OK to rename these HS devices?

    Leave a comment:


  • jon102034050
    replied
    Alright, I'm back to this plugin again. I really did like my Insteon thermostats better than my zwave ones, so here I am... I've been able to successfully add a thermostat to the plugin, but it doesn't appear to create a HomeSeer device. Also, I don't see the Thermostat is my "Manage Devices" from Mark's Insteon plugin configuration page.

    Any thoughts? Nothing that I can see looks too concerning in the logs

    Leave a comment:


  • jon102034050
    replied
    thanks for the reply - I decided to go a different way with my thermostats. I was having way too many issues with insteon on my HS, so I canned all of my insteon devices and thermostats, and am just going straight zwave.

    Regards,
    Jon

    Leave a comment:


  • nfrobertson
    replied
    Hello,

    Sorry for the delay in reply, I've been away traveling and am now back.

    If you are using a trial license and it has run out, I believe you can submit a helpdesk ticket to homeseer to reset your trial period. They control the licensing mechanism.

    Are you using both Mark Sandler's Insteon plugin as well as my Insteon Thermostat plugin? Both are required. Mark's plugin is the primary interface to the Insteon PLM or Hub and supports loads of devices. My plugin registers Insteon thermostats as external devices to Mark's plugin and provides all the specific thermostat handling support.

    The instructions in that post are a bit out-dated. Look under PLUG-INS -> Insteon Thermostat -> Insteon Thermostat Help which should open a new tab in your browser and show the included help documentation.

    Basically, once you have Mark's plugin providing communication to your PLM or Hub you can then use this Insteon Thermostat plugin to add a new Thermostat as an external device. There will be a button on the Thermostats tab to Register... and after clicking that and waiting a bit, if all is working, your Thermostat will query and receive the DEVCAT (device category) protocol and firmware information from your thermostat and show that in brackets under the Thermostat name on the Thermostats tab. That process can take a while if your Insteon network is having any communication issues.

    After doing the above, if you're still having issues, look for the debug log under HS3\Logs\InsteonThermostatDebug.log You may have to make a copy as InsteonThermostatDebug.log.txt to be able to post it to a message here for further review.

    Nathan

    Leave a comment:


  • jon102034050
    started a topic Can't add thermostats

    Can't add thermostats

    Im new to HS, came from an ISY where I had 2 thermostats works well. I'd like to be able to use these again, but I can't seem to get my thermostats to get recognized by the plugin. Followed the instructions to add it from this thread:

    http://board.homeseer.com/showthread...ghlight=devcat

    This is what my thermostat name looks like:
    Main Floor
    [???,FFFFFFFF,]

    Here is my debug log.



    Code:
    5/27/2016 3:54:37 PM ~ Insteon Thermostat ~ ERRORS ~ Post-startup timer to check for thermostat DEVCAT: Main Floor still missing DEVCAT after 12 run(s).  Requesting protocol again.
    5/27/2016 3:54:37 PM ~ Insteon Thermostat ~ DEBUG ~ Request PROTOCOL for Main Floor
    5/27/2016 3:54:37 PM ~ Insteon Thermostat ~ DEBUG ~ TransmitInsteon: [Main Floor] [0F] [0D] [00]
    5/27/2016 3:54:37 PM ~ Insteon Thermostat ~ DEBUG ~ Request DEVCAT and FIRMWARE version for Main Floor
    5/27/2016 3:54:37 PM ~ Insteon Thermostat ~ DEBUG ~ TransmitInsteon: [Main Floor] [0F] [10] [00]
    5/27/2016 3:56:37 PM ~ Insteon Thermostat ~ ERRORS ~ Post-startup timer to check for thermostat DEVCAT: Main Floor still missing DEVCAT after 13 run(s).  Requesting protocol again.
Working...
X