Announcement

Collapse
No announcement yet.

HSTouch Crash with latest version (and others)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HSTouch Crash with latest version (and others)

    Hello all,

    Have an odd situation here. Not sure if this is something I'm doing wrong, issues with the Insteon PI, Insteon Thermo PI, or HSTouch Server but after startup everything is fine for a bit. Setpoint changes, temp changes, etc work fine. After a few minutes if I try to adjust setpoint (both cool and heat) or if the thermostat makes a temp change notification the HSTouch server debug log floods with "Refreshing Thermostat Info" and eventually the HSTouch server usually crashes. During and after this CPU spikes and stays at a steady 25%-75% and if the HSTouch server remains running it becomes unresponsive. The odd part.. works fine sometimes.. and then decides to crash and burn...

    Specs are below. I have tried several variations on all of these and all produce the same results...

    RPI3 running Ubuntu 16.04 (also tried Raspbian - latest)
    Mono Version 4.2.1 (also tried 3.2.8 with Raspbian)
    HS3 Pro (latest Linux version)
    Insteon Plugin (Mark's): latest in updater (tried several versions)
    Insteon Thermo Plugin: latest in updater (tried beta and several others I could find)
    HSTouch Server: latest in updater (tried beta and others)

    Thanks for any ideas or suggestions!

    Ben

  • #2
    Hi Ben,

    I assume you also posted over in the HSTouch forum and maybe Mark's forum (Insteon PI) about this experience? This sounds like some sort of event/thread looping in the HSTouch server in the linux version of HS3? In your description you mention two scenarios: HSTouch client (change set point) sending to HS3 / HSTouch server, and Thermostat change which is thermostat hardware->HS3->Insteon PI->Insteon Thermostat PI->HS3 virtual devices->HSTouch server->HSTouch client. If both produce the same HSTouch server logging/error it would seem there might be an issue with the processing of or the messaging from HSTouch server to HSTouch client? I would initially pursue this over in the HSTouch forum and see if others on the same versions of HSTouch as you're running are experiencing anything similar?

    Nathan
    HS 3.0.0.435 (PRO)
    Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
    Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
    Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
    http://www.kazteel.com/

    Comment


    • #3
      Thanks for the advice Nathan. I will post something over in HSTouch.

      Somehow I was mistaken though - I guess in all the switching from PI version to version and specifically with mono I missed it. After my original post I gave it a last ditch effort with the latest Raspbian with the current mono version being 3.2.8 in the repository. Installed all plugins and viola! everything seems to be stable and working for the most part. No more crashing on thermostat IO. So I'm assuming its something with the HSTouch server and mono 4+ or possibly with Ubuntu 16.04 which is what I was using.

      Not pointing fingers because at this point I have no solid conclusion.

      Thanks for the reply and thanks for the plugin - Have been using it for a while now.

      Ben

      Comment

      Working...
      X