Announcement

Collapse
No announcement yet.

Feature requests

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Feature requests

    Please add your feature requests here.

    I will update this post with the current status and expected availability of the requests in future versions.
    • Multiple HS devices per thermostat
      This is available in version 3.3 now (except for the Honeywell)
    • HVAC mode On/Off/Auto for Proliphix
    Last edited by Rien du Pre; May 3rd, 2015, 02:23 AM.
    Regards,

    Rien du Pre
    The Netherlands
    Using:
    Homeseer PRO latest HS4 BETA on a Raspberry
    Plugin's:
    RFXCOM, mcsMQTT, Z-Wave

  • #2
    Hi,

    See image below. Is that how you want separate devices per functionality ?
    Attached Files
    Regards,

    Rien du Pre
    The Netherlands
    Using:
    Homeseer PRO latest HS4 BETA on a Raspberry
    Plugin's:
    RFXCOM, mcsMQTT, Z-Wave

    Comment


    • #3
      That looks great. The only change I would make is one device for the profile pairs (i.e day/home, day/away, night/home, night/out, etc.) and one device to identify the mode (i.e. normal, hold, override)

      Cheers

      Sandro

      Comment


      • #4
        Version 3.3 is now available in the updater
        Regards,

        Rien du Pre
        The Netherlands
        Using:
        Homeseer PRO latest HS4 BETA on a Raspberry
        Plugin's:
        RFXCOM, mcsMQTT, Z-Wave

        Comment


        • #5
          Rien,

          The new 3.3 is awesome and thank you!

          Small bugs that I noticed but nothing as a show stopper.

          1. Coolsetpoint has a "1" in front of the value (string). (IE "177" instead off "77").
          2. Hopefully this is just my HSTouch setup but if I choose a particular cool/heat set point no reaction. If I choose if from the web interface it does change. Along with this the "+" (plus) and "-" (minus) do not seem to work.

          Again thank you for the changes even if with the two bugs it is still a big jump forward for me (and these are minor)!

          Comment


          • #6

            Comment


            • #7
              Solved it !!!!

              Next release with this and other solved bugs and Proliphix HVAC mode device functionality will be available very soon.
              Regards,

              Rien du Pre
              The Netherlands
              Using:
              Homeseer PRO latest HS4 BETA on a Raspberry
              Plugin's:
              RFXCOM, mcsMQTT, Z-Wave

              Comment


              • #8
                Honeywell connection does not work

                I cannot get a connection to my Honeywell gateway account. Only error of the plugin in debug mode is:
                <TABLE class=log_table_row cellSpacing=0> <TBODY> <TR> <TD class="LogDateShort LogDateTime0" style="WHITE-SPACE: nowrap" align=left>mei-08 22:42:10 </TD> <TD class=LogPri0 align=left></TD> <TD class=LogType0 colSpan=3 align=left>IPThermostat </TD> <TD class=LogEntry0 colSpan=8 align=left>DEBUG1: PollHONEYWELLServer: Parsing info </TD></TR></TBODY></TABLE> <TABLE class=log_table_row cellSpacing=0> <TBODY> <TR> <TD class="LogDateShort LogDateTime1" style="WHITE-SPACE: nowrap" align=left>mei-08 22:42:10 </TD> <TD class=LogPri1 align=left></TD> <TD class=LogType1 colSpan=3 align=left>IPThermostat </TD> <TD class=LogEntry1 colSpan=8 align=left>DEBUG1: PollHONEYWELLServer: Set credentials for HONEYWELL Server request.</TD></TR></TBODY></TABLE>

                Comment


                • #9
                  Originally posted by Christian View Post
                  I cannot get a connection to my Honeywell gateway account. Only error of the plugin in debug mode is:
                  <TABLE class=log_table_row cellSpacing=0> <TBODY> <TR> <TD class="LogDateShort LogDateTime0" style="WHITE-SPACE: nowrap" align=left>mei-08 22:42:10 </TD> <TD class=LogPri0 align=left></TD> <TD class=LogType0 colSpan=3 align=left>IPThermostat </TD> <TD class=LogEntry0 colSpan=8 align=left>DEBUG1: PollHONEYWELLServer: Parsing info </TD></TR></TBODY></TABLE> <TABLE class=log_table_row cellSpacing=0> <TBODY> <TR> <TD class="LogDateShort LogDateTime1" style="WHITE-SPACE: nowrap" align=left>mei-08 22:42:10 </TD> <TD class=LogPri1 align=left></TD> <TD class=LogType1 colSpan=3 align=left>IPThermostat </TD> <TD class=LogEntry1 colSpan=8 align=left>DEBUG1: PollHONEYWELLServer: Set credentials for HONEYWELL Server request.</TD></TR></TBODY></TABLE>
                  Is it possible to give me temporary access to your Honeywell account to test it?
                  Regards,

                  Rien du Pre
                  The Netherlands
                  Using:
                  Homeseer PRO latest HS4 BETA on a Raspberry
                  Plugin's:
                  RFXCOM, mcsMQTT, Z-Wave

                  Comment


                  • #10
                    Hi Rien,

                    I've got the same problem. The plugin does login. A false username and password leads to an error in the log: not authenticated.
                    The proper username only gives the lines listed by Christianand no new devices are created.
                    Sometimes an error Too many requests is visible, but that has a different cause.

                    Since I just started the trial yesterday I didn't had this plugin on my system yet.

                    I also emailed you about this, but now i found this thread I thought it well to append my experience as well.

                    Comment


                    • #11
                      Originally posted by Fraggel View Post
                      Hi Rien,

                      I've got the same problem. The plugin does login. A false username and password leads to an error in the log: not authenticated.
                      The proper username only gives the lines listed by Christianand no new devices are created.
                      Sometimes an error Too many requests is visible, but that has a different cause.

                      Since I just started the trial yesterday I didn't had this plugin on my system yet.

                      I also emailed you about this, but now i found this thread I thought it well to append my experience as well.
                      Hi,

                      I tested it with a friend's account and this seems to work like expected.
                      For another test I use an US account for my own Honeywell and this account shows the same errors as you guys have.

                      Can you tell me where on which site you registered your EVoHome?
                      At https://europe.mytotalconnectcomfort.com of at https://mytotalconnectcomfort.com

                      For some (unknown) strange reason Honeywell seperated the 2 continents.

                      My plugin only supports the EU version at this time.
                      Regards,

                      Rien du Pre
                      The Netherlands
                      Using:
                      Homeseer PRO latest HS4 BETA on a Raspberry
                      Plugin's:
                      RFXCOM, mcsMQTT, Z-Wave

                      Comment


                      • #12
                        Hi Rien,

                        Last night I viewed the source of your plugin and compared it to the API I already wrote sometime ago.
                        I see you use the same url, but another application id.

                        You use ID: 09cdfda7-0ba6-49af-8ee1-c4e9065afaca.

                        The latest honeywell-app uses 91db1612-73fd-4500-91b2-e63b069b185c (found this out myself by proxying app-communication, I found the ID you use already commented out in my code).

                        The old application ID also works for me, but gives me a lot more "Too many requests" errors.

                        Since I do get my 3 zones back, from my code, I do believe something is wrong in the way you parse the json data.

                        I'd be happy to give you a login to test.

                        Comment


                        • #13
                          Originally posted by Fraggel View Post
                          Hi Rien,

                          Last night I viewed the source of your plugin and compared it to the API I already wrote sometime ago.
                          I see you use the same url, but another application id.

                          You use ID: 09cdfda7-0ba6-49af-8ee1-c4e9065afaca.

                          The latest honeywell-app uses 91db1612-73fd-4500-91b2-e63b069b185c (found this out myself by proxying app-communication, I found the ID you use already commented out in my code).

                          The old application ID also works for me, but gives me a lot more "Too many requests" errors.

                          Since I do get my 3 zones back, from my code, I do believe something is wrong in the way you parse the json data.

                          I'd be happy to give you a login to test.
                          Do you have my source code ??
                          Regards,

                          Rien du Pre
                          The Netherlands
                          Using:
                          Homeseer PRO latest HS4 BETA on a Raspberry
                          Plugin's:
                          RFXCOM, mcsMQTT, Z-Wave

                          Comment


                          • #14
                            I sent you a PM with more info.

                            Comment


                            • #15
                              No devices since new version

                              Hi Rien,

                              I have the same issues as Christian en Fraggel with the new version of your plug-in. I use de Europe version of Honeywell connected. There seems connection but no devices are showed. I've got the same log entries as Christian: parsing info. That's it.

                              Regards,

                              Luuc.

                              Comment

                              Working...
                              X