Announcement

Collapse
No announcement yet.

One or more errors occurred

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • One or more errors occurred

    I was away for a couple of days, homeseer set my Nests in Eco mode. All was well. I came home today and homeseer attempted to switch eco mode off. I noticed it wasn't getting warmer so I went and checked the log. The plugin reported "One or more errors occurred" twice, presumably as I have two thermostats? I tried resending the command and got similar errors and a new one "Calling SetIOMulti in plugin Nest:Object reference not set to an instance of an object.". Then I got "Plugin Nest is not responding but it is still running, not restarting yet.". I let it go a while and still had issues. So I stopped and started it manually. Then I got "ERROR Cannot find thermostat gi6tL1If6GgDSRKTlE8uiQ_VumSUMP-v" twice, again presumably for two thermostats. I then decided to restart homeseer and still not resolved. So I went through the reauthorization of Nest. Still got errors for a while and then finally it started to work again.

    No other errors in the log since the Eco command was issued 4 days ago. Any thoughts on what happened here? Thanks.

  • #2
    It's happening again this morning. I tried to raise the temperature and I got the error "One or more errors occurred". However, if I adjust the temperature in the Nest app or on the thermostat then it does update in Homeseer.
    Last edited by simonmason; November 12th, 2018, 06:55 AM.

    Comment


    • #3
      I am still not able to control my thermostats - however, homeseer is updating when I change the temp settings through the Nest app or on the web site. I am still getting the "one or more errors". I am assuming this is unique to me or someone else would have said something. Shall I uninstall the plug-in and reinstall it?

      Comment


      • #4
        Does it work if you restart the plugin?
        Could you set the log level to Debug and post what you get when you try to control the thermostats from HS.

        Comment


        • #5
          Restarting the plugin seems to have no impact. I have attached the log file after switching to debug and adjusting the temperature and receiving the error. Thanks.
          Attached Files

          Comment


          • #6
            hmm... the logs doesn't help much...

            Are you on Windows or Linux? which version of mono/.NET?
            Could you try to disable any firewall you may have, for testing?
            Have you tried to reauthorize the plugin?

            Did you change anything to your system before it started happening?

            Comment


            • #7
              I am Windows 7 based. Nothing changed - in fact I was out of town for 5 days - it worked fine when I left - putting the house in Eco mode. It was when I came home that I noticed the errors.

              I have tried re-authorizing the plugin. The only firewall I have running is on my Verizon FIOS router - I haven't changed that in 5+ years. The firewall on the PC is disabled.

              What is mono, and how do I determine which version of this or .NET that I am running?

              Comment


              • #8
                Inexplicably it started working yesterday. I would like to get to the bottom of this as several times over the past few months I have gone to my touchscreens to adjust the temperature and got no response - the thermostats did not receive the commands, checked the logs and got no real information, then later in the day they would be working fine. Do you think this is in the communications from homeseer to Nest? I haven't changed firewall info, or anything like this but I could double check this to see what is happening. Also is the "one or more errors" message coming from your plugin. Are you able to make that error message more informative so we could see what is happening when it happens?

                Comment

                Working...
                X