Announcement

Collapse
No announcement yet.

Support for new ECO mode?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Support for new ECO mode?

    Received the Nest update yesterday, set the next in ECO mode, but in Homeseer, shows HVAC Mode unknown.

    Also think there may be an issue with Home/Away, as I saw my heat turning on when in AWAY status? I have HomeSeer set to AWAY when all phones have left the house and drop off my wireless network. I will be testing more today.

    DeVon

  • #2
    the ECO mode has been recently added to the API, I will add it to the plugin soon.
    thanks

    Comment


    • #3
      Thanks I rely heavily on my nest home/away/auto-away status to track people in the house. Looking forward to the updated support for "eco".

      Comment


      • #4
        Any ETA on when this may be available?

        Comment


        • #5
          next week

          Comment


          • #6
            Will that fix my home/away issue as well? When I set the Home device to Away, it does not drop the temp for the thermostat anymore. Must be something to do with the firmware update?

            Comment


            • #7
              Eco mode has been added in version 3.0.0.21 available here: http://board.homeseer.com/showthread...46#post1130146

              Comment


              • #8
                I just loaded it. Any idea if the Away mode will turn down the setpoints like before the firmware change? I will do some testing...

                Comment


                • #9
                  Seems like everything is working again. When the Home device goes to Away mode, the Nest HVAC Status goes to ECO mode. Seems ECO mode is the new AWAY mode...

                  Thanks for the update!

                  Comment


                  • #10
                    Target Temp

                    Hey Spud,

                    I think support for the new ECO mode is working fine although I'm seeing behavior that is slightly different than others. If I have an event that turns on Away mode the Nest does not appear to go into ECO mode - that's fine not your problem, just the way the Nest appears to work. Because of where the Nest is located and how I use it I have the auto-away stuff turned off - this is likely causing this.

                    In .20 you added support for target temp being changed based upon the Away setting - that worked great! However I think with the addition of ECO mode, target temp is now only determined by that setting. If your not in ECO Mode but in Away mode the target temp is still the non-eco mode setting. So I think the target temp code now needs to only pay attention to ECO mode and not if you are in away mode.

                    There is a work around, I have my events always set ECO then AWAY mode (reversing afterwards) so it's not a problem. However folks may see odd behavior with the target temp if they don't know about this quirk.

                    Thanks,
                    -Jeff

                    Comment


                    • #11
                      Hey Jeff. I do the same as you do. I have a script that watches for phone MAC addresses on my network. When all are gone, I have an Event that turns the Home device to Away, and to Home when one of the phones appear on the network.

                      That being said, you can have the Nest go to ECO mode when AWAY is set.

                      1. On your thermostat preferences, Select Home/Away Assist, then turn on "Automatically use ECO Temperatures when you're Away".

                      2. On your Home Preferences, Select Home/Away Assist, and select "What decides if you're home". Click on your Thermostat, and turn off "Should this Thermostat use it's Activity Sensors...". You can also select Use Phone Location here. I have this turned off, as I don't like the Nest App watching where I am all the time (and burning up my battery).

                      This will allow ECO mode to turn on automatically when AWAY is set.

                      Comment


                      • #12
                        Ahhh, configure param

                        Hi Devon,

                        Thanks for the pointer, guess I missed that config screen. That will definitely make things simpler. That said, my original comment about target temp being bound to ECO mode is still true so at some point it will be cleaner if the plugin used that instead of away. No rush, there are work arounds this time so its not a big deal.

                        -Jeff

                        Comment


                        • #13
                          Hi Spud,

                          Just a reminder about the target temp computation. With the introduction of the latest software (3.0.0.26) and the read only away/home state this has sort of become an annoying problem. For some reason that I'm not sure about the home/away status of the Nest spontaneously changes back to Home. It's a vacation home and there is no one there (and no motion) so what is causing the change is unclear. However the affect is the target temp changes to effectively non-eco and thus the wrong setting. This makes using it in events problematic.

                          Any chance you can tweak the logic to only use the HEAT/COOL/ECO mode setting instead of home/away setting? At this point home/away seems to have no real practical use.

                          Thanks,
                          -Jeff

                          P.S. - The reason this wasn't an issue before is I had an event that switched it back to away mode whenever it did something wrong. That no longer works.

                          Comment


                          • #14
                            Originally posted by januszczyk View Post
                            Any chance you can tweak the logic to only use the HEAT/COOL/ECO mode setting instead of home/away setting? At this point home/away seems to have no real practical use.
                            in version 3.0.0.29 available in beta section of the updater, the values displayed by the target temp devices only use the HVAC mode, and not the home/away status.

                            Comment

                            Working...
                            X