Announcement

Collapse
No announcement yet.

I broke Amazon Echo / Alexa Control of the Temperature

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I broke Amazon Echo / Alexa Control of the Temperature

    I have had the Omnistat 3 plugin working great for a long time. Today I had to import a bunch of new devices into the Alexa app and I saw a bunch of junk with enabled voice commands. Since HomeSeer does not easily show you which devices have it enabled, I did a show all in the Home screen and selected every single device and removed Voice control and only added it back to those 54 devices that needed it.

    All works great except I can no longer set the temperature by speaking "Alexa, set temperature to 70"... I get a "Your device does not support that yet" now.

    What device did I remove voice control from that I need to re-add it back to? It used to work great until I did this today.
    ---------------------------------------------------
    Jean-Marie G. Vaneskahian
    jean@vaneskahian.com
    ---------------------------------------------------

  • #2
    In looking at the code, it looks like only Current Heat Setpoint and Current Cool Setpoint need voice control.

    Comment


    • #3
      I've never been able to get this functionality working, even though I'm running the most current version.

      Anyone care to post some screenshots of the cool and heat setpoint devices? Mine show as 08_TS_1_CSP and 09_TS_1_HSP.

      On the Advance tab it says:
      Device Type Internal Thermostat API, Type: Thermostat Setpoint, SubType:

      The Device string did say Cool Setpoint and I changed it to Current Cool Setpoint and it didn't make a difference

      What should the Control Use settings on the Status Graphics values be set for?

      I can post mine if someone with a Alexa controllable Omnistat3 wants to compare.

      Comment


      • #4
        I think you are making this too difficult. You don't need to change any of the device values to make it work.

        I would recommend that you go to the thermostat configuration screen, select the thermostat, and click on the refresh icon. That will set the devices back to how they should be.

        Go to your Alexa app and set it up for homeseer like it says in other posts.

        I don't use Alexa, but a number of other people do.

        Comment


        • #5
          I followed your advice, refreshed the thermostat in the plugin, re-discovered devices in the Homeseer Alexa skill (I have many other devices working fine) and still get "Your device does not support that yet" when I ask alexa to set or query the thermostat.

          I'm running the newest Homeseer skill (V3)

          Does the thermostat appear in the devices list in alexa? It doesn't appear in mine.

          Is there any debugging I can enable?

          Comment


          • #6
            Ok, I'll admit the "making harder" comment made me dig in.

            I have it working now. Turns out there is a nuance that isn't documented. You might want to mention this in the documentation.

            I use the "User Access" feature in devices, mainly to make the device list simple for my wife. With that, there are a number of root devices I have set to only be accessible by the user "admin".

            Apparently for the echo discovery protocol to work, you have to have User Access set to "any" user. When I changed the root device for the thermostat, alexa discovered it, and now it works.

            Just thought I'd document it here in case anyone else uses this feature.

            Comment


            • #7
              I'm glad you figured it out. I'm afraid that I wouldn't be much help with Alexa.

              Comment


              • #8
                Got it working! Thanks so so so very much Kirby! I also learned that you have to set the root device (Thermostat) for voice control also.

                You are awesome! Thanks again!
                ---------------------------------------------------
                Jean-Marie G. Vaneskahian
                jean@vaneskahian.com
                ---------------------------------------------------

                Comment


                • #9
                  Jean-Marie,
                  You are very Welcome!

                  Comment

                  Working...
                  X