Announcement

Collapse
No announcement yet.

strange behavior with night occupancy mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kirby
    replied
    are there any plugin triggers that i can use when a transmission error occurs between the plugin and the stat? this might be the only way i can determine when i'm having this issue.
    There aren't any triggers. You could turn on Comm error logging. Maybe one of the log plugins could screen for the comm errors and notify you.

    Leave a comment:


  • mnsandler
    replied
    Kirby,
    well now its working as you described. I stood in from of each stat and changed a few different set points via hstouch and the changes were reflected on the stat Program screen.

    are there any plugin triggers that i can use when a transmission error occurs between the plugin and the stat? this might be the only way i can determine when i'm having this issue.

    Leave a comment:


  • Kirby
    replied
    Mark,
    On the Omnistat2, If you change any of the occupancy temp device values (i.e. Day Heat Setpoint), the plugin will change the corresponding value on the thermostat programming. I confirmed this behavior on my RC-2000.

    If this is not working for you, then let me know what method you are using to change the device value.

    Leave a comment:


  • mnsandler
    replied
    I wanted to followup on this topic...

    it seems like the Omnistat2 Occupancy mode uses the temps set in the programming, and just allows the plugin to change the mode but not the temps.

    so when i change a Day Setpoint in the plugin, it does not change the programming on the omnistat2 , correct?

    should i change the mode on the omnistat2 to None so that the plugin will set the temps accordingly

    Leave a comment:


  • Kirby
    replied
    Glad to hear it.

    Leave a comment:


  • mnsandler
    replied
    i didn't reset the unit, but i did change the programming directly on stat again and the issue seems to be resolved. changing to night mode seems to set the temp correctly

    Leave a comment:


  • Kirby
    replied
    I'm assuming then that your other stat is not exhibiting these issues.

    Let us know how the reset works for you.

    Leave a comment:


  • mnsandler
    replied
    i have two omnistat2 units. they are assigned different addresses (1 & 2). i'm not using the SetRegister method

    i think i may have to reset the unit and then reprogram it.

    Leave a comment:


  • Kirby
    replied
    every time i go to the program setup, it changes the heat setpoint to 66 regardless of what is on the program screen (like on #8 above)
    That is very strange. Do you have more than one thermostat? Are you using the plugin's SetRegister method in any events?

    Leave a comment:


  • mnsandler
    replied
    the above didn't work. There is something going on with the stat itself. every time i go to the program setup, it changes the heat setpoint to 66 regardless of what is on the program screen (like on #8 above)

    Leave a comment:


  • mnsandler
    replied
    ok. i manually adjusted all the heat set points in the plugin, and verified them against the program screen on the stat. I'll see what happens tonight @ 9pm when hs initiates night mode.

    thanks for your help

    Leave a comment:


  • Kirby
    replied
    The stat.

    Leave a comment:


  • mnsandler
    replied
    Ok. so when i change the occupancy mode (via hs) from day to night, and the current setpoint changes; where does the new temp value come from? the related hs device, or read from the stat

    Leave a comment:


  • Kirby
    replied
    No. The plugin looks at the type of thermostat that you have. If it is one that natively supports occupancy then it sets the current occupancy register and not the current setpoint.

    I think you should change the values of your occupancy devices to a different temp and then change them back to the desired temp. This should change the temp settings on the stat to match your devices.

    Once you do this, everything should work as expected.

    Leave a comment:


  • mnsandler
    replied
    Kirby,
    should i set the programming mode in the stat to None? Will the plugin then set the stat temp according to the occupancy mode i select in the plugin?

    Leave a comment:

Working...
X