Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Unable to enroll one of my thermostats

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to enroll one of my thermostats

    Switched to HS3 over the Xmas break and initially used the HAI Omnistat plugin to control my four thermostats (2 RC80's and 2 RC100's). They were working fine with HS2 for several years and continued to work fine with HS3 and the Omnistat plugin. Having some issues dealing with the fractional temps, really want to setpoint to be 72, (not 71.6). Stumbled upon the Omnistat 3 plugin by Kirby and gave it a try. Like the looks and operation of this plugin much better! (thanks so much Kirby!!) But I've ran into one very major problem. I've had no problem enrolling thermostat addresses 1 thru 3 which happens to be the two RC80's and one of the RC100's. When I go to add the last at address 4 the "Enroll Thermostat" button is dimmed no matter what I do and I can't add my last thermostat (which is an RC100). If I disable the Omnistat 3 plugin and re-enable the HAI Omnistat plugin the last thermostat works fine (I can read values and set parameters). I disable the HAI Omnistat plugin and re-enable the Omnistat 3 plugin and still no joy.
    Any ideas or suggestions would be greatly appreciated! I'd really like to switch to this plugin but before I mod all my HSTouch clients for it I need to have that last thermostat working!

    Thanks!
    Georgia Dutchman

  • #2
    I have five thermostats enrolled in my home in Atlanta so trying to enroll four should not be a problem.

    Can you post a screen shot so that I can see what you have entered for the thermostat?

    Thanks,

    Kirby

    Comment


    • #3
      I haven't been able to replicate your issue. Essentially what happens is that whenever you enter the Name, Address, Location, or Location 2, a method is called to see if there is a value in all these fields and that the address is not already in use. If all are true then it enables the enroll button.

      Try this:
      Add a thermostat as address 5 (or higher) and see if the enroll button becomes enabled. If it does, change the address to 4 and press the enroll button.

      Let me know what happens.

      Kirby

      Comment


      • #4
        Problem solved

        Kirby,
        I went back into the plugin config screen and took 2-3 screen shots of the dimmed enroll button and suddenly found myself with an enabled enroll button. I had been playing with the location 1 and location 2 labels when the enroll button became enabled again. I went back to the original labels that had produced the dimmed enable button and now it is not dimmed

        Don't know what happened but my fourth Tstat is enrolled and working so if it ain't broke it doesn't need fixin! Thanks for your quick response and thanks for a great plugin!

        Georgia Dutchman

        Comment


        • #5
          I'm glad you got it to work. This is definitely a strange one.

          I appreciate your kind words about the plugin.

          Kirby

          Comment

          Working...
          X