No announcement yet.

Odd Thermostat device behavior

  • Filter
  • Time
  • Show
Clear All
new posts

    Odd Thermostat device behavior

    I've got an odd thing I noticed with my Omnistat 2000. When the HVAC system is off, all the device states and setpoints seem normal. When the HVAC system is running (currently in cooling mode), the current mode STATE says cooling (which is true) but the current mode changes to HEAT (which is opposite of what is happening).

    During the run state, the current setpoint switches to the heat setpoint.

    I have no idea why this is happening.

    See the attached captures during HVAC not running and HVAC running.

    Any ideas?
    Attached Files

    What registers are used to determine "Current Mode" verses "Current Mode State"? In the Omnistat documentation I can't seem to find anything that matches "state".


      Register 71 is polled for the current mode. Register 72 contains 7 bits that provide the relay output status. I use these bits to determine the mode state. The bits are defined as follows:
      bit 0: heat/cool bit - set for heat, clear for cool
      bit 1: auxiliary heat bit - set for on, clear for off (RC-100, -101, -112, -1000, -2000 only)
      bit 2: stage 1 run bit - set for on, clear for off
      bit 3: fan bit - set for on, clear for off
      bit 4: stage 2 run bit: set for on, clear for off (RC-112, 120, 121, 122, -1000, -2000 only)
      bit 5: Humidifier bit - set for on, clear for off (RC-2000 only)
      bit 6: Dehumidifier bit - set for on, clear for off (RC-2000 only)

      It seems that the current mode (reg 71) is unreliable.

      I will look at adding some sanity logic so that the current mode will be accurate. If the current mode is accurate then the current setpoint will also be correct.


        Yeah, I did some polling of the registers last night while the system was idle and running. Idle, register 71 was equal to 2, running register 71 was equal to 1.

        I suppose it could be a bug in my firmware version, but I'm not sure what version I have.

        Net time it runs I'll check register 72.

        Thanks for the prompt response!


          When running, register 72 returns 12, which seems to correctly indicate stage 1 cooling with the fan on.


            I think register 72 is being interpreted properly, but your register 71 is not returning the proper value.
            My firmware is 1.058-ZHA-V14.27.
            You should be able to check yours by going into setup.


              Mine is 1.02C

              Sent from my VS986 using Tapatalk


                Bummer. I will try and put the sanity checks in and attach a version for you to test. This is a really busy week for me so I can't promise when I can post it , but hopefully some time next week.

                You might check with Leviton to see if they can upgrade your firmware. I have found them to be very accommodating (they are the original HAI guys).


                  Thanks. It would be great if you could work around this apparent bug in Omnistat firmware.

                  I shot off an email to Leviton support, I'll see if it gets me anywhere.


                    I have created an updated version for you to try. Basically I'm using this logic:
                    If the Mode device is not "Auto", I set the Current Mode to the Mode (Em Heat as Heat)
                    If the Mode is "Auto" and the system is heating then I set the Current Mode to Heat.
                    If the Mode is "Auto" and the system is cooling then I set the Current Mode to Cool.
                    If the Mode is "Auto" and the system is idle then I set the Current Mode to the previous Current Mode.

                    I think this will give you what you are looking for.

                    To try out the new version do the following:

                    1) Disable the Omnistat 3 plugin.
                    2) Copy HSPI_OMNISTAT_3.exe to another file name.
                    3) Unzip the attached file and copy HSPI_OMNISTAT_3.exe to your HomeSeer directory.
                    4) Enable the Omnistat 3 plugin.

                    Let me know how it works for you.
                    Attached Files


                      Thanks for the update. I can confirm it's working as expected - when the system comes on in cooling mode the current mode and state still say "cooling" correctly.

                      Thanks for writing this fix. I haven't heard back from Leviton from my initial email. I will try to give them a call to see if it makes a difference.