Announcement

Collapse
No announcement yet.

Thermostat Integration With Amazon Echo (Alexa)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thermostat Integration With Amazon Echo (Alexa)

    I am using the Standard HomeSeer Skill (The one where you do NOT have to say Alexa Tell HomeSeer To XXXX) and it states it can control the Thermostat. I can all and control all my Insteon Devices, but I cannot see in the Alexa Discovery the Thermostat nor can I control it.

    Is there something I am missing here? Will the Omnistat 3 Plugin be updated to support Amazon Echo API?

    Thanks
    ---------------------------------------------------
    Jean-Marie G. Vaneskahian
    jean@vaneskahian.com
    ---------------------------------------------------

  • #2
    Jean,
    I don't have an echo and I don't know what the requirements are to make the plugin compatible. If you could send me a link to information about supporting the echo, I'll take a look at it.

    Comment


    • #3
      I got most of the info from here:

      http://www.homeseer.com/amazon-echo-integration.html

      and here

      http://forums.homeseer.com/showthread.php?t=180033

      This is what stood out:

      HomeSeer will include thermostats in the discovery even though Amazon does not support thermostats with this version. (Note that thermostat support has been added to their API and HomeSeer will be adding it an update). For now you can control a thermostat with the following command. Assuming your thermostat heat setpoint device was named "thermostat", you can say:

      "Alexa, set my thermostat to 72 degrees"
      I highly recommend getting an Echo Dot... they are only $39 and they are amazing interface to your HomeSeer devices... as well as all the other things they do..

      For now I created virtual devices called "Air Conditioner" and "Heater" and have events tied to the ON and OFF state of these devices... so I can say:

      "Alexa, Turn On Air Conditioner" and the echo will turn on the virtual device called "Air Conditioner" and that will in turn fire off an event that then uses your plugin to set my Omnistat to Cool Mode and 72 degrees.. etc...

      Not the same as "Alexa, set the Thermostat to 72 Degrees" but it works... just not a native way to do it...

      Thanks for any help!
      ---------------------------------------------------
      Jean-Marie G. Vaneskahian
      jean@vaneskahian.com
      ---------------------------------------------------

      Comment


      • #4
        It doesn't seem too difficult to implement. I will make the changes when I get back home (End of January).

        Comment


        • #5
          That's good news. Thanks

          Comment


          • #6
            Sorry for the delay in getting back on this, my plate has been pretty full.

            I now have a dot and I have had a chance to play with it and the smart home API.

            After some research and trial & error, I have been able to get the plugin working although more work needs to be done. The biggest change is that the Alexa interface requires the use of ranges for the setpoints where I am currently using single value status/graphics pairs.

            In Fahrenheit mode, it shouldn't make much of a difference. In Celsius mode,
            you will lose the ability to set a half degree setpoint from HomeSeer. That is because ranges are integers. That is why initially I chose single values. So in Celsius mode you can set 25 or 26 degrees but not 25.5 degrees. The input control for the setpoints will change from a dropbox to a text box.

            The temperature will still display in half degrees.

            I would like some feedback from our Celsius users on these changes.

            Comment


            • #7
              Losing the ability to set a half degree setpoint is not a big deal. But do we have to go to textboxs to input setpoints?

              Comment


              • #8
                Originally posted by YvMo View Post
                But do we have to go to textboxs to input setpoints?
                Yes. I sent Rich this question having to do with using a dropbox. Here is his response:
                Originally Posted by Kirby
                It only sorta works. If the cool setpoint is set at the thermostat to 25 and the range is 19 to 32 then the dropdown box displays 25 as it should. If the setpoint is set to 25.5 at the thermostat then the dropbox displays 19 which is confusing and I'm sure the plugin users will consider this a bug.
                Originally posted by rjh View Post
                We use a textbox for the set points. I have yet to receive any complaints from users about using Alexa with any of the Z-Wave thermostats that we support so I am not sure this is an issue.

                Comment


                • #9
                  Try This

                  I have attached a new version of the plugin for you to try. It implements the HS smart home API skill. To try it out do the following:
                  1. Disable the Omnistat_3 plugin.
                  2. Backup HSPI_Omnistat_3.exe
                  3. Unzip the attached zip file and copy the exe to your HomeSeer directory.
                  4. Enable the Omnistat_3 plugin
                  5. Go to the Omnistat_3 configuration screen and "Refresh" each of your thermostats.
                  6. In your Alexa app, make sure your HomeSeer skill for the Smart Home API is enabled.
                  7. Select the option to forget your devices.
                  8. Select the option to Discover Devices.


                  The skill works best when the thermostat is not in auto mode.

                  You can tell Alexa to raise or lower the temperature by so many degrees. You can also tell Alexa to set the temperature to a specific temperature.

                  Let me know how it works for you.
                  Attached Files

                  Comment


                  • #10
                    This works! Should be posted to updater.

                    Thanks!

                    Comment


                    • #11
                      Also worked for me! Thanks

                      Comment

                      Working...
                      X