Announcement

Collapse
No announcement yet.

New Plugin Posted

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    It sounds like it's running correctly. The new plugin only creates and updates one device. Hence the script to poll and update discrete devices with current mode information. There's nothing in either of these that will accumulate runtimes. You would have to implement that via another script or plugin. But this allows you to use the devices updated by the script as triggers for that.

    If you search around there are several different approaches to doing that. I think Jon00 has something on his website.
    jim

    Comment


      If you search a bit in this forum, there is a post or two where some of us running script once a minute to populate additional devices with HVAC information as well as accumulate run time information.
      HS: 2.5.0.60
      Environment: Virtual XP as guest in VMWare Server running under Win 7
      Plug-ins: MLHSPlugin|RCS Serial Thermostat|UltraLog|UltraMon|
      Misc: 303 Devices, 313 Events, 68+ Scripts

      HSeer: 3.0.0.54
      Environment: Virtual XP as guest in VMWare Server running under Win 7
      Plug-ins: BLGData|BLRF|BLRadar|BLRandom|BLSpeech
      UltraM1G3|UltraECM3|UltraMon3|UPBSpud|Z-Wave
      Misc: 148 Devices, 116 Events, 9+ Scripts (so far, still converting)

      Comment


        Originally posted by jstaab View Post
        If you search a bit in this forum, there is a post or two where some of us running script once a minute to populate additional devices with HVAC information as well as accumulate run time information.
        Are you referring to the file j_RCS_populate_devices.txt you directed me to earlier in this thread? Lets assume I actually figured out how to use that. Where would the result be? What would it look like? At the time I was using HS1.7. I have since upgraded to HS2 hoping I could get tit to work.

        Comment


          That one is actually very similar, maybe based off of the one I was thinking about, or the other way around. The only real difference is that it had a few extra lines of code to keep track of the fan, heat and cool run times. This could easily be added to this script. Create some additional variables, add to them once a minute based off the current state of the HVAC system, and run the script once a minute... I'll see if I can find reference to that other script.

          Originally posted by NJ Bill T View Post
          Are you referring to the file j_RCS_populate_devices.txt you directed me to earlier in this thread? Lets assume I actually figured out how to use that. Where would the result be? What would it look like? At the time I was using HS1.7. I have since upgraded to HS2 hoping I could get tit to work.
          HS: 2.5.0.60
          Environment: Virtual XP as guest in VMWare Server running under Win 7
          Plug-ins: MLHSPlugin|RCS Serial Thermostat|UltraLog|UltraMon|
          Misc: 303 Devices, 313 Events, 68+ Scripts

          HSeer: 3.0.0.54
          Environment: Virtual XP as guest in VMWare Server running under Win 7
          Plug-ins: BLGData|BLRF|BLRadar|BLRandom|BLSpeech
          UltraM1G3|UltraECM3|UltraMon3|UPBSpud|Z-Wave
          Misc: 148 Devices, 116 Events, 9+ Scripts (so far, still converting)

          Comment


            Well, my HS 2.whatever trial is about to expire, and I still don't have this plugin doing what I asked for help with a month ago. It works, to the extent that HS can control the thermostats, but I wanted to create a log to tell me how long my HVAC was on, and which stage. I hear people have been using a script, and yet no one can tell me what exactly it would look like or where I would find the result of this script. Instead, I have had suggestions like put a sail switch in the plenum (how that was going to tell me what stage the HVAC was on is a mystery to me, or for that matter, how it would know that the fan wasn't just running to humidify or clean the air) or the one from the guy who bragged about having the GPS in his car turns his heaters on before he gets home. (technology for the sake of technology) I am glad I didn't spend the money to upgrade to HS2. I hate the web browser interface as I did when it first came out. I know my 1.7 is old software, and maybe when HS 3.0 comes out and does more than turn my lights on and off without soliciting programmers for help, I'll try it. Mean while, my thermostats came with software that actually DOES create a log. Not exactly what I want, but the other simply isn't worth the trouble.

            Thanks.

            Comment


              I'm sorry there isn't a canned method of tracking run time. However, there are a variety of methods that can be used. Some are actually using hardware devices to monitor current (Brultech or TED), in which case, they can track both run time and the amount of electricity used. In this case, this still might take some custom work to get totals into HS. Likewise, you can set triggers when your HVAC kicks on and office that run a script to do whatever you want, log to a file, calculate the difference between the 'on' and 'off', and so on. Likewise, you could run a script once a minute that increments a 'run time' device as the HVAC is running. However, in the cases of a scripts, chances are it would still be custom specific to your setup.

              Maybe somewhere down the road the plug in can be enhanced, but even that then brings up the subject matter of how it should work when your talking about the possibility of a fair number of zones, when should the values reset and so on. Also, keep in mind, the plug-in will not be 100% accurate since it polls the hardware at set intervals. Then if your talking about graphs and charts, it might be easier to use this plug in conjunction with mcsTemperature for logging and charting.
              HS: 2.5.0.60
              Environment: Virtual XP as guest in VMWare Server running under Win 7
              Plug-ins: MLHSPlugin|RCS Serial Thermostat|UltraLog|UltraMon|
              Misc: 303 Devices, 313 Events, 68+ Scripts

              HSeer: 3.0.0.54
              Environment: Virtual XP as guest in VMWare Server running under Win 7
              Plug-ins: BLGData|BLRF|BLRadar|BLRandom|BLSpeech
              UltraM1G3|UltraECM3|UltraMon3|UPBSpud|Z-Wave
              Misc: 148 Devices, 116 Events, 9+ Scripts (so far, still converting)

              Comment


                By the way, with a little searching, I found that run time script on the thread below. Again, you would have to customize the logic based on your setup and needs, and maybe update a few of the commands.

                http://forums.homeseer.com/showthread.php?p=651527
                HS: 2.5.0.60
                Environment: Virtual XP as guest in VMWare Server running under Win 7
                Plug-ins: MLHSPlugin|RCS Serial Thermostat|UltraLog|UltraMon|
                Misc: 303 Devices, 313 Events, 68+ Scripts

                HSeer: 3.0.0.54
                Environment: Virtual XP as guest in VMWare Server running under Win 7
                Plug-ins: BLGData|BLRF|BLRadar|BLRandom|BLSpeech
                UltraM1G3|UltraECM3|UltraMon3|UPBSpud|Z-Wave
                Misc: 148 Devices, 116 Events, 9+ Scripts (so far, still converting)

                Comment


                  Changing Cool set point ALSO changes the heat set point

                  I had this thing working for about 3 weeks while on HS2 trial. Just before I registered it started giving me trouble. Now whenever I change the cool set point, the heat set point also changes. I have 2 RCS TR40, one on address 1 and the other on address 5. They were working fine. What happened?

                  Comment


                    Originally posted by Isk82 View Post
                    I had this thing working for about 3 weeks while on HS2 trial. Just before I registered it started giving me trouble. Now whenever I change the cool set point, the heat set point also changes. I have 2 RCS TR40, one on address 1 and the other on address 5. They were working fine. What happened?
                    Do you have the latest plugin loaded from the HS updater?
                    -Rupp
                    sigpic

                    Comment


                      Originally posted by Rupp View Post
                      Do you have the latest plugin loaded from the HS updater?
                      Thank you for the prompt reply.

                      I am running HS2 2.4.0.6 and the plugin is 2.4.0.7. I tried to uninstall the plugin, and reinstall, but it seemed to remember some of my settings so I don't know if I was successful with that.

                      Comment


                        Originally posted by Isk82 View Post
                        I had this thing working for about 3 weeks while on HS2 trial. Just before I registered it started giving me trouble. Now whenever I change the cool set point, the heat set point also changes. I have 2 RCS TR40, one on address 1 and the other on address 5. They were working fine. What happened?
                        I copied this from an old post of mine from 2008:
                        "It appears that programs that have the Heat Set point set before the Cool Set point perform correctly; programs that set the cool set point and then the heat set point do not work. Further, when they don't work, they set the heat set point correctly, but the cool set point at 4 degrees above the heat set point. This is a nasty little bug in the plug in.

                        Again, the work around seems to be to set the heat set point BEFORE setting the cool set point. "

                        Comment


                          See the following thread, which I believe is still unresolved. If this sounds like your problem, send me an e-mail via this board, and I can send you a copy of the DLL (HS provided) that has a band-aid fix.

                          http://board.homeseer.com/showthread.php?t=135524


                          Originally posted by Isk82 View Post
                          I had this thing working for about 3 weeks while on HS2 trial. Just before I registered it started giving me trouble. Now whenever I change the cool set point, the heat set point also changes. I have 2 RCS TR40, one on address 1 and the other on address 5. They were working fine. What happened?
                          HS: 2.5.0.60
                          Environment: Virtual XP as guest in VMWare Server running under Win 7
                          Plug-ins: MLHSPlugin|RCS Serial Thermostat|UltraLog|UltraMon|
                          Misc: 303 Devices, 313 Events, 68+ Scripts

                          HSeer: 3.0.0.54
                          Environment: Virtual XP as guest in VMWare Server running under Win 7
                          Plug-ins: BLGData|BLRF|BLRadar|BLRandom|BLSpeech
                          UltraM1G3|UltraECM3|UltraMon3|UPBSpud|Z-Wave
                          Misc: 148 Devices, 116 Events, 9+ Scripts (so far, still converting)

                          Comment


                            Originally posted by jstaab View Post
                            See the following thread, which I believe is still unresolved. If this sounds like your problem, send me an e-mail via this board, and I can send you a copy of the DLL (HS provided) that has a band-aid fix.

                            http://board.homeseer.com/showthread.php?t=135524
                            This thread exactly describes my problem. I sent you an email address to send me the band-aide. It doesn't answer my question though. What happened? This thing was working perfectly for 3 weeks.

                            Comment


                              Thermostat auto send y/n?

                              If the plug in polls every few seconds, how should auto send be set when using this plug in? I currently have it set to not auto send. When I make a change at the thermostat, Homeseer won't know until it polls. Am I correct in this?
                              Last edited by Isk82; September 15, 2010, 12:22 PM. Reason: added some stuff

                              Comment


                                Autosend should be off I believe. You are correct in that hs does do a poll, but its never been an issue for me anyway. I believe I have mine set to 15 seconds, but I will double check. So, you are correct, if you make a local adjustment at the wdu, there will be a short delay.

                                Originally posted by Isk82 View Post
                                If the plug in polls every few seconds, how should auto send be set when using this plug in? I currently have it set to not auto send. When I make a change at the thermostat, Homeseer won't know until it polls. Am I correct in this?
                                HS: 2.5.0.60
                                Environment: Virtual XP as guest in VMWare Server running under Win 7
                                Plug-ins: MLHSPlugin|RCS Serial Thermostat|UltraLog|UltraMon|
                                Misc: 303 Devices, 313 Events, 68+ Scripts

                                HSeer: 3.0.0.54
                                Environment: Virtual XP as guest in VMWare Server running under Win 7
                                Plug-ins: BLGData|BLRF|BLRadar|BLRandom|BLSpeech
                                UltraM1G3|UltraECM3|UltraMon3|UPBSpud|Z-Wave
                                Misc: 148 Devices, 116 Events, 9+ Scripts (so far, still converting)

                                Comment

                                Working...
                                X