Announcement

Collapse
No announcement yet.

Communication trouble

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Communication trouble

    I'm trying to establish communciation between HS and my RCS thermostats. I have 3 ZC6R zone controllers that were purchased in 2000. They have worked fine with Stargate. I have a RCS RS485/232 hub that I just purchased and have placed each zone controller, stargate, ane 3 LCD keypads on their own channel on the hub. I am able to access the zone controllers with the RCS demo program running on my Hometroller, but have not been successful in communicating through the HS plugin. I have verified that the network addresses and physical connections are correct. I'm wondering if the age of these units is a factor? I have included an excerpt of the log. Thanks in advance!

    12/7/2008 2:46:27 PM - RCS Serial Thermos - Error in Poll Thread, Argument 'Start' must be greater than zero.
    12/7/2008 2:46:38 PM - RCS Serial Thermos - #TP05Q83!TP00m040580GL 4 Idle 00#TP0AQ77!TP00m050080GL5 Idle 00A=1 R=1!TP00m050180GL6 Idle 00#TP05Q83!TP00m050280GL7 Idle 00#TP0AQ77!TP00m050380GL8 Idle 00A=1 R=1!TP00m040280GL1 Idle 00#TP05Q83!TP00m040380GL2 Idle 00#TP0AQ77!TP00m040480GL3 Idle 00A=1 R=1!TP00m040580GL 4 Idle 00#TP05Q83!TP00m050080GL5 Idle 00#TP0AQ77!TP00m050180GL6 Idle 00!R80AQ!TP00m050280GL7 Idle 00A=2 R=1
    12/7/2008 2:46:38 PM - RCS Serial Thermos - Error in Poll Thread, Argument 'Start' must be greater than zero.
    12/7/2008 2:46:48 PM - RCS Serial Thermos - !TP00m050380GL8 Idle 00#TP05Q83!TP00m040280GL1 Idle 00#TP0AQ77!TP00m040380GL2 Idle 00A=2 R=1!TP00m040480GL3 Idle 00#TP05Q83!TP00m040580GL 4 Idle 00#TP0AQ77!TP00m050080GL5 Idle 00A=2 R=1!TP00m050180GL6 Idle 00#TP05Q83!TP00m050280GL7 Idle 00#TP0AQ77!TP00m050380GL8 Idle 00A=1 R=1!TP00m040280GL1 Idle 00#TP06Q82!TP00m040380GL2 Idle 00
    12/7/2008 2:46:48 PM - RCS Serial Thermos - Error in Poll Thread, Argument 'Start' must be greater than zero.
    12/7/2008 2:46:59 PM - RCS Serial Thermos - A=1 R=1!TP00m040480GL3 Idle 00A=2 R=1!TP00m040580GL 4 Idle 00A=14 R=1!TP00m050080GL5 Idle 00A=15 R=1!TP00m050180GL6 Idle 00A=15 R=1!TP00m050280GL7 Idle 00#TP07Q81!TP00m050380GL8 Idle 00A=15 R=1!TP00m040280GL1 Idle 00!R802Q!TP00m040380GL2 Idle 00#TP09Q7F!TP00m040480GL3 Idle 00!R803Q!TP00m040580GL 4 Idle 00#TP08Q80!TP00m050080GL5 Idle 00
    12/7/2008 2:46:59 PM - RCS Serial Thermos - Error in Poll Thread, Argument 'Start' must be greater than zero.
    12/7/2008 2:47:09 PM - RCS Serial Thermos - !TP00m050180GL6 Idle 00!KL02R!TP00m050280GL7 Idle 00!KL0FR!TP00m050380GL8 Idle 00!R809Q!TP00m040280GL1 Idle 00!AI06Q!TP00m040380GL2 Idle 00A=1 R=1!TP00m040480GL3 Idle 00!KL01R!TP00m040580GL 4 Idle 00!KL08R!TP00m050080GL5 Idle 00!R805Q!TP00m050180GL6 Idle 00A=1 R=1!TP00m050280GL7 Idle 00A=1 R=1!TP00m050380GL8 Idle 00!TP00P050e2f!R80CQ!TP00W1044A=2 R=1!TP00m040280GL1 Idle 00A=2 R=1
    12/7/2008 2:47:09 PM - RCS Serial Thermos - Error in Poll Thread, Argument 'Start' must be greater than zero.

    #2
    Did you set the comport via the setup > Interfaces tab?
    -Rupp
    sigpic

    Comment


      #3
      Originally posted by Rupp View Post
      Did you set the comport via the setup > Interfaces tab?
      Yes - COM2.

      I have tried 2 other RS485 to RS232 converters with the same results. I have tried a single zone controller alone as well as all of them on the hub with no luck either way.

      Comment


        #4
        Are you running the latest version of this plugin from the HomeSeer updater?
        -Rupp
        sigpic

        Comment


          #5
          Originally posted by Rupp View Post
          Are you running the latest version of this plugin from the HomeSeer updater?
          Yes - 2.4.0.2

          thanks for your interest

          Comment


            #6

            Comment

            Working...
            X