Announcement

Collapse
No announcement yet.

Initial Release.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Hi Smargi,

    Thanks for the message, The Plugin should open up a Synchronous link to the aircon, So in theory it should be updating automatically... I did have some trouble with some of my older units originally where they didn't have the outdoor temp sensor, Ultimately if they where left for a while with no changes the connection dropped... Where my newer units were ok.

    I will have to make a change and allow the plugin to poll the status at set intervals to keep the connection alive.

    I will make the changes ASAP and get an update out, Apologies for the inconvenience.

    I'm working on the plugin anyhow to get it working on Linux, so it shouldn't be long.

    Apart from that how are you finding the plugin?

    Thanks
    Mat

    Comment


    • #32
      Hi.

      First thanks for the quick answer the plugin is great and been looking for this for a long time to control my air conditioner within homeseer.
      one thing more don't know if it as to do with your plugin or not I'm using imperihome plugin for the homeseer interface and it seems like imperihome doesn't find or see your plugin controls to operate it within imperihome like other devices ( hue, shutters .... ).

      Shay.

      Comment


      • #33
        Hi Shay,

        Thanks for the Note, I have changed the plugin to allow polling every 30 seconds on a 5 second device rotation, I have tested it for a couple days and its working ok, I will release it shortly.

        I am just working on some other changes to support linux to try and get them in the same update... But if the Linux doesn't play nice I will release it without linux support.

        Thanks
        Mat

        Comment


        • #34
          Hi All,

          Update on Linux Support :

          I have the plugin working now for the V2 protocol, This is tested and working well.

          However, the V1 protocol presents an issue, They will not connect under the Mono Linux SSL due to being SSLV3 which is not supported any more, It tries to connect as TLS but errors as the security key is not high enough.

          I have had some success connecting directly from Linux with Openssl, But getting this to work through the plugin is something i just have not been able to nut out, I cannot force the Cipher type in .Net which is the problem.

          I am still investigating and will keep you all updated.

          This will affect older Systems and the Washing Machines, So i am hoping to resolve it.

          Thanks
          Mat

          Comment


          • #35
            Hi All,

            I have just Submitted a new version of the plugin which supports Linux. V1 protocol is still an issue in Linux and is unsupported at this time...

            I have also mad a change to enable a log session of the data between devices, Which should enable me to add support for other devices or individual settings on units like Central Air Con, To enable this head to the config page, Do not enable this forever, it will not write to the HS log, it creates a Text file that you can download and send to me for debugging.

            As mentioned I also enabled a polling feature with adjustable time to support older units that drop connection.

            Any feedback or issues please let me know.

            Thanks
            Mat

            Comment


            • #36
              Any think new on the washer. It is cloud base.

              Comment


              • #37
                Hi RK15,

                Unfortunately not, Its not available in Aus so i am unable to test it and reverse engineer the protocol.

                If you can reverse the protocol and do the testing I would be happy to add support to the plugin?

                Thanks
                Mat

                Comment

                Working...
                X