Announcement

Collapse
No announcement yet.

crash after update 3.0.9.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • crash after update 3.0.9.1

    after update in 3.0.9.1 the plugin crash with error :
    WARNING: Failed getting InterfaceStatus from SDJ-VStat - the interface was not found in the list of active interfaces, the list may need to be refreshed.

    thanks for help

  • #2
    Originally posted by did36 View Post
    after update in 3.0.9.1 the plugin crash with error :
    WARNING: Failed getting InterfaceStatus from SDJ-VStat - the interface was not found in the list of active interfaces, the list may need to be refreshed.

    thanks for help
    Did you disable the plug-in before updating?
    Quite often with HS3 you will get this type of error when you update when it tries to update a running plug-in..
    Try clicking on disable and then updating again. If that doesn't work try shutting down HS3 and restarting and see if the plug-in starts up. You might have to enable the plug-in after restarting HS3.

    Let me know how you get on.

    Steve

    Comment


    • #3
      Did you disable the plug-in before updating? yes

      test 1 :
      disable plugin
      stop hs3
      start HS3
      install plugin
      same error

      test 2 :
      disable plugin
      delete plugin in hs3
      stop hs3
      start HS3
      install plugin
      same error

      log HS3 :


      Initializing plug-in(2): SDJ-VStat Instance::La conversion de la chaîne "0.19" en type 'Double' n'est pas valide.STACK: Server stack trace: Exception rethrown at [0]: à System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) à System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) à HomeSeerAPI.IPlugInAPI.InitIO(String port) à Scheduler.clsHSPI.CheckInterfaces()

      Comment


      • #4
        OK, you've tried everything there.
        Please can you post your system details from the Tools>About Homeseer menu.

        Steve

        Comment


        • #5
          works after change decimal from "," to "."

          Comment


          • #6
            Originally posted by did36
            Current Date/Time: 05/02/2019 17:49:17
            HomeSeer Version: HS3 Pro Edition 3.0.0.500
            Operating System: Microsoft Windows Server 2012 R2 Standard - Domain Controller
            System Uptime: 0 Days 0 Hours 11 Minutes 28 Seconds
            IP Address: 192.168.1.10
            Number of Devices: 318
            Number of Events: 19
            Available Threads: 200
            HSTouch Enabled: True
            Event Threads: 0
            Event Trigger Eval Queue: 0
            Event Trigger Priority Eval Queue: 0
            Device Exec Queue: 0
            HSTouch Event Queue: 0
            Email Send Queue: 0
            Anti Virus Installed:
            In Virtual Machine: No MFG:
            Enabled Plug-Ins
            2.9.1.0: InControl Server
            1.0.0.0: InControl WinPhone
            1.0.0.0: InControl WinStore
            1.0.0.1: IPX800
            3.0.0.14: NetCAM
            3.0.6.8: SDJ-Health
            3.0.9.1: SDJ-VStat
            3.3.5.17921: SMS-Gateway
            3.2.0.1: SqueezeBox
            3.0.1.252: Z-Wave
            I've edited out the Helpdesk output from your previous posts as that has your license details in it.
            The error is caused by the fix I added for where one or two users had switched their system from European comma to US period decimal place after installing the plug-in. I tested it all by switching locale's on my system back and forth and the change worked, but it is obviously throwing an error on yours, and potentially others.

            I will look into this and post a better fix.

            Sorry for your trouble.

            Steve

            Comment


            • #7
              thanks for all ….. I love your plugin :-)

              Comment


              • #8
                Originally posted by did36 View Post
                thanks for all ….. I love your plugin :-)
                I’m glad you can still say that🙂
                I will post another update tonight.
                Steve

                Comment


                • #9
                  I am posting version 3.0.9.2 to the updater to correct the bug I introduced in 3.0.9.1.
                  It might be a day or two until it appears so in the meantime I've attached the HSPI_SDJ-VStat.exe file for 3.0.9.2. to this post. If you have updated to 3.0.9.1. and the plugin won't run then unzip and copy this exe file over the one in the HS3 root folder and the pi should start ok.

                  Sorry for any inconvenience.

                  Steve

                  Update
                  3.0.9.2. is available in the updater now so I have removed the attachment from this post.

                  Comment


                  • #10
                    update works fine

                    thanks

                    Comment


                    • #11
                      Originally posted by did36 View Post
                      update works fine
                      Thanks for the confirmation.

                      Steve

                      Comment

                      Working...
                      X