Announcement

Collapse
No announcement yet.

Control devices that aren't On/Off

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Control devices that aren't On/Off

    I'm thinking of updating the plug-in so that the device controlled by a VStat doesn't have to be an On/Off device. This is already possible but currently requires a virtual device and events. I will need to add a options where you can configure the Control Values of the control child device.

    ZoRaC
    Referring to your other post where you say you are using VStats to control the SetPoint of physical thermostats can you post a screenshot of the graphics tab of one of the devices you are controlling. Thanks.

    Steve

  • #2
    Originally posted by SteveMSJ View Post
    ZoRaC
    Referring to your other post where you say you are using VStats to control the SetPoint of physical thermostats can you post a screenshot of the graphics tab of one of the devices you are controlling. Thanks.

    Steve
    Sure!
    Click image for larger version

Name:	9BD58EB2-AD31-4AE6-A241-6E22AC6D457E.jpeg
Views:	119
Size:	127.8 KB
ID:	1343914 ​​​​​​​

    Comment


    • #3
      Originally posted by ZoRaC View Post

      Sure!
      Thanks, I'll notify you when I have something ready for testing.

      As usual the operation is relatively simple to implement, it's the configuration and UI that takes the time.

      ​​​​​​​Steve

      Comment


      • #4
        Originally posted by SteveMSJ View Post

        Thanks, I'll notify you when I have something ready for testing.

        As usual the operation is relatively simple to implement, it's the configuration and UI that takes the time.

        Steve
        Hi ZoRac,

        I have this implemented and running now. Once I have finished testing it myself I'll release a beta update here before posting it to the updater. I'm not allowed to post to the beta section of the updater because I don't charge for my plug-ins. I'm not sure why that restriction applies but it does.

        Steve

        Comment


        • #5
          Originally posted by SteveMSJ View Post

          Hi ZoRac,

          I have this implemented and running now. Once I have finished testing it myself I'll release a beta update here before posting it to the updater. I'm not allowed to post to the beta section of the updater because I don't charge for my plug-ins. I'm not sure why that restriction applies but it does.

          Steve
          ZoRaC

          If you have a chance can you test the new update attached to this email? It's primarily to add the ability to control devices that aren't just On/Off so your setup would be ideal to test. I have been running for a week now with no issues so hopefully it shouldn't cause any problems but I suggest you shut down HS3 and do a full back up of your HS3 directory before updating. It does change the data format stored in the VStat devices so you can't roll back the plug-in. As I don't charge for my plug-ins Homeseer don't let me post to the beta section of the updater but I'd rather it was tested a bit more before a general release.
          • To make all control devices appear in the selection list for a VStat Control device uncheck the new 'Limit Control to On/Off' global parameter.
          Click image for larger version

Name:	Limit control.JPG
Views:	79
Size:	11.1 KB
ID:	1346592
          • After selecting the device you want to control for a VStat deselect the 'By ControlUse' checkbox.
          • Then enter the control values you want to use in the 'On' and 'Off' boxes.
          Click image for larger version

Name:	control values.JPG
Views:	130
Size:	20.6 KB
ID:	1346591
          • When you enter a value it will interrogate the device and show the status for that value alongside the boxes so you know that you have entered a valid value. In your case, if you enter 1 and 2 you should see Heat and Cool displayed alongside the boxes.
          Also included in this update is an option to Ignore Dead Sensors for VStats using multiple temperature sensors. It is a new global option where you set the number of hours (can be a decimal so not limited to a whole number of hours) of no temperature change after which a sensor will be considered to be dead. Any sensors not changed in this time frame will be considered dead and ignored when computing the Lowest, Average or Highest value for the Current Temperature. As soon as the sensor receives an updated value it will be considered alive again. Any dead sensor references are shown in red text in the VStats root device string for information.

          Click image for larger version

Name:	Ignore.JPG
Views:	78
Size:	13.9 KB
ID:	1346593

          Also added is a new feature whereby if no internal temperature sensors are selected for a VStat then the Current Temperature child will have controls so it can be set manually or from events. As soon as a temp sensor is selected the controls disappear.

          Click image for larger version

Name:	Temperature.JPG
Views:	77
Size:	9.5 KB
ID:	1346594


          To test this update, first back everything up then:
          • Disable the SDJ-VStat plug-in.
          • Download the attached zip file (SDJ-VStat_Download_3_0_9_6.zip) and open it.
          • Copy the 'updater_overide.txt' file to your root HS3 folder.
          • Copy the 'SDJ-VStat_3_0_9_6.zip' file to your '//Homeseer HS3/Updates3/Zips' folder.
          • Go to >Plug-ins>Manage and click on Update Listing and then Additional Interfaces.
          • You should just get an option to tick and install the local SDJ-VStat plug-in.
          • Re-enable SDJ-VStat.
          There is an updated guide installed in your /Docs folder.

          Note that this update changes the data format stored in the VStats so the VSTAT_Schedule.exe program is also updated. If you use this and you run it from anywhere other than the HS3 root directory you will need to replace it with the new version which has been installed in the HS3 root directory.

          Let me know how you get on.

          Steve
          SDJ-VStat_Download_3_0_9_6.zip

          Comment


          • #6
            Would this update allow for control of a variable speed fan or pump? IE: set %Value for fan\pump speed for high\low\frost settings?

            Comment


            • #7
              Originally posted by Atticka View Post
              Would this update allow for control of a variable speed fan or pump? IE: set %Value for fan\pump speed for high\low\frost settings?
              It’s geared to the control device, effectively calling for heat or not, therefore 2 states. Those 2 states could be %values for fan or pump speeds or valves.

              Steve

              Comment


              • #8
                Just updated yesterday and this seems to be working great, so far! A super addition to a great plugin! I’m running on Linux, btw.

                One bug though - the PayPal “donate” button isn’t displayed anymore (but luckily, it shows the “alt-text” and is clickable).

                Happy holidays!

                Comment


                • #9
                  Originally posted by ZoRaC View Post
                  Just updated yesterday and this seems to be working great, so far! A super addition to a great plugin! I’m running on Linux, btw.
                  Thanks for the feedback.

                  Originally posted by ZoRaC View Post
                  One bug though - the PayPal “donate” button isn’t displayed anymore (but luckily, it shows the “alt-text” and is clickable).
                  Thanks for the heads up on that, what browser are you using? I have tested on Chrome and Edge and I have just checked on Safari on my iPhone and it shows correctly. However, my HS3 is running on windows, I wonder if it something to do with that. I used to have a test system set up on a raspberry pi, I must recreate that so I can test.

                  Thanks,

                  Steve

                  Comment


                  • #10
                    Originally posted by SteveMSJ View Post
                    Thanks for the heads up on that, what browser are you using? I have tested on Chrome and Edge and I have just checked on Safari on my iPhone and it shows correctly. However, my HS3 is running on windows, I wonder if it something to do with that. I used to have a test system set up on a raspberry pi, I must recreate that so I can test.

                    Thanks,

                    Steve
                    The icon is displayed now. Must have been a small “glitch”.

                    Comment


                    • #11
                      SteveMSJ updated to beta plugin you provided me for Health, and the donate button was gone as well only showing "alt" text. One refresh later and PayPal button icon was back, so it didn't bother me, but I'm on Windows for HS3, and Windows+FireFox for the client that had GUI open in browser. Did not have F12 open, so will be difficult to explain in detail what was causing the issue, but it does exist and seems to resolve itself quickly.

                      I'll have to remember to keep F12 open next time I install update, and go into config page.

                      Comment

                      Working...
                      X