Announcement

Collapse
No announcement yet.

SDJ-VStat in HS4

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SDJ-VStat in HS4

    WARNING: SDJ-VStat needs to be version 3.1.0.5 or higher to operate successfully in HS4. If upgrading from HS3 make sure you install and enable 3.1.0.5 or higher in HS3 before upgrading to HS4.

    If you have already installed HS4 and don't want to step back, update and re-import your HS3 database, then just update to 3.1.0.5 in HS4. Your VStats should still be there but you may need to update the configuration for each one, e.g. input sensors, schedules, etc.

    Prior to 3.1.0.5 there can be an issue with HS corrupting the plugExtraData PED stored in the VStat root devices when it converts it from the HS3 HSD database to the HS4 JSON storage. I have changed the format of the PED data in SDJ-VStat version 3.1.0.5. to work around the issue.

    This is still an HS3 legacy plug-in and whilst I intend to produce a native HS4 version eventually there is no ETA for this as it is a mammoth task.

    Thanks,
    Steve

    #2
    Originally posted by SteveMSJ View Post
    WARNING: SDJ-VStat needs to be version 3.1.0.5 or higher to operate successfully in HS4. If upgrading from HS3 make sure you install and enable 3.1.0.5 or higher in HS3 before upgrading to HS4.

    If you have already installed HS4 and don't want to step back, update and re-import your HS3 database, then just update to 3.1.0.5 in HS4. Your VStats should still be there but you may need to update the configuration for each one, e.g. input sensors, schedules, etc.

    Prior to 3.1.0.5 there can be an issue with HS corrupting the plugExtraData PED stored in the VStat root devices when it converts it from the HS3 HSD database to the HS4 JSON storage. I have changed the format of the PED data in SDJ-VStat version 3.1.0.5. to work around the issue.

    This is still an HS3 legacy plug-in and whilst I intend to produce a native HS4 version eventually there is no ETA for this as it is a mammoth task.

    Thanks,
    Steve
    Incompatibility problems appear to have resurfaced with HS4 4.1.5.0. I will update this thread when I know more.

    Steve

    Comment


      #3
      Originally posted by SteveMSJ View Post

      Incompatibility problems appear to have resurfaced with HS4 4.1.5.0. I will update this thread when I know more.

      Steve
      Homeseer think they have found and corrected the bug in HS4 causing issues with thermostat plug-ins that store PED information in their root devices. Hopefully the issue is cured in HS4 4.1.5.1 and beyond.

      Steve

      Comment

      Working...
      X