Announcement

Collapse
No announcement yet.

Polling time

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Polling time

    Spud,

    I've installed your trial plugin yesterday and have these questions :

    1 - The plugin is relying on polling while Neviweb seem to be updating almost instantly with push data. Is this an API limitation or was there other programming reasons being considered. I tried putting the "Poll" to zero but no luck. I'm moving from Stelpro Ki to Sinope because they have in floor heating TStat with 2nd stage output and long cycle capability. What I really liked about the Ki was the immediate values broadcast and update.

    2 - This one might be related to HS UI or my current understanding of it. I wanted to fine tune the "Status graphic" properties and the more I try to either change them or even bring them back to their initial values, the more they look weird. In short, are you managing these properties beyond their initial creation? I will probably end-up deleting the root device and re-discover it.

    Thanks.

  • #2
    1. It's an API limitation, value changes associated to thermostats are not pushed. If you set poll to 0 it will totally stop polling, the minimum poll interval you can set is 1 minute.

    2. The devices status graphics properties are updated by the plugin if it detects you have upgraded the plugin version. To get the initial values, delete your devices and restart the plugin, it will recreate them.

    Comment


    • #3
      I don't like the idea of polling every minute. I will be trying out these thermostats this weekend. So, if I get this right by putting the value to 0 there will be no polling. Now if I want to set a manual poll how can this be done? Is there a command string that can be sent?

      Comment


      • #4
        Originally posted by Jack View Post
        I don't like the idea of polling every minute. I will be trying out these thermostats this weekend. So, if I get this right by putting the value to 0 there will be no polling. Now if I want to set a manual poll how can this be done? Is there a command string that can be sent?
        Why don't you like to poll? The polling interval is configurable so you can set it to any number of minutes.

        Right now there is no way to do a manual poll ( except by changing the GT125 device Home/Away status, which forces a poll), but I could add that as a an event action.

        Comment


        • #5
          Tried the Sinope and your plugin. I can do everything I want to do, so I will be deploying it. I would still want to do polls on demand. 2 situations when that would happen:
          1 when I would be applying rules
          2 when I am in HS3 Touch I could do a manual refresh

          There must be another way to refresh other than doing home-away? Would that be a request to make to Sinope?

          Other question. To enroll I need to give the GT125 IP address to the plug in. How can I make this failproof ifever there is a change in DHCP. I cannot give the GT125 q static address.

          Thanks for the great plugin!

          Comment


          • #6
            Originally posted by Jack View Post
            Tried the Sinope and your plugin. I can do everything I want to do, so I will be deploying it. I would still want to do polls on demand. 2 situations when that would happen:
            1 when I would be applying rules
            2 when I am in HS3 Touch I could do a manual refresh

            There must be another way to refresh other than doing home-away? Would that be a request to make to Sinope?

            Other question. To enroll I need to give the GT125 IP address to the plug in. How can I make this failproof ifever there is a change in DHCP. I cannot give the GT125 q static address.

            Thanks for the great plugin!
            I will add a Poll action in the next version of the plugin

            Regarding the GT125 IP, are you sure you can't assign a static address?

            Comment


            • #7
              Originally posted by spud View Post
              I will add a Poll action in the next version of the plugin



              Regarding the GT125 IP, are you sure you can't assign a static address?
              cheeryfool

              Comment


              • #8
                Contacted Sinope and IP can be set to static. Here is how. On the same network as the GT125 type:
                http://rfgateway/eth_ip.htm

                Leave the user id blank and password is admin and do the change

                Comment


                • #9
                  Originally posted by spud View Post
                  I will add a Poll action in the next version of the plugin

                  Regarding the GT125 IP, are you sure you can't assign a static address?
                  thanks!!!

                  Also contacted Sinope and manged to change IP to static. I just posteed above how to do it

                  Comment


                  • #10
                    in version 3.0.010 available here I added a "Poll Devices" action

                    Comment


                    • #11
                      hmm. Tried to install 3.0.0.10 on my zee S2. I need the root access to the location where to copy the files. I am still in my Linux learning curve. I am logging in with my homeseer id with winscp. I guess I need to access in terminal mode and sudo. I just dont want to brick my unit.

                      Comment


                      • #12
                        Originally posted by Jack View Post
                        hmm. Tried to install 3.0.0.10 on my zee S2. I need the root access to the location where to copy the files. I am still in my Linux learning curve. I am logging in with my homeseer id with winscp. I guess I need to access in terminal mode and sudo. I just dont want to brick my unit.
                        yeah, you need to upload the files anywhere on your Zee, then ssh to it using putty and then use the "sudo cp" command line to copy them in the correct directory.

                        if you don't want to mess with that, just wait (a few weeks) for this version to be in the updater.

                        Comment


                        • #13
                          Ok, thanks! I will play it safe and wait. Are you going to make it available in the Beta area?

                          Comment


                          • #14
                            I just installed 3.0.0.10 using Putty. everything went fine. Where is the polling event??

                            Comment


                            • #15
                              oops, it appears under Autelis Action, bad copy/paste from another of my plugin. Sorry for that, I will fix it in the next version.

                              Even if the name is wrong, the action should work though.

                              Comment

                              Working...
                              X