Announcement

Collapse
No announcement yet.

Error when setting tado overide mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when setting tado overide mode

    I get the follow error:

    dec-13 13:04:17 Tado DEBUG bij System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt) bij System.Double.Parse(String s, NumberStyles style, NumberFormatInfo info) bij VqkusTA6GDPXVZC3lr.Tr2nfCGqw7TgF12iV2.aw78TgF12(strTrigActIn fo )
    dec-13 13:04:17 Tado ERROR De indeling van de invoertekenreeks is onjuist.
    dec-

    Country = Netherlands, dutch number format

    The tado goes to manual mode until user gets home, does not matter what mode i chose




    Please advise

    Attached Files

  • #2
    sorry i missed the notification for this message, i will look into it now.

    Comment


    • #3
      Thanks,

      When i set the setpoint tado action goes into automatic, The set to "Revert to tado schedule" does not work


      Click image for larger version

Name:	reset tado.jpg
Views:	10
Size:	71.8 KB
ID:	1276550

      But this event does work to get it back into default tado schedule.
      the command tado set thermostat gives error

      but after that the set device schedule mode to "Revert to tado schedule" does work (after waiting min of 10 sec)

      so i do have a work around to get from automatic to tado schedule after a change to setpoint.

      The funny thing is, everything works good for hot water.

      If i change the settings via the tado app, they are given correctly in Homeseer

      Comment


      • #4
        have just started to play with this plugin and have run into the same issue...any news on a fix?

        Comment


        • #5
          I have fixed the issue setting the Mode to Off from the Tado Set Thermostat Action

          you can just replace the EXE and DLL from the attached zip. otherwise please wait and this version will appear in the Beta section of the homeseer updater.

          please test and feedback if this resolves your issue.
          Attached Files

          Comment


          • #6
            Hi ya,

            Have just tried...I get a different error message...
            Jan-20 16:27:40 Tado DEBUG at rauRKoe9Fi5vpMlx5t.yTYvV6GWP0Ww1wfCx1.wP0IWw1wf(strTrigActIn fo )
            Jan-20 16:27:40 Tado ERROR Object reference not set to an instance of an object.

            Comment


            • #7
              Please confirm you are running v1.0.0.260? can you also send me a screen grab of your event, or indeed let me know exactly what you were doing when you hit this error.

              Comment


              • #8
                Its clearly me...its still reporting
                1.0.0.254

                Comment


                • #9
                  nope I restarted HS...and it picked it up correctly but I am still getting the error. I created this as a Manual event

                  Comment


                  • #10
                    ok can you confirm what device Chris Bedroom is?

                    Comment


                    • #11
                      Sure..hope this helps...I get the same with the hot water

                      Comment


                      • #12
                        ok pretty sure this is now fixed for Heating and Hot Water now in the attached version. please check and let me know and i will push this version to the updater.
                        Attached Files

                        Comment


                        • #13
                          Magic thanks that's fixed that. However, when run the event to switch off the heating...everything is reflected correcting in Tado…"Chris Bedroom Off until you cancel" which is perfect. However, what I don't understand the status in HS still shows...."
                          Tado Schedule Active"

                          Comment


                          • #14
                            the actions don't automatically trigger a status refresh, my thinking behind this was that the event is an automatic action so the update of the device status can wait until the next refresh. this just reduces the frequency of traffic and updates. so at the next refresh interval (within 5 minutes) it will get the correct status (i've confirmed this is the case here on my TRV and Heating devices)

                            Comment


                            • #15
                              I wil try tonight and report back if all the issues have been fixed.

                              Small feature request: is it posible to get a "extra"device to state if the user changed setting on the phone instead of via HS ? (i know use the settings timer and user with a script)

                              Comment

                              Working...
                              X