Announcement

Collapse
No announcement yet.

Error when setting tado overide mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Red64 I don't quite understand what you mean by change setting on the phone instead of HS?
    There's no way I can track how a status is set. The API doesn't provide this functionality.

    Trying to introduce one by tracking what commands were sent by HS and tallying that up across each and every refresh would be an expensive process in memory and additionally iit would require a method to track across plugin restarts. I'm not sure the benefits would be worth the performance impact.

    Unless I've misunderstood what you meant

    Comment


    • #17
      fuzzysb Thanks, if you dont ask you dont get a answere,

      i was thinking of tracking, but did not know it was that resource intensive.

      I will test the new version tonight, and report back.

      Comment


      • #18
        Yup unfortunately because the Tado API doesn't contain this info I would need to invent a mechanism for it. I'm just not sure it's worth the pain, and isn't with it unless I could guarantee the info would be accurate

        Comment


        • #19
          fuzzysb Hi, i no longer get errors but:
          1) set mode = Off is working




          2) set Mode is Heat is not working, meaning that the tado is not set from off to heat. setting "revert to tado schedule" does work

          Click image for larger version  Name:	heat.jpg Views:	1 Size:	48.5 KB ID:	1277980


          o and yes i have waited 10 min to see if changes where made in tado (disregard the 1 min in the screenshot)

          Attached Files

          Comment


          • #20
            Ok thanks for the feedback I will troubleshoot this evening and provide a new beta

            Comment


            • #21
              Red64 New Beta v1.0.0.268 is live in the Beta section, please update and try again using the Heat Action, be warned though that the action was missing prompting for the temperature, so you will most likely have to recreate your Heating actiosn and ensure you specify the temperature

              Comment


              • #22
                fuzzysb i missed your message, i will try right away

                Comment


                • #23
                  fuzzysb I did my test script:

                  the issues i found where:
                  1) (Severe problem for me) it is no longer posible to set heatpoint via script to value with decimals for instance 20.4C
                  2) Set thermostat heat now working (both timer and manual), but with timer the set amount of minutes is not always send to the thermostat. It then uses the default of 60 min. (This might be issue with the new tado app and not the plugin; no big deal, my script would kick in again after 62 min)
                  3) Set thermostat off not working, workaround set thermostat heat 16c does work
                  4) when using set thermostat heat it is no longer posible to change the heat setpoint after 30 sec (it changes in HS, but not on thermostat. HS is overwritten with Thermostat value)

                  Changing heatpoint still works when outside set thermostat, with the execption off decimal vaues. Yes + and - do work but not if used more then once every few minutes. This is the reason why i used a script to set the decimal value)

                  Thank for all the effort you put into it to make this even better.

                  Henk

                  Comment


                  • #24
                    fuzzysb Hi,

                    Just some background info.

                    I have a tado thermostat, a nefit gas heating and a Techneco Elga heat pump.

                    Below 4c the elga no longer works properly and it will pass the heating commands to the Nefit, becouse of this the room temp jump from 1c to high to 1c to low. I intercept this by changing the tado setting via homeseer. The temp i want in the livingroom is 20.4c.

                    One problem witrh the elga is that if you change the heat setpoint it will shut down for 10 min and start again, so using + or - to go from 20 to 20.4 over several minutes is not realy a option, and becouse the elga send the command to the Nefit this also shuts down for 10 minutes after every set heatpoint command

                    Henk

                    Comment


                    • #25
                      I will hopefully be able to work on your points over the next few days, and release a new beta.

                      Comment


                      • #26
                        fuzzysb A small update
                        For point 1 and point 4; after a periode of minimum of 5 min 30 sec (the refresh time) both set decimal and change heatpoint do work if you wait that long; before that time they are overwritten by the value of the theromastat itself (set with the "set thermostat heat" command)

                        I hope this info helps

                        Henk

                        Comment


                        • #27
                          Red64 i'm trying to get a handle on your issues. my apologies for the delay, however i am time poor at the moment and have had the perfect storm of all of my plugins having bugs ive needed to squash and i have had to prioritise accordingly. but i suspect your main issues prescribe from the event usage does not trigger a refresh of the status immediately (this was by design just to keep the number of requests to a minimum and to prevent overlapping refresh requests, my reasoning was that these are automated actions so a timely refresh wouldn't be necessary), but since this is causing you issues i will trigger a refresh as soon as the events actions have finished.

                          The last point is that the events don't support decimal places, you are correct and i will get onto this point so it does take note of the minimum step setting within the settings page.

                          I will again check the off command, however with the latest version v1.0.0.268 this definitely works turning off both my Tado TRV and Tado Thermostats, so if it does not for you, please confirm the Version of the Beta version you are testing. also what devices you are testing against, and what Tado Version of the App you are using, is it v3 or v3+ ? and is your temp unit in C or F?

                          also could you provide the debug log from when you turn off the device, is there any errors or output?

                          Comment


                          • #28
                            Red64 ok don't worry about the off command. i think you mean using the off command from an event action? i've just seen that if you select Off for the zone it doesn't close the event action as complete. but if you set to heat first and select a temperature, then select off you can then press the arrow that completes the event then if you run that action it then works succesfully to turn the device off. its just evaluation rule for the event being completed that is an issue. I will get that fixed v soon

                            Comment


                            • #29
                              fuzzysb , from my point of view, you may prioritise all other issues first. Currently if have a workaround for all issues (via the plugin or outside Homeseer via IFTTT)
                              Regarding off setting: i use set heat to 12c and have effectively a off situation

                              I have the latest version of the app (yes i also paid money) and work in Celsius, my step setting is 0,1C

                              If you want me to test something for you just give a shout.

                              Henk

                              Comment


                              • #30
                                Red64 I have just pushed v1.0.0.186 Beta, please update to that version and check your last remaining issues, this version should fix these points, however i am working remotely on a VPN and debugging over that connection, so testing fully from my end is slow and laborious so i may have missed something, so again if you see any further issues please raise them.

                                the temp values in the event now respect the minimum Step value from the settings, with the exception if your device only support a step value by 1 degrees and no less, such as my Air Conditioner

                                Comment

                                Working...
                                X