Announcement

Collapse
No announcement yet.

PI Enhancement

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PI Enhancement

    Bob, Plug-in works great and has saved me many of time, is there anyway to add a manual back-up button to the PI that would create a back-up on demand. The reason is that when one does a number of changes to events, devices what ever, they would have to wait for a scheduled backup whereas if I know I've done changes I can save on the go mentality. Mike
    Computer: CUK Intel NUC7i7BNH
    Op System: Windows 10 Pro - Work Station
    HS Version: HS3 Pro Edition 3.0.0.435

    Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

  • #2
    Why not just run the event manually?

    Robert
    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

    Comment


    • #3
      While it would be very easy to create a separate virtual device and an event, I just modified the backup status device to have a 4th value of 3 for "Start" and removed the "Status Only" option.

      Click image for larger version

Name:	Capture1.jpg
Views:	1
Size:	36.1 KB
ID:	1196493

      Click image for larger version

Name:	Capture.jpg
Views:	1
Size:	9.4 KB
ID:	1196492

      Then I added a trigger to my backup event.

      Click image for larger version

Name:	Capture2.jpg
Views:	1
Size:	33.6 KB
ID:	1196494

      When I click on "Start" a backup is begun. The plug-in will take care of the status of the device.

      Click image for larger version

Name:	Capture4.jpg
Views:	1
Size:	11.3 KB
ID:	1196495
      Randy Prade
      Aurora, CO
      Prades.net

      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

      Comment


      • #4
        Randy,

        What Blbackup status device? I don't have any such device... Even checked with Jon's device script. Did you create this?

        Robert
        HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

        Comment


        • #5
          Originally posted by langenet View Post
          Randy,

          What Blbackup status device? I don't have any such device... Even checked with Jon's device script. Did you create this?

          Robert
          Per the instructions

          Click image for larger version

Name:	Capture5.jpg
Views:	1
Size:	10.6 KB
ID:	1196497

          I created the virtual device and entered the RefID in the configuration

          Click image for larger version

Name:	Capture3.jpg
Views:	1
Size:	26.6 KB
ID:	1196496
          Randy Prade
          Aurora, CO
          Prades.net

          PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

          Comment


          • #6
            Thanks Randy... I may have seen this, but it's been a long time.
            I like your mod for the device. You are the 'Event God!'

            Robert
            HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

            Comment


            • #7
              Randy, I agree with Robert.. "you be da Event man!". I like your virtual device approach rather than having to go to the PI and execute it. Mike
              Computer: CUK Intel NUC7i7BNH
              Op System: Windows 10 Pro - Work Station
              HS Version: HS3 Pro Edition 3.0.0.435

              Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

              Comment


              • #8
                Randy, I must be missing something, I created a virtual Device with the 4 values same as your example (see attached) and modified my backup event to include "Start" Trigger but when I select the Start on the VD it doesn't start the BLbackup but if I manually start the event it works like a champ. Mike
                Attached Files
                Computer: CUK Intel NUC7i7BNH
                Op System: Windows 10 Pro - Work Station
                HS Version: HS3 Pro Edition 3.0.0.435

                Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                Comment


                • #9
                  Originally posted by MNB View Post
                  Randy, I must be missing something, I created a virtual Device with the 4 values same as your example (see attached) and modified my backup event to include "Start" Trigger but when I select the Start on the VD it doesn't start the BLbackup but if I manually start the event it works like a champ. Mike
                  I have no idea why yours doesn't work. Mine has worked for a year or so and ran when I captured the screenshots above. Did the event trigger when you selected "Start"?
                  Randy Prade
                  Aurora, CO
                  Prades.net

                  PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                  Comment


                  • #10
                    Originally posted by rprade View Post
                    I have no idea why yours doesn't work. Mine has worked for a year or so and ran when I captured the screenshots above. Did the event trigger when you selected "Start"?
                    No the event did not trigger when I selected "Start" on the VD, in fact I put a start icon within the VD to change when Start was depressed but it did not change the VD status which I would have expected when depressed the start. I will explore some more, I could restart my HS3, I noticed that I'm have some TTS issues since updating to beta v.435 e.g. my Ultracid isn't announcing when I'm getting phone calls which was working back at beta v.425. I noticed that you have the "start" but with "unspecified" selected not sure what the difference between it and "On" is. Mike
                    Computer: CUK Intel NUC7i7BNH
                    Op System: Windows 10 Pro - Work Station
                    HS Version: HS3 Pro Edition 3.0.0.435

                    Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                    Comment


                    • #11
                      Originally posted by MNB View Post
                      No the event did not trigger when I selected "Start" on the VD, in fact I put a start icon within the VD to change when Start was depressed but it did not change the VD status which I would have expected when depressed the start. I will explore some more, I could restart my HS3, I noticed that I'm have some TTS issues since updating to beta v.435 e.g. my Ultracid isn't announcing when I'm getting phone calls which was working back at beta v.425. I noticed that you have the "start" but with "unspecified" selected not sure what the difference between it and "On" is. Mike
                      These things should happen
                      1. Select "Start" on the device and the change of status is logged
                      2. If the device change was logged, the log should show the event was triggered
                      3. The backup status device should change to a value of 2=In progress
                      4. After some time the status device will either show success or failure

                      Where is the failure in yours? Mine changes so quickly, I never see the icon go blank, as soon as I click Start the backup in progress icon shows.

                      Here is what happened with mine just now (newest at top):

                      Apr-23 2:43:42 PM BLBackup Info The backup process (Folder Tree - Full) has started at 4/23/2018 2:43:42 PM...
                      Apr-23 2:43:42 PM Event Event Trigger "Utilities - Backup BLBackup - Folder DS10"
                      Apr-23 2:43:42 PM Device Control Device: Utility Controls BLBackup to Start (3) by/from: CAPI Control Handler
                      Randy Prade
                      Aurora, CO
                      Prades.net

                      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                      Comment


                      • #12
                        Randy, when I enter start I only get the following:

                        Code:
                        Apr-23 16:56:03 	  	Device Control 	Device: Utility Controls Blbackup (folder) to Start (3) by/from: CAPI Control Handler
                        so it appears that the start action is being detected but the event isn't executing. maybe I should create a new event?
                        Computer: CUK Intel NUC7i7BNH
                        Op System: Windows 10 Pro - Work Station
                        HS Version: HS3 Pro Edition 3.0.0.435

                        Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                        Comment


                        • #13
                          Well, I went back to square one and re-created both a new VD and event and lo and behold I now have a working device/event. I'm not sure why (me thinks may have been corrupted trigger portion of the event) but I'm happy that its working, again thanxs Randy for a great tutorage example to be added to ones Home Automation tool box Mike
                          Computer: CUK Intel NUC7i7BNH
                          Op System: Windows 10 Pro - Work Station
                          HS Version: HS3 Pro Edition 3.0.0.435

                          Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                          Comment


                          • #14
                            Dumb question... why do I define the backup; format, type, directories and destination folder both within the event action and within the BLbackup PI? seems counter intuitive, am I missing something? Mike
                            Computer: CUK Intel NUC7i7BNH
                            Op System: Windows 10 Pro - Work Station
                            HS Version: HS3 Pro Edition 3.0.0.435

                            Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

                            Comment


                            • #15
                              Originally posted by MNB View Post
                              Well, I went back to square one and re-created both a new VD and event and lo and behold I now have a working device/event. I'm not sure why (me thinks may have been corrupted trigger portion of the event) but I'm happy that its working, again thanxs Randy for a great tutorage example to be added to ones Home Automation tool box Mike
                              Randy Prade
                              Aurora, CO
                              Prades.net

                              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                              Comment

                              Working...
                              X