Announcement

Collapse
No announcement yet.

Mapped Network Drive

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jimbell
    replied
    Originally posted by larrywal32 View Post
    I would like BLBackup to backup my Homeseer directory onto a server that I have on the network. That server is protected by domain credentials, so I created a mapped network drive (e.g. Z:\) on the Homeseer Hometroller that had the credentials baked in. When I navigate to the drive in Windows on the hometroller, it works fine. So the share and mapped drive are set up properly.

    But BLBackup doesn't seem to work with this. It won't accept the drive as a destination.

    Bug?
    The following only applies if you are using windows 7 as a host for HS3. (Not sure about Windows 8).
    HS3 runs as an elevated app.

    This behaviour is documented by Microsoft

    https://support.microsoft.com/en-us/...when-uac-is-co

    I used the registry edit method at the end of the article and now all the shares are seen by my elevated applications including HS3.

    Leave a comment:


  • jbfoster
    replied
    Originally posted by MattL0 View Post
    Event action : run program
    Still don't wok. Ill just keep using Onedrive.

    Jim

    Leave a comment:


  • MattL0
    replied
    Event action : run program

    Leave a comment:


  • jbfoster
    replied
    Originally posted by sparkman View Post
    I've found that Windows will "soft" disconnect mapped drives so I run a batch file before I have HS (or one of its plugins) try to use a mapped drive. The batch file is just something like this and is called from an event:

    Code:
    net use t: \\server\share
    t:
    How do I run the batch file from an Event?

    Thanks
    Jim

    Leave a comment:


  • sparkman
    replied
    I've found that Windows will "soft" disconnect mapped drives so I run a batch file before I have HS (or one of its plugins) try to use a mapped drive. The batch file is just something like this and is called from an event:

    Code:
    net use t: \\server\share
    t:

    Leave a comment:


  • jbfoster
    replied

    has this been figured out?

    I have a QNAP NAS that I want to save my BLBackups to. I have tried as a mapped drive but it says Backup folder does not exist. I wonder if it has something to do with needing a username and password.

    Thanks
    Jim

    Leave a comment:


  • larrywal32
    replied
    It's starting on startup of Windows

    Leave a comment:


  • shill
    replied
    How are you starting HS?

    Leave a comment:


  • larrywal32
    replied
    So - it was working for a while. Then the computer rebooted. I remapped the drive manually, but it's still failing. Tells me drive doesn't exist. But when I paste the path into start run, it finds it fine...

    Leave a comment:


  • shill
    replied
    What about putting something in startup scripts to map a drive? That way it would be in the context of the server's session...

    Leave a comment:


  • HS14
    replied
    I am having the same issue, I have my NAS mapped to N:\

    Then I tried:
    \\192.168.1.2\nas\Backups\HomeSeer 3 BLBackup

    It worked for a few days and then it stopped (after an BLBackup update I think), now when I try to enable debugging, it says "Backup folder does not exist!"

    Leave a comment:


  • larrywal32
    replied
    Ok - did it without quotes and it worked. Except...won't it fail using a UNC path like that because it won't have the credentials to connect after a reboot? That's why I wanted to use a mapped drive.

    Leave a comment:


  • larrywal32
    replied
    Will try - should I surround it in quotes (") if there is a space in the path?

    Leave a comment:


  • Blade
    replied
    That is odd - looks like it has an issue with Z:\HSBackups
    I mapped a network drive here as Z and used it in BLBackup and it seemed to take it
    Can you try referencing it as a UNC path to the server

    \\myserver\HSBackups

    Leave a comment:


  • larrywal32
    replied
    Sure. Done. Here you go.
    Attached Files

    Leave a comment:

Working...
X