Announcement

Collapse
No announcement yet.

Deleted the same days backup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • zwolfpack
    replied
    All makes sense now! Glad you got it working, thanks for reporting back.

    Leave a comment:


  • awhitton
    replied
    zwolfpack, really appreciate your help.

    So it would appear that the timeserver my Synology NAS was using by default pool.ntp.org no longer exists or is in another way defective. My NAS was rebooted after a power cut went beyond the life of my UPS on 16th October. On restart its time was 1/1/2001. So all the new backups were being made with very old timestamp. Not unreasonably then BLBackup was picking up these "really old" backups as the ones needing to be deleted. I have now pointed by NAS at time.cloudflare.com and all is working again. Stupidly I was looking at the time and date stamps in the file names not the actual time and date stamps of the files.

    Apologies for wasting your time but really appreciate the fact you sought to help.

    Cheers

    Andy

    Leave a comment:


  • zwolfpack
    replied
    Very strange...

    An obvious difference between yours an mine is that you're backing up to a network share vs. my local USB drive.

    I also have two weekly backups (Monday and Wednesday); those are behaving themselves as well.

    Are there any other files in the destination folder other than those from previous backups? Something might be confusing the choice of what to delete.

    There's an SQLite database located at <HS root>/Data/BLBackup/BLBackup.s3db. You might try removing that (halt the plugin first and keep a copy), then run a backup and see if anything changes. (I'm assuming that it will create a new database; if instead it errors out, you can reinstall the plugin to install a virgin database).

    All the configuration parameters are stored in <HS root>/Config/hspi_BLBackup.ini. Here's mine.

    Code:
    [Settings]
    debugLevel=false
    helpFolder=/BLHelp/
    backupProcessPriority=Normal
    createBackupLogFromBackupProcess=true
    zipFileCompressionLevel=6
    numberOfDaysToKeepLogFiles=30
    emailMethod=HomeSeer
    enableEmail=false
    emailBackupLogAttachmentWithoutHtml=false
    emailFrom=---
    supportForumUrl=http://forums.homeseer.com/forumdisplay.php?f=1057
    backupFolder=F:\BLBackup
    emailTo=---
    convertDirectoriesToKeysDone=true
    [BackupDir=B20170305T075219655]
    key=B20170305T075219655
    backupDirectory=C:\apcupsd
    frequency=Weekly (Monday)
    includeSubDirs=True
    LastBackupCompleted=11/2/2020 3:3:55
    numberOfBackupsToKeep=4
    computerName=hometroller
    [BackupDir=B20170305T075219546]
    key=B20170305T075219546
    backupDirectory=C:\Program Files\Homeseer HS3
    frequency=Daily
    includeSubDirs=true
    LastBackupCompleted=11/7/2020 4:9:52
    numberOfBackupsToKeep=30
    computerName=hometroller
    statusDeviceCode=866
    [BackupDir=B20180503T005334204]
    backupDirectory=C:\Users\homeseer\Downloads
    frequency=Weekly (Wednesday)
    includeSubDirs=true
    numberOfBackupsToKeep=4
    computerName=hometroller
    LastBackupCompleted=11/4/2020 4:22:58
    If all else fails, you could remove this config file and the database file, uninstall & reinstall the plugin and start from scratch.

    Leave a comment:


  • awhitton
    replied
    I have amended the retention period to 365 days. Stopped and started the plugin and restarted HS3 but the same thing is happening, its deleting the backup its just made:
    Code:
    Backup Log for 07/11/2020 18:29:24
    
    
    ** Backup process (One Zip File - FULL) has STARTED at 07/11/2020 18:29:24...
    
    Processing backup directory: C:\Program Files (x86)\HomeSeer HS3\scripts ( Frequency: Weekly (Monday); Include Sub Dirs: Yes )
    Computer Name: THBrixServer; Unique Alias: THBrixServerScripts
    Comment: Homeseer HS3 Scripts Folder
    Number of backups to keep: 20
    Zip File Path: \\192.168.1.240\Backup\HS3\THBrixServer\Weekly (Monday)\scripts_THBrixServerScripts_WEEKLY-MONDAY_2020-11-07_18-29-24_FULL.zip
    Zip Archive: \\192.168.1.240\Backup\HS3\THBrixServer\Weekly (Monday)\scripts_THBrixServerScripts_WEEKLY-MONDAY_2020-11-07_18-29-24_FULL.zip was DELETED
    52 files were processed
    0 files in use
    1 zip archive(s) deleted
    Backup time: 2 secs
    
    ** Backup process (One Zip File - FULL) has COMPLETED at 07/11/2020 18:29:26
    
    
    ** Backup process took 2 secs to complete!
    
    Total backup directories processed: 1
    Total files processed: 52
    Total files backed up: 52
    Total files in use: 0
    Total old backup logs deleted: 0
    Total zip archives deleted: 1

    Leave a comment:


  • zwolfpack
    replied
    Strange, mine is working correctly. Same plugin version 2.0.61.0; this version was posted 21 Aug 2019, over a year ago.

    Here is the most recent log, as you can see the deleted backup was 30 days prior.

    Code:
    Backup Log for 11/6/2020 3:02:30 AM
    
    
    ** Backup process (One Zip File - FULL) has STARTED at 11/6/2020 3:02:30 AM...
    
        Processing backup directory:  C:\Program Files\Homeseer HS3   ( Frequency: Daily;  Include Sub Dirs: Yes )
            Computer Name:  hometroller;  Unique Alias:  
            Comment:  
            Number of backups to keep:  30
            Zip File Path:  F:\BLBackup\hometroller\Daily\HomeseerHS3_DAILY_2020-11-06_03-02-30_FULL.zip
                    Zip Archive: F:\BLBackup\hometroller\Daily\HomeseerHS3_DAILY_2020-10-07_03-02-34_FULL.zip was DELETED
                    2,731 files were processed
                    0 files in use
                    1 zip archive(s) deleted
                    Backup time: 1 hrs, 6 mins, 23 secs
    
    ** Backup process (One Zip File - FULL) has COMPLETED at 11/6/2020 4:08:54 AM
    
    
    ** Backup process took 1 hrs, 6 mins, 23 secs to complete!
    
    Total backup directories processed:  1
    Total files processed:  2,731
    Total files backed up:  2,731
    Total files in use:  0
    Total old backup logs deleted:  1
    Total zip archives deleted:  1

    Leave a comment:


  • awhitton
    replied
    On my system it was set to 30 days. Although not sure that was doing anything as I have monthly backups going back 12 months and weekly backs going back 20 weeks (I had configed for 20 backup cycle on my weekly settings). All was fine until a few weeks ago.

    Leave a comment:


  • zwolfpack
    replied
    In the BLBackup options, what do you have set for 'Number of days to keep backup logs' ?
    Attached Files

    Leave a comment:


  • awhitton
    started a topic Deleted the same days backup

    Deleted the same days backup

    I have just had cause to want to restore the most recent database backup only to discover no backup files exist since 12th October. I think I upgraded to the latest version (2.0.61.0) about then. I am using HS3 (HS3 Pro Edition 3.0.0.548 (Windows)) Looking at the backup logs it seems like the backups were created but the process to delete the oldest backup selected the backup it had just made not the oldest one. Anyone else had this experience / know how to fix it?
Working...
X