Announcement

Collapse
No announcement yet.

Linux support coming?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux support coming?

    I installed BLBackup on my HS3 linux VM and it installs just fine. I setup an event and when I kick it off nothing happens. I'm running HS3 has linux user "hs3" out of the /home/hs3 directory. My backup destination directory is a NFS mounted directory on /home/bkup/hs3 which is user/group owned by hs3 with 664 permissions.

    Is Linux supported? If so, any log files I can look at to see what is happening (or not happening)?

    Thanks

  • #2
    It should work fine in Linux. I have it in Linux just fine.
    Check the [HS root]\bin\BLBlackup folder
    Tell me what is in that folder
    What DLLs exist in the hs3 root folder?
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      I included the home and backup directory information so you can see the user/group and permissions information for the HS3 installation and backup destination.

      root@p-vubuhs301:/home/hs3/HomeSeer/bin/BLBackup# ls -l /home | grep hs3
      drwxr-xr-x 3 hs3 hs3 4096 Jan 17 11:22 hs3

      root@p-vubuhs301:/home/hs3/HomeSeer/bin/BLBackup# ls -l /home/bkup | grep hs3
      drw-rw-r-- 2 hs3 hs3 4096 Jul 5 16:11 hs3

      root@p-vubuhs301:/home/hs3/HomeSeer/bin/BLBackup# cat /etc/fstab | grep bkup
      192.168.1.18:/volume1/nastest /home/bkup nfs nouser,rsize=8192,wsize=8192,atime,auto,rw,dev,exec,suid 0 0

      root@p-vubuhs301:/home/hs3/HomeSeer/bin/BLBackup# ls -l
      total 1792
      -rw-r--r-- 1 root root 200704 May 25 2010 ICSharpCode.SharpZipLib.dll
      -rw-r--r-- 1 root root 677376 Nov 13 2012 sqlite3.dll
      -rw-r--r-- 1 root root 700928 Feb 14 2014 SQLite.Interop.dll
      -rw-r--r-- 1 root root 249856 May 21 19:12 System.Data.SQLite.dll
      root@p-vubuhs301:/home/hs3/HomeSeer/bin/BLBackup#
      And some screen shots of my BLBackup setup
      Attached Files

      Comment


      • #4
        I just tried to run the backup again and am getting this message in the log... strange that I didn't get this message yesterday.
        Jul-06 11:00:51 AM BLBackup Warning You have not set a backup folder for the plug-in. Please specify the backup folder on the Options page!
        I changed the permissions to 777 for the /home/bkup and /home/bkup/hs3 directories just to make sure I didn't have an issue there... still not working. Does it matter that /home/bkup is a NFS mount?

        root@p-vubuhs301:/home# ls -l /home | grep bkup
        drwxrwxrwx 17 hs3 hs3 4096 Jul 6 01:19 bkup

        root@p-vubuhs301:/home# ls -l /home/bkup | grep hs3
        drwxrwxrwx 2 hs3 hs3 4096 Jul 5 16:11 hs3

        root@p-vubuhs301:/home# ls -l /home/bkup/hs3
        total 0

        Comment


        • #5
          You need to set a destination folder in the options page.
          Is one set?
          I ran another backup on my PI2 this weekend and it worked fine
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6
            That was it - all fixed. I thought putting the "Destination Folder" in the "Backup Directories" configuration screen was where that was setup. Thanks for clarifying. All is good. Thanks!!

            Comment


            • #7
              You need a destination folder in the main options page
              If you put one in the event action it will use that otherwise it will use the one in the options
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment

              Working...
              X