Announcement

Collapse
No announcement yet.

Google shutting down third party app access using traditional login on May 30

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Google shutting down third party app access using traditional login on May 30

    I got the following email the other day. Is there a way around this to use this plugin? If so, can you provide instructions? Thanks

    ---------------------------------------------------------------------------------------------------------------------------------------------------------
    On May 30, you may lose access to apps that are using less secure sign-in technology

    To help keep your account secure, Google will no longer support the use of third-party apps or devices which ask you to sign in to your Google Account using only your username and password. Instead, you’ll need to sign in using Sign in with Google or other more secure technologies, like OAuth 2.0.
    What do you need to do?
    An app or device which uses Simple Mail Transfer Protocol (SMTP) to send emails using your Google Account has less secure access to your Gmail. This might be an older device, like a printer or scanner. To continue using your Google Account with this app or device:
    • App - Remove your Google Account from the app or device and sign in again using Sign in with Google
    • Device - Change your device’s settings so you’re using more secure sign-in technology

    #2
    yes good question...I saw that email too and was wondering

    Comment


      #3
      Have you tried setting up an App password in your google account?
      I had to do this for my Acronis backup emails as well as my BLEmail plugin in HomeSeer

      https://myaccount.google.com/apppasswords

      Cheers,
      Bob
      Web site | Help Desk | Feature Requests | Message Board

      Comment


        #4
        Originally posted by Blade View Post
        Have you tried setting up an App password in your google account?
        I had to do this for my Acronis backup emails as well as my BLEmail plugin in HomeSeer

        https://myaccount.google.com/apppasswords
        I think this also requires you to first enable two-way authentications which in most cases is a good idea anyways.

        Comment


          #5
          Originally posted by Blade View Post
          Have you tried setting up an App password in your google account?
          I had to do this for my Acronis backup emails as well as my BLEmail plugin in HomeSeer

          https://myaccount.google.com/apppasswords
          Ok so I set up app password for calendar app on windows machine. How do I change my plugin set up to use the app password?

          Comment


            #6
            Yes 2FA needs to be enabled

            I just updated the password for my google account user in the plugin
            Then I restarted the plugin
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


              #7
              Originally posted by prsmith777 View Post

              Ok so I set up app password for calendar app on windows machine. How do I change my plugin set up to use the app password?
              You use your usual gmail account for the user and then the cryptic password that you specifically created for the plugin. Each app will have its own pwd.

              Comment


                #8
                Ok guys I did that and restarted the plugin and its working. I also removed the API client and secret key data.

                Is it safe to deauthorize the app client from google now? It seems like once I remove the client I wouldn't be able to reauthorize it

                Comment


                  #9
                  I had my original User name without the @gmail.com part so I had delete that user and add a new user with the proper email address. Then I had to update all my scripts which had the wrong username.

                  But its working now.

                  Comment


                    #10
                    I spoke too soon. I can't get the plugin to connect.

                    I am getting the following error each time the plugin starts:

                    Google authorization error 400. missing required parameter: client_id.

                    Comment


                      #11
                      I reverted back to the old way.

                      I still need help trying to connect using app passwords

                      Comment

                      Working...
                      X