Announcement

Collapse
No announcement yet.

Can't get it to work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get it to work

    I got the API authentication. The only thing that shows up under my users is calendar. I click on it and then try to add a calendar and it won't let me add anything. What am I missing?

  • #2
    I have never gotten the plugin to work either.

    Comment


    • #3
      I need a debug log in order to see what the issue is

      Log a help desk ticket on my site.
      gather a debug log using steps below

      1. Shutdown HS3
      2. Edit hspi_BLGData.ini and change debugLevel=true
      3. Save INI file
      4. Restart HS3

      Once started for a minute or so, turn off debug logging and attach the BLGData-Detailed.log file zipped to help desk ticket
      The log is in the HS3 root folder
      Cheers,
      Bob
      Web site | Help Desk | Feature Requests | Message Board

      Comment


      • #4
        I've done that several other times for you, and you never found anything wrong.

        Comment


        • #5
          Sometimes the cause is DLLs in the HS3 root folder
          They should only exist in the [hs3 root]\BIN\BLGData folder
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6
            A few minutes after I click on my 'calendar' in HS3.
            Error finding plugin in GenPage: Object reference not set to an instance of an object.

            Here are the pertinent parts of the debug log.


            8/12/2016 1:00:24 PM : v2.0.24.0 - CalendarFunctions.Create_Google_Auth_File() started
            8/12/2016 1:00:24 PM : v2.0.24.0 - CalendarFunctions.Create_Google_Auth_File(): aUser.ToString -->
            User:
            -----
            Key: ******************
            Name: ************
            EmailAddress: *******************
            EnableCalendar: True
            EnableContacts: False
            EnableTasks: False
            EnableVoice: False
            EnableGooglePlus: False
            Calendar Count: 0
            Contact Count: 0
            Contact Group Count: 0
            ProcessedEvents: 0
            ProcessedEventOffsets: 0
            ProcessedReminders: 0

            8/12/2016 1:00:24 PM : v2.0.24.0 - Linux() started
            8/12/2016 1:00:24 PM : v2.0.24.0 - Linux(): isLinux --> False
            8/12/2016 1:00:24 PM : v2.0.24.0 - Linux() finished
            8/12/2016 1:00:24 PM : v2.0.24.0 - CalendarFunctions.Create_Google_Auth_File(): fileName --> C:\Program Files (x86)\HomeSeer HS3\Data\BLGData\client_secrets.json
            8/12/2016 1:00:24 PM : v2.0.24.0 - CalendarFunctions.Create_Google_Auth_File() finished
            8/12/2016 1:00:24 PM : v2.0.24.0 - Linux() started
            8/12/2016 1:00:24 PM : v2.0.24.0 - Linux(): isLinux --> False
            8/12/2016 1:00:24 PM : v2.0.24.0 - Linux() finished

            Comment


            • #7
              DLL's only in the proper directory...

              Comment


              • #8
                Do the following:

                1. Disable the plugin
                2. Re-enable it
                3. Turn on debug logging
                4. Go to the calendars page
                5. Once it gives you that error turn off debug logging

                Email me the log zipped directly

                blade9123 at gmail dot com
                Cheers,
                Bob
                Web site | Help Desk | Feature Requests | Message Board

                Comment


                • #9
                  I have uploaded my latest debug log to your help desk.
                  I put in my ticket in January and still have not gotten this to work?

                  Yes the API is enabled, yes the DLL's are only in the BLDATA directory...

                  Comment

                  Working...
                  X