No announcement yet.

Betabrite USB Problem on new Win10 machine

  • Filter
  • Time
  • Show
Clear All
new posts

    Betabrite USB Problem on new Win10 machine

    Hi Blade or anyone !- I've been using BLLED for years under Windows 10 with 3 Betabrite signs, 2 serial and 1 USB.
    I just upgraded my Win10 PC to a faster machine and moved the whole setup across to the new machine.
    All is well however, both serial signs work fine but I can't for the life of me get the USB sign to work again at all.
    It will work with its own messaging software and from the old PC still, but I just cannot get it to work with the new box.
    It is driving me absolutely nuts

    So far I have tried:
    Restarting the plugin and PC numerous times.
    Removing & reinstalling the plugin and HS3.
    Deleting all BLLED associated files and reinstalling.
    Reinstalling HS3Pro.
    Double checked that the drivers on both machines appear to be the same ie betabriteusb.dll
    Deleting and re-adding all 3 signs.
    Both Debug logs appear to be identical and I'm on the latest version ( I've never had a USB problem with any prior version btw.

    Even more frustrating is that if I connect the USB sign back to the old PC, it still works! Aghhh!

    I tried capturing the USB port output with USBPcapCMD.exe and the new BLLED install doesn't appear to be putting out anything on the USB port.
    Why would that be? The USBBulkDevice accepts messages from its own software fine so I don't get it.
    The detailed debug log says messages are being sent to all signs and they all appear to be fine but no data is actually, coming out of the USB port according to USBPcapCMD.

    The only config difference between the two machines (that I know of) are that HS3 was installed on my C: drive on the old box.
    The new installation is on drive F:
    I did try reinstalling HS3 to C: but the issue prevails

    Anyone have any idea what the issue might be?

    betabriteusb.dll needs to be in c:\windows and not just in c:\windows\system32
    As soon as I did that it started working.