Announcement

Collapse
No announcement yet.

HStouch - No Icons

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HStouch - No Icons

    Does anyone use blradar with hstouch?

    I'm getting the text status messages changes on hstouch, but no graphics.

    When I look in web everything looks fine.

    Note I do see this in the status graphics for the device?

    Device Type (String) Motion Sensor
    Misc Settings Status Only, Show Values, No Graphics Display
    HS3 Pro Edition 3.0.0.435 (Windows 10 vmware)
    BLOccupied:,UltraNetCam3:,weatherXML:,RFXCOM:,Current Cost 3P:,UltraGCIR3:
    DMMQTT:,Kodi:,Z-Wave:,BLRadar:,EasyTrigger:,MySensors:,BLBackup:

  • #2
    Interesting, I do see the graphics but not the text in several of my sensor devices, they are the same model. I'm trying to figure it out myself, I do not see any reason why it does not work. In the text message I see " motion, 1 minute, 20 seconds" how do you format your text and graphics?

    Comment


    • #3
      I created defaults devices and then assigned those devices as motion/photo in blradar. In the plugin I accept the default graphics and they work fine in Web Browser.....But not n HStouch.

      But looking at the status graphics tab for the device, no graphics are defined...I't like blradar is building the web page but doesn't update the devices with the graphics....
      HS3 Pro Edition 3.0.0.435 (Windows 10 vmware)
      BLOccupied:,UltraNetCam3:,weatherXML:,RFXCOM:,Current Cost 3P:,UltraGCIR3:
      DMMQTT:,Kodi:,Z-Wave:,BLRadar:,EasyTrigger:,MySensors:,BLBackup:

      Comment


      • #4
        I have the same problem.How do I get the icons of a motion sensor visible on my HSTouch screen?
        Peter

        http://ohh.pcgsm.nl

        Comment


        • #5
          Using a virtual device for the sensor should work
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6
            graphics gone

            Is there a way to change BLRadar so it does not block me from using my graphics on devices?
            I like how the program works but it should have an option to stop it from changing strings and blocking my graphics.
            Even better, provide full support to HSTouch (all plugins should).
            It was really saddening to see all my screens gutted like that .

            Comment


            • #7
              If you do not want BLRadar to touch your original sensor devices then set it to use a virtual device for the sensor.
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                Blade, if you have made the devices and blradar connection is there a way to remove the "No Graphics Display" property from the device, as this looks like the cause of the graphics not being available in hstouch?

                Would like to not have to redo 38 devices, if possible

                D
                HS3 Pro Edition 3.0.0.435 (Windows 10 vmware)
                BLOccupied:,UltraNetCam3:,weatherXML:,RFXCOM:,Current Cost 3P:,UltraGCIR3:
                DMMQTT:,Kodi:,Z-Wave:,BLRadar:,EasyTrigger:,MySensors:,BLBackup:

                Comment


                • #9
                  You could try changing that.
                  I will have to look up the command when I am home
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    Originally posted by Blade View Post
                    If you do not want BLRadar to touch your original sensor devices then set it to use a virtual device for the sensor.
                    Does BLRadar have an option for creating the virtual devices for us for all the sensors we wish to keep our graphics intact?
                    Jim
                    ----
                    Plugins:Z Wave 3.0.1.55, HS3 Pro 3.0.0.208, HS3Touch, HS3Touch IOS, Z-Net, SceneMaster, XBMC, Sonos, Media Controller, Envisalink (52 Virtual nodes), JowiHue, EasyTrigger, Liftmaster MyQ, BLBackup, BLLAN, BLRadar, Pushover

                    Devices:Cooper RF9540, Cooper Scene, Yale Locks, Sonos, Phillips Hue and Lux, DSC, Somfy Blinds

                    Comment


                    • #11
                      You create the virtual device, then assign it to the sensor
                      Cheers,
                      Bob
                      Web site | Help Desk | Feature Requests | Message Board

                      Comment


                      • #12
                        My workaround was to define the graphics in HST designer using StatusImages, matching the values in the device.

                        Not as desirable as having it in the device -now I need to maintain each HTS screen instead of central control in the device, but works.

                        Comment


                        • #13
                          Originally posted by Blade View Post
                          You create the virtual device, then assign it to the sensor
                          Blade, can you tell me how do we "assign it to the sensor"?
                          I am happy on using HST to define device graphics but want to learn more on how to properly use this plugin.

                          Comment


                          • #14
                            On the edit sensor page you can assign a virtual device (using device code, or reference id)
                            Cheers,
                            Bob
                            Web site | Help Desk | Feature Requests | Message Board

                            Comment


                            • #15
                              Blade,
                              Good news if you remove NO_GRAPHICS_DISPLAY Property then it behaves better....see code below

                              dvRef = hs.GetDeviceByRef(322)

                              If CType(dvRef, Scheduler.Classes.DeviceClass).MISC_Check(hs, HomeSeerAPI.Enums.dvMISC.NO_GRAPHICS_DISPLAY) Then
                              CType(dvRef, Scheduler.Classes.DeviceClass).MISC_Clear(hs, HomeSeerAPI.Enums.dvMISC.NO_GRAPHICS_DISPLAY)
                              End If

                              However the occupied devices, reinstate that property, on transition...so I have to keep running this code. any chance you could look at this please?

                              Dan.
                              HS3 Pro Edition 3.0.0.435 (Windows 10 vmware)
                              BLOccupied:,UltraNetCam3:,weatherXML:,RFXCOM:,Current Cost 3P:,UltraGCIR3:
                              DMMQTT:,Kodi:,Z-Wave:,BLRadar:,EasyTrigger:,MySensors:,BLBackup:

                              Comment

                              Working...
                              X