Announcement

Collapse
No announcement yet.

How do you use this plugin?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do you use this plugin?

    I just installed the trial and I don't get it.

    I created a group. Entered some values but I can't figure out what to do next. I copied the example code in the help doc and replaced "Morning Phrases with my group name and tried to run it from the control panel but nothing happened. The log tells me there is a syntax error.

    For the record this is exactly what I ran:

    Code:
    &Dim myRandomValue As String = ""
        myRandomValue = hs.PluginFunction("BLRandom", "", "RandomizeGroup", {"I Entered"})
        hs.writelog("Info", "The new random value is: " & myRandomValue)
        myRandomValue = Nothing
    I'm assuming I'm leaving something out.

    Also, can I put BLSpeech special processing tags in front of my values? Is that the proper way to do it?
    Originally posted by rprade
    There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

  • #2
    Where are you running this from (script, event action)?

    I have a vb.net script that does this:

    I run in the startup script for HS3

    Code:
    Sub Main(byval param As Object)
    
    	Dim message As String = hs.PluginFunction("BLRandom", "", "RandomizeGroup", new Object(){"HomeSeer Startup Phrases"})
    	hs.Speak(message, True)
    	message = Nothing
    
    End Sub
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      The control panel directly, under tools.
      Originally posted by rprade
      There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

      Comment


      • #4
        Yea do not use that. It does not handle vb.net code properly.
        Use a .vb script file
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          So I copied your code, made a xxx.vb script with it changing startup phrases to the name of my group and at least does something now. It plays the TTS but the BLSpeech special processing tags I specified in my values aren't respected. I had been using Jeff's Random Phrase plugin before and the same happened with it, which is why I'm trying BLRandom. Is there a way to use the BLSpeech special processing tags with BLRandom?
          Originally posted by rprade
          There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

          Comment


          • #6
            Capture me a debug log from both plugins on what you are doing.
            Post both logs here zipped so I can see what is going on.
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              Here you go.

              In the mean time I actually had it work twice in a row. Without changing anything. It then failed the next several attempts though. So then I tried it again with the Random Phrase plugin and after repeated attempts I also got it to work that way once. So I'm beginning to think that if I'm not doing something very very wrong I may have uncovered a bug in either BLSpeech or HS3.

              So I'm also attaching a BLSpeech log from when it fails with the Random Phrase plugin.

              Thanks for looking into it!
              Attached Files
              Originally posted by rprade
              There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

              Comment


              • #8
                OK I will have a look as soon as I can and let you know
                Cheers,
                Bob
                Web site | Help Desk | Feature Requests | Message Board

                Comment


                • #9
                  I do not see any errors at all.
                  I see that BLRandom picked this phrase for speaking:

                  {speaker=Kitchen,source=2,volume=50} Welcome home Colin

                  BLSpeech looks like it processed it fine. According to BLSpeech it spoke it. Did it speak it?

                  Can you show me how you ran the whole thing?

                  I will then run the same thing here and see what happens
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    Hmmmm. The plot thickens.

                    Maybe it's a BLRussound issue? What happens, with both BLRandom and Random Phrase, is that the Russound zone turns on and then back off immediately. The speaker client does indeed show that it spoke what I desired every time. I just can't hear it because the zone isn't on. Which is why I assumed that the special processing tags weren't being followed.
                    Attached Files
                    Originally posted by rprade
                    There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                    Comment


                    • #11
                      Capture a debug log from BLSpeech and BLRussound and attach them zipped.
                      I will then see what is going on

                      Log a ticket on my site for it please so it is easier to track.
                      Attach the debug logs zipped.
                      Attach the script you are using as well
                      Cheers,
                      Bob
                      Web site | Help Desk | Feature Requests | Message Board

                      Comment


                      • #12
                        OK. Done.

                        I was beginning to feel pretty embarrassed. I turned debug logging on and then it worked three times in a row. So I tried with Random Phrase and again, it worked. So I waited a while and then it failed for me. So I turned debug logging on again and managed to get it to fail. All in all I've probably tried to run this event 40 times and it has now succeeded 7 times.
                        Originally posted by rprade
                        There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                        Comment


                        • #13
                          OK I will have a look as soon as I can
                          Cheers,
                          Bob
                          Web site | Help Desk | Feature Requests | Message Board

                          Comment


                          • #14
                            Great. Thanks for looking into it.
                            Originally posted by rprade
                            There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                            Comment

                            Working...
                            X