Announcement

Collapse
No announcement yet.

Stopped Working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stopped Working

    Good Morning! Hopefully this is a simple fix (I believe so but not sure). I noticed that BLRandom had stopped working but didn't have much tme to investigate. Finally sitting down to see what may be happening and now I'm not too sure.

    The problem is BLRandom does not execute at all so all my events connected to is don't say anything. I've tested my speakers and connections and if I change the events to speak, HomeSeer will speak. If I go to the BLRandom plugin management screen and click the play button, it works. So I'm guessing that there is a problem with the vb script passing the commands on. I'm on an old XP box and have ZoneAlarm 13.3.209 installed on that box. Not sure if that's the problem but I did disable it. How to I look at the logs to see what the problem may be?

    Thanks in advance for any help!

  • #2
    Any errors?
    I have not changed this plugin at all.
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Hey Blade! I know so that's what's confusing. No additional error messages that I can see. Literally, when I run the event, nothing is spoken. Is there anywhere else I need to look at for logs?

      Comment


      • #4
        Turn on debug logging in the plugin and capture the issue. Then disable debug logging. Attach the BLRandom-Detailed.log file zipped from your HS3 root folder
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          Thanks Blade! Attached is the file...
          Attached Files

          Comment


          • #6
            I do not see a call to RandomizeGroup in your log
            How are you randomizing the speech
            Show me a screenshot
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              Ok. Here's how the event is setup as well as a screenshot of the group showing enabled.
              Attached Files

              Comment


              • #8
                Does that actually work or does it give an error
                There is a hs.writelog in there that has no parameters. Does not look right
                Cheers,
                Bob
                Web site | Help Desk | Feature Requests | Message Board

                Comment


                • #9
                  It did work as I usually just copy one .vb file and just modify it if I create another event. I took out the hs.writelog line and tried to manually run the event but it did not work. Should I try to create a different file?

                  Comment


                  • #10
                    Hey Blade....any ideas?

                    Comment


                    • #11
                      I was away at a family funeral so I am just getting back.
                      Do you see any errors in the HS log
                      Cheers,
                      Bob
                      Web site | Help Desk | Feature Requests | Message Board

                      Comment


                      • #12
                        I figured something important was happening as you are always responsive. My condolences to you and family.

                        I don't have any entries other than the debug log.

                        Comment


                        • #13
                          Paste the text of the script in here. I would like to add to it
                          Cheers,
                          Bob
                          Web site | Help Desk | Feature Requests | Message Board

                          Comment


                          • #14
                            ok. Here is what I currently have....

                            Code:
                            Sub Main(byval param As Object)
                             Dim message As String = hs.PluginFunction("BLRandom", "", "RandomizeGroup", new Object(){"Weekday_830pm"})
                             hs.Speak(message, True)
                             message = Nothing 
                            End Sub

                            Comment


                            • #15
                              Can you try this and see if it prints anything in the HS Log

                              Code:
                              Sub Main(byval param As Object)
                                  Dim message As String = hs.PluginFunction("BLRandom", "", "RandomizeGroup", new Object(){"Weekday_830pm"})
                                  hs.Writelog("Info", "message = " & message)
                                  hs.Speak(message, True)
                                  message = Nothing 
                              End Sub
                              Cheers,
                              Bob
                              Web site | Help Desk | Feature Requests | Message Board

                              Comment

                              Working...
                              X