Announcement

Collapse
No announcement yet.

BLShutdown - Loss of C# External Library References on Restart

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BLShutdown - Loss of C# External Library References on Restart

    I'm in the process of trying to troubleshoot something that I think may be related to the method by which BLShutdown restarts the HomeSeer application. The symptoms are that when I use a timed event (every morning at 2:00 AM EST) to shutdown and restart HomeSeer, my custom scripts which reference external libraries stop working until I manually restart HomeSeer myself, logged into the Hometroller S6 Pro as the Homeseer account. I can't think of any good reason why this should be the case, but it appears to happen every time the timed event restarts the system, and predictably the scripts start working again as soon as I restart HomeSeer.

    Anyone else have similar issues? I know the population of C# programmers using custom scripts is probably pretty small, given what I've seen on the message boards. But perhaps someone else has seen similar, and/or managed to isolate the cause.

    Thanks.

    Details on my particular installation below.

    HomeSeer Version: HS3 Pro Edition 3.0.0.548
    Operating System: Microsoft Windows 10 Pro - Work Station
    System Uptime: 0 Days 12 Hours 46 Minutes 31 Seconds
    IP Address: 10.0.1.55
    Number of Devices: 633
    Number of Events: 129
    Available Threads: 200
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed: Sophos Home Windows Defender
    In Virtual Machine: No MFG: shuttle inc.
    Enabled Plug-Ins
    2.1.1.1: AmbientWeather
    2.0.61.0: BLBackup
    2.0.7.0: BLMapper
    1.0.4.0: BLShutdown
    3.0.0.19: DirecTV
    3.0.0.67: EasyTrigger
    3.0.0.33: Ecobee
    1.5.0.0: MQTT
    1.2019.211.1740: MyQ
    0.0.0.45: Pushover 3P
    3.0.7164.18799: UltraRachio3
    3.0.5902.19061: UltraSMTP3
    3.3.6389.22764: Yamaha
    3.0.1.252: Z-Wave

  • #2
    Any errors in the log after the nightly restart?
    HS 3.0.0.548: 1976 Devices 1156 Events
    Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

    Comment


    • #3
      Originally posted by sparkman View Post
      Any errors in the log after the nightly restart?
      No. No errors after the restart...HomeSeer comes back up cleanly. That's what adds to the intrigue.

      I've got a few other events that run scripts that just use standard .NET objects in the System namespace (that HomeSeer already references out-of-the-box) that work fine after BLShutdown does its thing every night. It's this one script where I wanted to use a List object, hence the additional external reference, that throws the error.

      For an additional bit of mystery, if I manually execute the same BLShutdown event that is set to run automatically every night, and then retry the script with the external library reference, I do not get the error. After the automated BLShutdown event runs at 2:00 AM, and the script with the external reference throws the error (as seen in the HomeSeer log), I can manually run the same event that invokes BLShutdown each night, retry the script with the external library reference, and it will execute without error.

      The event logic is:

      If the time is at 2:00 AM
      Then BLShutdown: Shutdown and Restart HomeSeer

      That's it.

      Comment

      Working...
      X