Announcement

Collapse
No announcement yet.

Load Schedules Question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Load Schedules Question

    Blade/All,

    Starting to use events to load a different schedule. What I am seeing is Log indicates schedule loaded, but the Heating and Cooling Setpoints do not change until the next time listed in the schedule.

    I was expecting that loading a schedule would also cause an immediate execution of the appropriate setpoints. Am I missing something?

    Regards,
    Vector

  • #2
    I believe that is how it works. I no longer have a zwave thermostat to test here but am positive that is how it worked at my old house.
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Thanks Blade,

      So is there a way to force an immediate execution of the new schedule values?

      Regards,
      Vector

      Comment


      • #4
        There is no current way to do this without changing the plugin. You could put in a feature request on my site for this but I have to say that I am very busy right now at work and have not had the time to work on much for automation. I am hoping things slow down soon
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          Victor, I believe that schedules get initiated/applied when the PI starts. As a work around you could use Jon00 Homeseer Plugin Enable/Disable utility to disable then re-enable the PI.
          Larry

          Comment


          • #6
            I have 8 CT100 thermostats. When I load a new schedule (from an event or the plug-in page) the setpoints are immediately changed on the thermostats according to the newly loaded schedule. It has always worked that way and I just now verified that it still works that way.
            Randy Prade
            Aurora, CO
            Prades.net

            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

            Comment


            • #7
              Thanks All,

              Randy - I have a Trane Z-wave and I have tested it repeatedly using both the Event Load schedule as well as on the plugin page and I get the same result (setpoints update at next scheduled change). Not sure why mine is different from your thermostats.

              Ipcal - Thanks for the tip, and thanks to Jon00 for the plugin. Not the most elegant solution but absolutely forces an immediate setpoint change!

              Blade - If you decide to work on this that would be great (again not sure why it works for Randy), but I am able to do what I need using the workaround.

              Thanks again!

              Regards,
              Vector

              Comment


              • #8
                Originally posted by Vector View Post
                Thanks All,

                Randy - I have a Trane Z-wave and I have tested it repeatedly using both the Event Load schedule as well as on the plugin page and I get the same result (setpoints update at next scheduled change). Not sure why mine is different from your thermostats.

                Ipcal - Thanks for the tip, and thanks to Jon00 for the plugin. Not the most elegant solution but absolutely forces an immediate setpoint change!

                Blade - If you decide to work on this that would be great (again not sure why it works for Randy), but I am able to do what I need using the workaround.

                Thanks again!

                Regards,
                Vector

                Do me a favor and turn on debug logging, then load a schedule for a thermostat, then disable debug logging and attach the BLStat-Detailed.log file zipped so I can see what it is doing. The log is located in the HS3 root folder
                Cheers,
                Bob
                Web site | Help Desk | Feature Requests | Message Board

                Comment


                • #9
                  Blade,

                  Thanks for taking a look. Attached is the requested Zip file.

                  Regards,
                  Vector
                  Attached Files

                  Comment


                  • #10
                    I see your thermostat mode is off. That is why it is not setting a setpoint for you.
                    I assume it is working for others because they have the thermostat in heat or cool mode
                    Cheers,
                    Bob
                    Web site | Help Desk | Feature Requests | Message Board

                    Comment


                    • #11
                      Blade,

                      Based on your latest I have done some additional testing:

                      Mode - Change when schedule loaded
                      Off - None
                      Auto - None
                      Heat - Heat Septoint only
                      Cool - Cool Setpoint only


                      So it appear to ONLY change the corresponding setpoint for Cool or Heat and changes no setpoints for Off or Auto (Cools or Heats as needed based on the high and low setpoint).

                      I use Auto and Off modes as part of some events that operate my Whole House Fans.

                      I hope that makes sense and helps to figure it out.

                      Regards,
                      Vector

                      Comment


                      • #12
                        Can you try the latest build and see if it helps
                        Cheers,
                        Bob
                        Web site | Help Desk | Feature Requests | Message Board

                        Comment


                        • #13
                          Blade,

                          Works perfectly now!

                          Thanks very much for the help.

                          Regards,
                          Vector

                          Comment

                          Working...
                          X