Announcement

Collapse
No announcement yet.

Lost Schedules/Settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lost Schedules/Settings

    Yesterday all my schedules and settings for my thermostats disappeared. I backup my HS3 regularly; can I copy over a certain directory and have everything restored? Thanks for the help.

    #2
    You can restore the hspi_BLThermostat.ini file and then restart the plugin
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


      #3
      Thank you for the quick answer!

      Comment


        #4
        Bob,

        Where are the schedules kept as the schedule I have setup keep on disappearing in the plugin? I set one up, add it and if I restart the plugin or homeseer the schedule is gone.

        Judd

        Comment


          #5
          The schedule is in the hspi_BLStat.ini file in the config folder
          I would like you to try and capture this happening in a debug log if you can.
          Attach it zipped if you can capture it
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


            #6
            Bob,

            It looks like the schedule is not being saved to the ini file. You can look at the screen captures below.

            I have included the ini file and the one schedule i have.
            Attached Files

            Comment


              #7
              It should be in the INI as far as I can remember - I will have to check the code to be sure
              Can you grab a debug log of you saving the schedule and I can see what is happening
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


                #8
                I have quite a number of schedules that have remained for a couple of years without issue. They are in the .ini file. I have events that will load different schedules based on work schedule, outside temperature, holidays and occupancy. They all load reliably.
                Randy Prade
                Aurora, CO
                Prades.net

                PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                Comment


                  #9
                  Originally posted by jpape View Post
                  Bob,

                  It looks like the schedule is not being saved to the ini file. You can look at the screen captures below.

                  I have included the ini file and the one schedule i have.
                  Your .ini file seems to be missing the thermostat(s) preferences and the schedule(s). This should start just below the filterLastChangeDate.
                  Randy Prade
                  Aurora, CO
                  Prades.net

                  PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                  Comment


                    #10
                    Bob,

                    Here is my config file and the log as you requested. I created a second schedule called "test" with just one days worth of settings and the config file was not updated.
                    Attached Files

                    Comment


                      #11
                      That is very odd
                      The log says the object and INI was updated

                      02/14/2018 10:04:03:200 PM : v2.0.71.0 - PagePut: new schedule class has been built
                      02/14/2018 10:04:03:200 PM : v2.0.71.0 - PagePut: schedule added to dictionary and INI

                      Can you edit it once you add it in the plugin?
                      If it is not in the INI file then it will not load when you restart but does it load up again right after you add it in the plugin. That would tell me that the class is created within the plugin but for some reason it will not write the INI file

                      Could your INI file be read-only?
                      Cheers,
                      Bob
                      Web site | Help Desk | Feature Requests | Message Board

                      Comment


                        #12
                        Yes i can edit the schedules once created. But if i restart the plugin or Homeseer the schedules disappear.

                        The ini file is not read only. If i change a setting in the Options screen it does get reflected in the ini file.

                        Another thing i have wondered about, should there be a field next to the "Set" button for each stat?

                        I am running Windows 10 if that means anything.

                        Judd
                        Attached Files

                        Comment


                          #13
                          I believe there should be a field next to that set button - I will check that

                          That is just strange that your schedule is not writing to the INI file
                          Is it possible there is another hspi_BLStat.ini file on the system it is writing to.
                          I am at a loss right now on this one
                          Cheers,
                          Bob
                          Web site | Help Desk | Feature Requests | Message Board

                          Comment


                            #14
                            I checked and there is only one BLStat INI file on my system.

                            Do you have an example of what the INI file should look like and I could possibly add the missing schedule fields and see what happens when I modify the schedule.

                            Comment


                              #15
                              I do not as I do not have a zwave stat anymore (using a nest)
                              Perhaps rprade could paste in his

                              Still trying to think of what could cause this
                              Cheers,
                              Bob
                              Web site | Help Desk | Feature Requests | Message Board

                              Comment

                              Working...
                              X