Announcement

Collapse
No announcement yet.

BLStat for HS3

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BLStat for HS3

    I need some help with getting BLStat finished.
    I do not have my thermostat setup in HS3 yet so I will need someone with one or more thermostats to run the attached script and attach the output to this thread.

    Follow these steps:

    1. Extract the attached script to your scripts folder under your HS root folder (eg: C:\Program Files (x86)\HomeSeer HS3\scripts)
    2. Go to the Control Panel
    3. In the Immediate Script Command box, type the following and click Execute Command.

    Code:
    &hs.RunScript("HS3_Display_ZWave_Thermostat_Device_Info.vb", False, False)

    If everything works there will be a file in your HS root folder called "HS3_Display_ZWave_Thermostat_Device_Info.log"

    Attach this file to this thread and tell me how many thermostats you have in your HS3 system.
    Attached Files
    Last edited by Blade; February 8th, 2019, 07:53 AM.
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

  • #2
    Yes that was helpful. I will change the script a bit and post a new one and have you run it again if you don't mind. Might not be tonight tho
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      No problem
      Bryan
      Software/Hardware: Win10 Pro, HS 3 Pro, HS Touch, Echo, Edgeport/4, Z-Net w/88 Devices, Insteon PLM w/19 Devices, Nest, GC-100-6, W800RF32A, WS-2080 Weather Station (KMADRACU10)
      Plug-in/Scripts: Alexa API, BLBackup, BLGData, BLLED, BLLock, BLRF, BLTVGuide, Blue Iris, BLUPS, Current Cost 3P, DirectTV, FitbitSeer, Insteon, Nest, Pushover 3P, Random, Restart, Tasker, UltraGCIR3, UltraWeatherWU, Z-Wave

      Comment


      • #4
        Bryan,
        I updated the script. Can you run it again and attach a new log. You do not have to zip it if you do not want.
        It should now only list the thermostat devices in the log (hopefully)
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          Thanks guys... that info helps.
          Now I just need to figure it out and how I need to modify BLStat to use it.
          Stay tuned.
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6
            I am going to add some more info to the script and then have you run it again.
            I will let you know once I have uploaded the new script.
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              I have updated the script to show more info.
              Can you both please rerun it and post the logs
              Thanks
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                Here is your new log file
                Attached Files

                Comment


                • #9
                  BIGMACK48,

                  I have noticed something odd in your file. For all 4 of your thermostats, one device has a blank subtype. I believe it is fan mode. In the example below the offending device is Q2. I do not get a device entry in the file for this one either. The last file was missing device ref 413 as well.

                  Here is an example:

                  Code:
                  Ref: 4637
                  Device Code: 
                  Address: 00E669A7-061
                  Name: Wayne Dalton Thermostat
                  Location: Bar Area
                  Location 2: Basement
                  Type: Z-Wave Thermostat Root Device
                  Type API: Thermostat API
                  Type Description: Thermostat Root Device
                  SubType API: Thermostat
                  Relationship: Parent_Root
                  Associated Device Count: 8
                  Associated Devices:
                          Ref: 4223; Code: Q1; Address: 00E669A7-061-Q1; Location: Bar Area; Name: Wayne Dalton Thermostat; Relationship: Child; SubType API: Temperature
                          Ref: 413; Code: Q2; Address: 00E669A7-061-Q2; Location: Bar Area; Name: Wayne Dalton Thermostat; Relationship: Child; SubType API: 
                          Ref: 5391; Code: Q3; Address: 00E669A7-061-Q3; Location: Bar Area; Name: Wayne Dalton Thermostat; Relationship: Child; SubType API: Mode
                          Ref: 6361; Code: Q4; Address: 00E669A7-061-Q4; Location: Bar Area; Name: Wayne Dalton Thermostat; Relationship: Child; SubType API: Operating State
                          Ref: 854; Code: Q5; Address: 00E669A7-061-Q5; Location: Bar Area; Name: Wayne Dalton Thermostat; Relationship: Child; SubType API: Heating 1
                          Ref: 2357; Code: Q6; Address: 00E669A7-061-Q6; Location: Bar Area; Name: Wayne Dalton Thermostat; Relationship: Child; SubType API: Cooling 1
                          Ref: 636; Code: Q7; Address: 00E669A7-061-Q7; Location: Bar Area; Name: Wayne Dalton Thermostat; Relationship: Child; SubType API: Energy Save Heating
                          Ref: 890; Code: Q8; Address: 00E669A7-061-Q8; Location: Bar Area; Name: Wayne Dalton Thermostat; Relationship: Child; SubType API: Energy Save Cooling
                  Notice that Q2 has no subtype. I assume it is the fan mode but not sure. Does it show ok in the device management page. Can you post a screenshot of this thermostat and all associated devices so I can see what they look like.

                  Just thought it was weird that the one was blank.
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    If I look Bryans file, he only has one thermostat but the fan mode is there for it. No idea why you are missing that one. Strange that it comes in with a blank subtype
                    Cheers,
                    Bob
                    Web site | Help Desk | Feature Requests | Message Board

                    Comment


                    • #11
                      Here the latest
                      Attached Files
                      Bryan
                      Software/Hardware: Win10 Pro, HS 3 Pro, HS Touch, Echo, Edgeport/4, Z-Net w/88 Devices, Insteon PLM w/19 Devices, Nest, GC-100-6, W800RF32A, WS-2080 Weather Station (KMADRACU10)
                      Plug-in/Scripts: Alexa API, BLBackup, BLGData, BLLED, BLLock, BLRF, BLTVGuide, Blue Iris, BLUPS, Current Cost 3P, DirectTV, FitbitSeer, Insteon, Nest, Pushover 3P, Random, Restart, Tasker, UltraGCIR3, UltraWeatherWU, Z-Wave

                      Comment


                      • #12
                        here is my thermostat screen display
                        Attached Files

                        Comment


                        • #13
                          So you have no fan mode with any of the thermostats then?
                          That is odd
                          Cheers,
                          Bob
                          Web site | Help Desk | Feature Requests | Message Board

                          Comment


                          • #14
                            Guys,
                            I have updated the script again.
                            Can you please post a new file.
                            Thanks
                            Cheers,
                            Bob
                            Web site | Help Desk | Feature Requests | Message Board

                            Comment


                            • #15
                              Here is your new file
                              Attached Files

                              Comment

                              Working...
                              X