Announcement

Collapse
No announcement yet.

error on reports

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • error on reports

    Server Error in '/' Application.

    Unable to find an entry point named 'sqlite3_close_v2' in DLL 'sqlite3'.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.EntryPointNotFoundException: Unable to find an entry point named 'sqlite3_close_v2' in DLL 'sqlite3'.

    Source Error:



    Line 37: If NOT (Page.IsPostBack) Then
    Line 38: Dim i_days as Integer = 7
    Line 39: DropDownList1.DataBind()
    Line 40: DropDownList1.SelectedIndex = 0
    Line 41: Dim almostDay as System.TimeSpan = New System.TimeSpan(0,23,59,59)


    Source File: C:\Program Files (x86)\HomeSeer HS3\html\BLStat\BLStat_hrs_per_day.aspx Line: 39

    Stack Trace:



    [EntryPointNotFoundException: Unable to find an entry point named 'sqlite3_close_v2' in DLL 'sqlite3'.]
    System.Data.SQLite.UnsafeNativeMethods.sqlite3_close_v2(IntP tr db) +0
    System.Data.SQLite.SQLiteBase.CloseConnectionV2(SQLiteConnec tionHandle hdl, IntPtr db) +125
    System.Data.SQLite.SQLiteConnectionHandle.ReleaseHandle() +75
    System.Runtime.InteropServices.CriticalHandle.Cleanup() +55
    System.Runtime.InteropServices.CriticalHandle.Dispose(Boolea n disposing) +9
    System.Runtime.InteropServices.CriticalHandle.Dispose() +17
    System.Data.SQLite.SQLite3.Close(Boolean canThrow) +84
    System.Data.SQLite.SQLiteConnection.Close() +255
    System.Data.Common.DbDataAdapter.FillInternal(DataSet dataset, DataTable[] datatables, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) +337
    System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) +134
    System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, String srcTable) +84
    System.Web.UI.WebControls.SqlDataSourceView.ExecuteSelect(Da taSourceSelectArguments arguments) +1458
    System.Web.UI.WebControls.ListControl.OnDataBinding(EventArg s e) +271
    System.Web.UI.WebControls.ListControl.PerformSelect() +21
    System.Web.UI.WebControls.BaseDataBoundControl.DataBind() +71
    ASP.blstat_blstat_hrs_per_day_aspx.Page_Load(Object sender, EventArgs e) in C:\Program Files (x86)\HomeSeer HS3\html\BLStat\BLStat_hrs_per_day.aspx:39
    System.Web.UI.Control.OnLoad(EventArgs e) +61
    System.Web.UI.Control.LoadRecursive() +98
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2732




    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1073.0


    please advise. Thank you

  • #2
    Do you have the SQLite dll in your [hs3 root]\bin\BLStat folder
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Originally posted by Blade View Post
      Do you have the SQLite dll in your [hs3 root]\bin\BLStat folder
      If this is something I have to do manually. No.

      where do I get this file if I need to manually?

      Comment


      • #4
        Originally posted by Mwillis View Post
        If this is something I have to do manually. No.

        where do I get this file if I need to manually?
        this is what I have
        Attached Files

        Comment


        • #5
          Do you have any of those files in your HS3 root folder?
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6
            Originally posted by Blade View Post
            Do you have any of those files in your HS3 root folder?
            here is what I have in my root folder
            Attached Files

            Comment


            • #7
              Hmmm... I do not see the files in the root.
              What version of BLStat are you running?
              It is like the wrong version on SQLite dll is there
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                Originally posted by Blade View Post
                Hmmm... I do not see the files in the root.
                What version of BLStat are you running?
                It is like the wrong version on SQLite dll is there
                here is a capture
                Attached Files

                Comment


                • #9
                  Show me what is in [hs3 root]\html\bin
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    Originally posted by Blade View Post
                    Show me what is in [hs3 root]\html\bin
                    Here you go
                    Attached Files

                    Comment


                    • #11
                      Can you confirm that the SQLite files in html\bin are the same as the ones in bin/BLStat
                      Cheers,
                      Bob
                      Web site | Help Desk | Feature Requests | Message Board

                      Comment


                      • #12
                        Originally posted by Blade View Post
                        Can you confirm that the SQLite files in html\bin are the same as the ones in bin/BLStat
                        here you go
                        Attached Files

                        Comment


                        • #13
                          Hmmm ok - this is odd
                          I wonder if anyone else is seeing the same thing
                          Cheers,
                          Bob
                          Web site | Help Desk | Feature Requests | Message Board

                          Comment


                          • #14
                            Originally posted by Blade View Post
                            Hmmm ok - this is odd
                            I wonder if anyone else is seeing the same thing


                            The reports have never worked for me. As I am finishing the hardware build for my systems. I am now starting to work on the detailed software side of things.

                            Comment


                            • #15
                              I will take a look as soon as I can
                              Has been very busy recently as we are in the process of a new house build.
                              Cheers,
                              Bob
                              Web site | Help Desk | Feature Requests | Message Board

                              Comment

                              Working...
                              X