No announcement yet.

No UPS battery could be found! - SOLVED

  • Filter
  • Time
  • Show
Clear All
new posts

    No UPS battery could be found! - SOLVED

    If you see this error when installing BLUPS
    Jun-06 12:07:10 Error Initializing plug-in(1): BLUPS Instance::No UPS battery exists on this system so this plugin will not run! Time to load: 845 milliseconds
    Jun-06 12:07:10 BLUPS Init Error No UPS battery could be found!
    This is how to fix:
    You MAY have previously installed APC PowerChute and then uninstalled it so as to use BLUPS since BLUPS will not work with PowerChute.

    You then install BLUPS but it has the error above when activated

    To fix it you need to remove the APC Battery driver and allow windows to install a generic driver. These are the steps:

    1. Open Windows Device Manager on your HS3 computer
    2. There will be a "Batteries" category. If you open that category you will see an "APC" entry. Right click on this entry and select "Properties" then click the "Driver" tab
    3. Click the "Uninstall Device" button and another pop up will ask for confirmation. On this button is a Delete driver option. Select that option and delete the driver.
    4. Next unplug the USB cable to your UPS
    5. Plug the UPS USB cable back in. Windows will install its OWN drivers and these are the ones you need for BLUPS

    So it appears that the installation of APC Powerchute will install it's own Windows drivers over the standard ones. These are NOT removed when you uninstall PowerChute.

    Hope this helps someone.

    Brilliant, thanks metkhoo !