No announcement yet.

SceneMaster Beta

  • Filter
  • Time
  • Show
Clear All
new posts

  • SceneMaster Beta

    First of all, this is an incredibly useful plugin! The approach for scenes and them profiles within scenes is wonderful; especially for implementing different dim and device combinations throughout the day as lighting and family patterns change, timed overrides for occupancy or "door open" events. All very nice. And the "<No Change>" action is a great addition.

    I have the beta up and it mainly seems to be doing fine, but I'm getting a few logged errors I can't track down. Examples below.
    Aug-02 2:45:58 PM SceneMaster Device 733902746 added but could not be accessed by plugin
    Aug-02 2:29:34 PM SceneMaster Device 521560557 added but could not be accessed by plugin
    Aug-02 2:05:39 PM SceneMaster Device 2062616413 added but could not be accessed by plugin
    This is new system and so I've moved around a few devices here and there. But I can't find the correlation as to what the cause it. These seem to come while some other actions are underway but not particularly related to anything being demanded of SceneMaster.

    The second issue, for the SceneMaster designer at any case, seems to get confused on it's database (perhaps from the caching changes?). The issues I've had were:
    a) when trying to select a specific profile, the wrong one came up for editing.
    b) the entire scene database seemed to go missing.

    Restarting the plugin correct both issues for a while.


    Don R

  • #2
    Hi Don,

    First, thank you for the kind words. The real thanks goes to Mike who originally wrote the plugin, I took it over from him last year when he got too busy to continue it. I really appreciate you taking the beta, I've been hesitant to push a large release out without more testing, so its very very much appreciated.

    On the first issue, the logs, I just saw that myself and its a bug (but harmless other than the logging). My framework is triggering on an event change (add/delete/modification) and a code path fires which tries to update the device with the same reference number as the event reference (worst case scenario, if the numbers overlap, I re-read the state of an existing device). Anyhow, I am literally fixing that today and the fix will be in the next beta.

    On the second issue, those certainly sound like more serious issues. Now the database itself is held in device objects, so most likely (as you surmised) this may be a caching issue. I will try to recreate both issue, and if you run into it again and have any suggestions on how to recreate please let me know. If you do see it again, the cache times out after about 15 minutes, I would be very curious if you simply wait if the problem fixes itself (not a permanent solution of course, but would help show if its indeed the caching or not)

    Thank you again!


    • #3
      re: I would be very curious if you simply wait if the problem fixes itself

      I don't think so. This morning first time I tried to use the plugin scene designer, I got that missing database kind of issue. I restarted the plugin and the issue went away.


      Don R.


      • #4
        Hi, I pushed an update (same link) that fixes the first issue and may fix the second (not sure I have root cause on the second, but I did find a caching issue that needed a change)


        • #5
          re:, I've been using the update off and on today, designing some new scenes, and the log issues are gone, and so far the weird database/perhaps caching issues have not reappeared. Will watch it again tomorrow.


          • #6
            Thank you, much appreciated!


            • #7
              Well, still a few things here and there.

              1. When using the scene designer, when you select a scene to edit, you will be editing the scene yo want, bu the display of the current "Scene to Edit" may show something entirely different (from sorting changes?).

              2. If you add devices or change device names, the scene member device selection is not updated.


              Don R.


              • #8
                Hey guys, i have something that may be related. sorry it's not very specific, but perhaps this story may help you triangulate any issues.
                A few weeks ago i had the displeasure of having to move about 50 zwave devices (the physical kind) off one znet to a few new ones --- i found zwave doesn't scale well above 70-ish nodes. "Moving" across zwave nets means deleting and reincluding, so after each chunk of devices i had to redo the device names, the event links, the HSTouch links, etc, etc. Major PITA, but very straightforward.
                I found that HS3 would crash every time i tried to use Scenemaster to update the scenes with my new devices. To keep that from happening, if I simply disabled and then restarted SceneMaster AFTER i moved the zwave devices to the new nets, but BEFORE i tried to use SceneMaster, then all worked fine.
                On the surface this seems to support some kind of database sync problem. But nothing critical for me - was one time work and issue is easily avoided. -m