Announcement

Collapse
No announcement yet.

Device Caching Bug?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Device Caching Bug?

    I have three Tuya LED bulbs I'm using to test both Tags and SceneMaster. My goal is to control the on/off and color of all three bulbs that will eventually be installed in a ceiling fan.

    I started out with:

    1. Blue Room Smart Bulb_1
    2. Katie's Room Smart Bulb_2
    3. Katie's Room Smart Bulb_3

    I had #1 in a #Tag called #BlueRoomBulbColor. I had #2 and #3 in another #Tag called "#Test".

    I moved #2 and #3 from Location2 "Katie's Room" to "Test Bench". Location1 for all devices is "Cps Tuya" representing the technology used.

    Now for the problem:

    I removed all of the rules from "Test" which basically deleted the #Test tag. When I try to create a new #Tag called "#TestBulbColor" and select "Cps Tuya" for Location1 (i.e. Technology) and here's the results:

    Click image for larger version

Name:	Screen Shot 2018-11-11 at 2.08.34 PM.png
Views:	46
Size:	510.1 KB
ID:	1258748

    Notice that Devices in Tag still show the old Location2 "Katie's Room". What's even weirder it that if I enter "Test Bench" for the next rule it still finds devices but shows the old Location2 "Katie's Room":


    Click image for larger version

Name:	Screen Shot 2018-11-11 at 2.14.08 PM.png
Views:	20
Size:	114.9 KB
ID:	1258749
    If, on the other hand, I change "Test Bench" to "Katie's Room" no devices appear in the tag:

    Click image for larger version

Name:	Screen Shot 2018-11-11 at 2.17.59 PM.png
Views:	22
Size:	37.8 KB
ID:	1258750

    Let me know if you need me to collect additional information.

    Thanks,
    Ken



  • #2
    I know what issue this is, I have a fix for it which is included in the SceneMaster update you just got. You just need an updated Tags. I'll push an update in just a few minutes, Ill post the link here.

    Comment


    • #3
      http://download.casapiedrasoftware.i...r_override.txt

      Forgot it was already posted for testing, you can use this link to upgrade.

      Comment


      • #4
        Hi Bill,

        Just updated to 1.4.0.0 and I got the following error when I enable the plugin:

        Nov-13 4:02:51 PM Cps Tags Successfully transfered state from SceneMaster to accelerate startup
        Nov-13 4:02:50 PM Starting Plug-In Plugin Cps Tags started successfully in 455 milliseconds
        Nov-13 4:02:50 PM Cps Tags Error Exception loading cache Exception:Object of type 'System.Collections.Generic.Dictionary`2[System.Int32,HomeSeerShared.DeviceInfo]' cannot be converted to type 'System.Collections.Generic.ISet`1[System.Int32]'. at System.RuntimeType.TryChangeType(Object value, Binder binder, CultureInfo culture, Boolean needsSpecialCast) at System.RuntimeType.CheckValue(Object value, Binder binder, CultureInfo culture, BindingFlags invokeAttr) at System.Reflection.RtFieldInfo.UnsafeSetValue(Object obj, Object value, BindingFlags invokeAttr, Binder binder, CultureInfo culture) at System.Runtime.Serialization.FormatterServices.Serialization SetValue(MemberInfo fi, Object target, Object value) at System.Runtime.Serialization.ObjectManager.CompleteObject(Ob jectHolder holder, Boolean bObjectFullyComplete) at System.Runtime.Serialization.ObjectManager.DoNewlyRegistered ObjectFixups(ObjectHolder holder) at System.Runtime.Serialization.ObjectManager.FixupSpecialObjec t(ObjectHolder holder) at System.Runtime.Serialization.ObjectManager.DoFixups() at System.Runtime.Serialization.Formatters.Binary.ObjectReader. Deserialize(HeaderHandler handler, __BinaryParser serParser, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage) at System.Runtime.Serialization.Formatters.Binary.BinaryFormatt er.Deserialize(Stream serializationStream, HeaderHandler handler, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage) at System.Runtime.Serialization.Formatters.Binary.BinaryFormatt er.Deserialize(Stream serializationStream) at HomeSeerShared.DeviceInfoCache.DeserializeDeviceInfo(IHSAppl ication HS, String cacheFileNamme, Boolean adoptPluginSpecificFields, Boolean deleteAfterLoad)
        Nov-13 4:02:50 PM Starting Plug-In Initializing plugin Cps Tags ...
        Nov-13 4:02:50 PM Info Plugin Cps Tags has connected. IP:127.0.0.1:49244
        Nov-13 4:02:50 PM Warning Using updater override file: updtater_override.txt for updates!

        Disabled and re-Enabled and I didn't get any errors the second time.

        Off to do some testing.

        Ken

        Comment


        • #5
          Odd, seems like HS didn't properly unload the older support DLL. Looks like it did on the second take, lmk if it comes back...

          Comment


          • #6
            Originally posted by bsobel View Post
            Odd, seems like HS didn't properly unload the older support DLL. Looks like it did on the second take, lmk if it comes back...
            Hi Bill,

            Is it possible that HS got confused because I'm using a couple of Cps plugins? Maybe another plugin was using the support DLL so it couldn't be unloaded?

            In any case, I haven't seen it since so I'm not going to worry about it.

            I can confirm that the reported bug with caching has been fixed in 1.4.0.0.

            Thanks,
            Ken

            Comment


            • #7
              It’s possible. That dll should hace a unique version number which should have prevented that. I rechecked that is correct today but it’s pissible I messed that up prior. Plus side it would be a one time issue, but I’ll ceryeiñy still double check.

              Comment

              Working...
              X