Announcement

Collapse
No announcement yet.

Dynamic Triggers - if all devices in a tags reach ''this value''

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    thanks, but it does not trigger as you can see
    Attached Files

    Comment


    • #17
      Can you clarify which version you are on? Did you install the 1.5.7?

      Comment


      • #18
        Originally posted by bsobel View Post
        Can you clarify which version you are on? Did you install the 1.5.7?
        I am on the last one.


        I also deleted the event then recreated it, restarted hs3.



        Attached Files

        Comment


        • #19
          Click image for larger version

Name:	Screen Shot 2019-01-02 at 11.53.25 AM.png
Views:	11
Size:	47.8 KB
ID:	1271556Click image for larger version

Name:	Screen Shot 2019-01-02 at 11.56.21 AM.png
Views:	9
Size:	28.7 KB
ID:	1271557Click image for larger version

Name:	Screen Shot 2019-01-02 at 11.55.53 AM.png
Views:	9
Size:	62.0 KB
ID:	1271558

          Comment


          • #20
            Prior post was my test case. Can you post your full event with the items expanded including the advanced button at the bottom, I believe I am literally running the same test as you. Trying to determine what is different.

            Comment


            • #21

              and can you tell me what is the purpose of the other set of trigger ?

              i tried them ... but they seems to fire nothing either
              Attached Files

              Comment


              • #22
                Originally posted by bsobel View Post
                Prior post was my test case. Can you post your full event with the items expanded including the advanced button at the bottom, I believe I am literally running the same test as you. Trying to determine what is different.
                here it is
                Attached Files

                Comment


                • #23
                  Matt can you please include the advanced area at the bottom of the script, including the 'Options' fully expanded?

                  Comment


                  • #24
                    yes

                    edit : i really do not know why but it now works
                    Attached Files

                    Comment


                    • #25
                      Ive seen issues with HS when updating a plugin, it keeps sending events to the old ghost process for a bit before fixing itself and sending to the new one. I was about to ask you to reboot to verify, but sounds like HS finally sorted itself. I also retested the single device triggers you asked about above and confirmed they are working, so I suspect it was indeed this issue of HS not sending the plugins the events. I tested specifically:

                      Click image for larger version

Name:	Screen Shot 2019-01-02 at 12.21.40 PM.png
Views:	12
Size:	55.5 KB
ID:	1271573

                      Comment


                      • #26
                        ok i did some tests. (deleted the event And i realized I just create a copy of the same event)


                        So....i realized, with one event settled like I did show you, it does not work.

                        but when I created another event with the exact same thing it works!!?

                        I created a second event without realizing it... so this why it worked.

                        Comment


                        • #27
                          Originally posted by bsobel View Post
                          Ive seen issues with HS when updating a plugin, it keeps sending events to the old ghost process for a bit before fixing itself and sending to the new one. I was about to ask you to reboot to verify, but sounds like HS finally sorted itself. I also retested the single device triggers you asked about above and confirmed they are working, so I suspect it was indeed this issue of HS not sending the plugins the events. I tested specifically:

                          Click image for larger version  Name:	Screen Shot 2019-01-02 at 12.21.40 PM.png Views:	1 Size:	55.5 KB ID:	1271573
                          This is not what I tested. That's why i asked you why their was two types of trigger in the hs dropdown list of triggers

                          Comment


                          • #28
                            The first event was probably never closed, which kept HS from updating the data the plugin uses. You mentioned the little chevon > wouldn't close before, so the event was probably not saved. With the earlier fix it most likely would have worked if you had toggled that open/closed.

                            On the two triggers,

                            The first one applies to any device in the Tag and contains most of the normal 'this device' triggers but fire if any Tag member matches the state
                            The second tag applies to all the tags, meaning they all (or none, or some) need to hit a particular state

                            You could fake the first triggers by using 'At least 1 tag has' in the second case, but I found that too strange for most people so called out the two ways to achieving the result separately.

                            Comment


                            • #29
                              i am sending a video to you in pm . ( from my phone , I need to install a video capture program on my pc)

                              Comment


                              • #30
                                Resolved ! + trigger fires instantly now...this smells like a release haha? . Thanks thanks bsobel

                                Cps tag link : http://download.casapiedrasoftware.i...r_override.txt

                                Comment

                                Working...
                                X