Announcement

Collapse
No announcement yet.

Device History Tab includes rendering for other tabs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Device History Tab includes rendering for other tabs

    When displaying the Device History tab for a device, it includes content for other devices such as from the Z-Wave tab below (but not specific to Z-Wave). I thought I was reading that this was addressed in the plugin. Is this something related to my browser (Chrome in this case) or a way to address this?

    Click image for larger version

Name:	2019-03-17_11-12-34.png
Views:	2
Size:	167.5 KB
ID:	1293073
    Attached Files

  • #2
    I have that problem with my own Z-Wave devices as well, and it appears to be an issue with the Z-Wave tab's HTML. I'll need to see if there's another plugin that also adds device options like mine does, but one proof point for that is that the "Device History" tab on my Insteon devices work fine with Mark Sandler's plugin tab in place, so I don't think it's my HTML causing that.

    Comment


    • #3
      It is not specific to the Z-Wave plugin. I have it also for another plugin where its tab is after the Device History tab. For other plugins where their device tab is before the Device History tab it does not show this behavior.

      Comment


      • #4
        I will add an Insteon device (Using Mark Sandler's plugin as well) and see if I run into the same.

        Comment


        • #5
          Same problem with Insteon device (Using Mark Sandler's plugin as well). See screenshot. As I mentioned before it only occurs if there is a plugin tab after the Device History tab and not if the plugin tab is before the Device History tab. Hope this helps.
          Click image for larger version

Name:	2019-03-17_15-49-01.png
Views:	1
Size:	345.5 KB
ID:	1293146

          Comment


          • #6
            You're right - I have that too, just didn't notice because it's not as obvious. I did some more digging and it appears this is caused by nested jquery tab groups. I'll need to work on rewriting my tab to NOT have a tab group inside it...

            Comment

            Working...
            X