Announcement

Collapse
No announcement yet.

Expression issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Expression issue

    Hello,

    After 2 tweeks testing, I bought this wonderful plugin tonight.

    Unfortunatly, I got some strange issue, and I tried solving it for several hours without finding any clue.

    In my heating "strategy" (big word), I need to put an expression into some virtual device :

    Click image for larger version

Name:	easy_02.JPG
Views:	1
Size:	40.3 KB
ID:	1212130

    But I got this error message (only the red line without DEBUG MODE, and the first line with DEBUG MODE) :

    Click image for larger version

Name:	easy_03.JPG
Views:	1
Size:	31.5 KB
ID:	1212131

    Any idea ?

    Thanks a lot,

    Michel
    Attached Files

  • #2
    Hi again,

    I think I'm close to the solution.

    Set <device> to 18.1

    is OK.

    But

    Set <device> to 18,1

    Gives the same error message.

    So, it seems that the Zigbee device that I need the value from gives values with a "," instead of a dot.

    I'm writing now to the JOWIHUE plugin author, but would it be a way to convert this on my own ? I can't find anywhere a list with alphanumerical functions.

    Thanks,

    Michel

    Comment


    • #3
      I changed the Window region parameter from , to .

      Now E.T. works well, but there are other problems with Jowihue.

      Thanks anyway, I guess this closes the present thread.

      Comment


      • #4
        I went back to the , (comma) decimal notation into Windows, and at my huge surprise, now things work with the Easy Trigger expression.

        Very very strange.

        Michel

        Comment


        • #5
          Hello,


          The problem I was talking about up here has come back :

          Click image for larger version

Name:	jowihue_easytrigger_01.JPG
Views:	2
Size:	14.5 KB
ID:	1195665

          It started again since an update of Jowihue plugin I just made.

          So maybe it's some coding mistake in Jowihue, but as this message comes from EasyTrigger, we must consider this could be an expression issue here...

          EDIT : if I try with some other device, for example a Z-Wave one, I got the same problem if there's a decimal, and no issue if the device's value is an integer.

          This seems to disculp Jowihue plugin, in my humble opinion.

          What do you think ?

          Thank you,

          Michel
          Last edited by Michelob; March 2nd, 2018, 01:37 PM.

          Comment


          • #6
            Hello,

            As the action SET DEVICE TO EXPRESSION doesn't work with European decimals, I wrote some very little script to fit my need.

            If it may help other people, here it is. Couldn't imagine the solution was that simple :

            Code:
            Sub Main
                 Dim DevTemp1
                 Dim DevTemp2
            
                 DevTemp1 = hs.DeviceValueEx(90)
                 DevTemp2 = hs.DeviceValueEx(96)
            
                 hs.SetDeviceValueByRef 207, DevTemp1 * 100, True
                 hs.SetDeviceValueByRef 208, DevTemp2 * 100, True
            
                 hs.Speak("Les températures de référence ont été stockées")
            
            End Sub
            Have a good night.

            Michel

            Comment

            Working...
            X