Announcement

Collapse
No announcement yet.

Toggle Device Using Dimming Light Switches

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Toggle Device Using Dimming Light Switches

    I bought this plugin mainly to toggle lights on and off using single presses of mini remotes and paddle swiches I made to trigger door sensors to function as wireless switches that look and act like normal 3-way Decora wall switches. Binary ON/OFF devices toggle great with EasyTrigger, be they Insteon or Z-wave.

    The problem I'm having is with dimmable Z-Wave switches (Homeseer and ZooZ brands).

    (a) If a switch is OFF, and if the light gets brightened at the switch itself or with the slider in the HS3 Device List, the plugin brightens the light to ON instead of turning the light OFF.

    (b) If a light is ON, and I dim the light manually as described above, it will often but not always, also brighten to ON instead of turning OFF.

    (c) A second press of the button, once it has brightened to ON, reliably turns the lights off but it forces users to wait at the switch to make sure the lights will actually toggle as expected.

    (d) If nothing has brightened or dimmed the light between toggles, the switches toggle ON and OFF perfectly.

    (e) Last and OFF toggles also work fine if no bright/dims have taken place.

    I've tried it with and without "Use closest toggle value" checked.
    Is there a way to have it to consider any dim value from 1 to 100% (however it gets set) as an ON condition so that the next toggle reliably gets thrown to OFF?
    Last edited by Panamon; October 10th, 2018, 02:34 AM.

  • #2
    Click image for larger version

Name:	2018-10-10 02_15_01-HomeSeer Web Control - Ev....png
Views:	38
Size:	65.5 KB
ID:	1252362

    Comment


    • #3
      What value has the On control/status? If On value is 100 and if you check "Use closest toggle value", then if the lights get brightened at the switch to a value > 50% then the toggle should work as you expect it, i.e the toggle action should turn it off.

      If dim value < 50%, then the toggle will turn it On.
      I don't think there is currently a way to workaround this behavior, but I'm going to think of a way to add more options to the toggle action so that it behave like you want.

      Comment


      • #4
        Originally posted by spud View Post
        What value has the On control/status? If On value is 100 and if you check "Use closest toggle value", then if the lights get brightened at the switch to a value > 50% then the toggle should work as you expect it, i.e the toggle action should turn it off.

        If dim value < 50%, then the toggle will turn it On.
        I don't think there is currently a way to workaround this behavior, but I'm going to think of a way to add more options to the toggle action so that it behave like you want.
        The screenshot just happend to have "Use closest toggle value" checked when I took it, but the lights brighten to ON even when unchecked after a local brighten.

        Hoping you can find a way to get the plugin to consider any dim values above 0% as a binary "ON", so it can know the correct next toggle should be to OFF, regardless of local dim events. It would really help me with the WAF of the toggle switches I've created and placed all over the house.

        Comment


        • #5
          in version 3.0.0.51, I have added an option to the Toggle action to be able to map one toggle value with a range of status value.
          so in your case configuring the action like in the screenshot below should solve your problem.
          please test and let me know


          Click image for larger version

Name:	togglerange.PNG
Views:	31
Size:	119.3 KB
ID:	1253944

          Comment


          • #6
            Hi Spud,
            Sorry that I just now saw this. Thank you so much!
            I will test over the weekend and report back, but it looks like exactly what was needed for dimmers to toggle properly.

            Comment


            • #7
              Hey Spud,
              I upgraded to beta version 3.0.0.51 and created a new test event, but I'm not seeing the "equivalency range start" options in "EasyTrigger: Toggle Device"
              I rebooted after installing the beta.
              Am I missing something?

              Click image for larger version

Name:	HomeSeer Web Control - Ev....png
Views:	38
Size:	44.0 KB
ID:	1255267

              Click image for larger version

Name:	Interfaces and Add Ons.png
Views:	34
Size:	96.3 KB
ID:	1255268

              Comment


              • #8
                Originally posted by Panamon View Post
                Hey Spud,
                I upgraded to beta version 3.0.0.51 and created a new test event, but I'm not seeing the "equivalency range start" options in "EasyTrigger: Toggle Device"
                I rebooted after installing the beta.
                Am I missing something?

                Click image for larger version

Name:	HomeSeer Web Control - Ev....png
Views:	38
Size:	44.0 KB
ID:	1255267

                Click image for larger version

Name:	Interfaces and Add Ons.png
Views:	34
Size:	96.3 KB
ID:	1255268
                You need to switch to advanced mode (blue bird button)

                Comment


                • #9
                  Doh!
                  Thanks!
                  I'll use it for a few days and post back.
                  First quick tests look good!

                  Comment

                  Working...
                  X