Announcement

Collapse
No announcement yet.

Buggy schedule editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jimcu
    replied
    That fixed it – thank you.

    -jim.

    Leave a comment:


  • spud
    replied
    In version 3.0.0.60 available in the beta section of the updater, I have fixed a few bugs related to the schedule editor.
    Please test and let me know.

    Leave a comment:


  • jimcu
    replied
    Same behavior if accessing locally or remotely via MyHS.

    Leave a comment:


  • jimcu
    replied
    This isn't in any way related to schedules crossing midnight – the example runs from 08:00-00:00. It just displays across midnight in the editor.

    Leave a comment:


  • drparker151
    replied
    Originally posted by spud View Post

    this is not the problem here the EasyTrigger schedules are perfectly capable of handling time ranges past midnight
    Interesting, I did not have the display issue. However, if a schedule range crossed midnight, a manual event being called with meets conditions based on being in that range would not fire. I created two schedules one ending midnight and the other starting at midnight and included both in my trigger and that worked.

    Leave a comment:


  • jimcu
    replied
    Deleting a schedule also initiates the problem, as does adding or deleting a Device Group. Seems like it goes screwy anytime the EasyTrigger Config page is redrawn, and fixed when it's refreshed.

    Leave a comment:


  • jimcu
    replied
    No problem with Edge or Firefox. Same problem with Brave browser (which, like Chrome, is built atop Chromium browser).

    Seems like refreshing the page fixes the problem. But it's consistently repeatable by creating a new Schedule, after which clicking Edit on the new schedule or an existing one will exhibit the problem.

    Leave a comment:


  • jvm
    replied
    Originally posted by spud View Post

    I have seen this problem before, but I have never been able to replicate consistently.
    Try to close completely chrome, then reopen the config page of the ET plugin. Make sure there is only one tab which has the config page open.

    Does it happen if you use another browser?
    I've had this problem before too and I recall that re-sizing the Zoom on the browser (i.e., by reducing the % zoom) made it go away.

    Leave a comment:


  • rprade
    replied
    FWIW I do not get the same results here. HomeSeer running on Windows 10, browser Safari on iPad.

    Click image for larger version  Name:	740DE876-17D8-4B2B-8CDC-B60FBD0EB940.jpeg Views:	1 Size:	54.1 KB ID:	1290322

    Leave a comment:


  • spud
    replied
    Originally posted by jimcu View Post
    Finally decided to give EasyTrigger a go, but the schedule editor ain't behavin'...

    HS3 Pro Edition 3.0.0.500 (Windows), EasyTrigger 3.0.0.56, Chrome 72.0.3626.121.

    I'm unable to create schedule segments in editor before ~13:00 (varies an hour or two); and hand-editing the string shows segments way off scale. String is [08:00;00:00]. Don't think it's related to time zone, as I'm, GMT -8:00.

    Click image for larger version

Name:	EasyTrigger.png
Views:	16
Size:	217.4 KB
ID:	1290234
    I have seen this problem before, but I have never been able to replicate consistently.
    Try to close completely chrome, then reopen the config page of the ET plugin. Make sure there is only one tab which has the config page open.

    Does it happen if you use another browser?

    Leave a comment:


  • spud
    replied
    Originally posted by drparker151 View Post
    HomeSeer does not like any time ranges going past midnight.
    this is not the problem here the EasyTrigger schedules are perfectly capable of handling time ranges past midnight

    Leave a comment:


  • drparker151
    replied
    HomeSeer does not like any time ranges going past midnight.

    Leave a comment:


  • jimcu
    started a topic Buggy schedule editor

    Buggy schedule editor

    Finally decided to give EasyTrigger a go, but the schedule editor ain't behavin'...

    HS3 Pro Edition 3.0.0.500 (Windows), EasyTrigger 3.0.0.56, Chrome 72.0.3626.121.

    I'm unable to create schedule segments in editor before ~13:00 (varies an hour or two); and hand-editing the string shows segments way off scale. String is [08:00;00:00]. Don't think it's related to time zone, as I'm, GMT -8:00.

    Click image for larger version

Name:	EasyTrigger.png
Views:	16
Size:	217.4 KB
ID:	1290234
Working...
X