Announcement

Collapse
No announcement yet.

Device String Change not triggering - missing something simple?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Device String Change not triggering - missing something simple?

    I have some blinds I'd like to also control with an on the wall zWave switch. When you press up on the switch, it sets a device labeled Floor1 Living Room (Downstairs) Right Blind Switch Central Scene to 1000 and when you press down it sets it to 2000. EasyTrigger appears to pick this up too:

    Code:
     
    Jul-05 2:08:35 PM EasyTrigger DEBUG Device 117 value changed from 2000 to 1000
    Jul-05 2:08:35 PM Z-Wave Device: Floor1 Living Room (Downstairs) Right Blind Switch Central Scene Set to 1000
    Jul-05 2:08:31 PM EasyTrigger DEBUG Device 117 value changed from 1000 to 2000
    Jul-05 2:08:31 PM Z-Wave Device: Floor1 Living Room (Downstairs) Right Blind Switch Central Scene Set to 2000
    (Yes, the labels are verbose - if I can remember how to rename rooms I'll clean things up; but an option to just work by divice ID would also be awesome)

    So based on that I have set this rule, but it doesn't seem to activate:

    The device in the If section that is cut off is Floor1 Living Room (Downstairs) Right Blind Switch Central Scene and the device in the Then section that is cut off is Floor1 Living Room (Downstairs) Right Blind Control Multilevel

    And as an FYI if I manually trigger the device from the device view in Homeseer this is what I see in the log:

    Code:
     
    Jul-05 2:12:05 PM EasyTrigger DEBUG Device 114 value changed from 99 to 0
    Jul-05 2:12:05 PM Z-Wave Device: Floor1 Living Room (Downstairs) Right Blind Control Multilevel Set to 0
    Jul-05 2:12:05 PM Device Control Device: Floor1 Living Room (Downstairs) Right Blind Control Multilevel to Off (0) by/from: CAPI Control Handler
    Jul-05 2:11:55 PM EasyTrigger DEBUG Device 114 value changed from 0 to 99
    Jul-05 2:11:55 PM Z-Wave Device: Floor1 Living Room (Downstairs) Right Blind Control Multilevel Set to 99
    Jul-05 2:11:54 PM Device Control Device: Floor1 Living Room (Downstairs) Right Blind Control Multilevel to On (99) by/from: CAPI Control Handler
    This should be pretty straightforward, no? Push up on the zWave switch and the value of it gets set to 1000, so then set the the other device to On or 99 and the blind goes up. What am I missing?
    Attached Files

  • #2
    Why do you try to use a "Device string change" trigger?
    Unless I missed something you should use the regular "Device value changes and becomes" trigger.

    Comment


    • #3
      Actually, both are incorrect. For a central scene device the Trigger is “This device had its value set to...”. The Action in the first post is also wrong. You would just control a device, not use Easy Trigger.
      Randy Prade
      Aurora, CO
      Prades.net

      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

      Comment

      Working...
      X