Announcement

Collapse
No announcement yet.

No Trigger?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No Trigger?

    Hey Spud

    I know you have been asked this a million times but I just cant figure it out...Why am I not getting a Trigger for the below event.
    Click image for larger version

Name:	Annotation 2019-08-02 154204.png
Views:	79
Size:	42.1 KB
ID:	1318970


  • #2
    I also get this warning/error which I expect is all related to me not having it set up correctly
    Warning Exception attempting to evaluate a plug-in trigger in event HVAC Heating Off Once At Target Tempeture: Object reference not set to an instance of an object.
    Click image for larger version

Name:	Annotation 2019-08-02 161153.png
Views:	79
Size:	40.1 KB
ID:	1318972

    Comment


    • #3
      On your first screenshot your trigger use "=" to compare temperatures, if those temperatures are decimal values it is unlikely that they are ever exactly equal. So I would use <= or >= instead.
      Also for the comparison trigger to fire, you need to be aware that the condition needs to becomes true. For example if the trigger is
      "If A < B"
      then A needs to be first >= B, then A or B needs to change so that A becomes < B

      The warning on your second screenshot is quite generic. I would try to recreate the event from scratch. If the problem persist look at the logs to see if you get more information

      Comment


      • #4
        Thank You That Helped!

        Comment


        • #5
          Well it helped with somethings...
          My below still wont trigger - I've tried to make it as simple as possible to trigger but it just wont, Any ideas?
          Click image for larger version

Name:	Annotation 2019-08-06 174219.png
Views:	41
Size:	243.7 KB
ID:	1319424

          Comment


          • #6
            How are the "Average Temp" and "Air Con Control" device values set?
            In EasyTrigger config page set the log level to Debug to check if the plugin is notified when those device values change

            To troubleshoot you can start by using virtual devices in your trigger and play with those to make sure you understand how the comparison trigger works.

            Also your IF and OR IF look exactly the same, so only one of them should be enough

            Comment

            Working...
            X